From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-2.3 required=3.0 tests=DKIMWL_WL_HIGH,DKIM_SIGNED, DKIM_VALID,HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SPF_HELO_NONE, SPF_PASS,USER_AGENT_SANE_1 autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 8A3C0C2BB1D for ; Tue, 17 Mar 2020 21:01:38 +0000 (UTC) Received: from bombadil.infradead.org (bombadil.infradead.org [198.137.202.133]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mail.kernel.org (Postfix) with ESMTPS id 57DF22051A for ; Tue, 17 Mar 2020 21:01:38 +0000 (UTC) Authentication-Results: mail.kernel.org; dkim=pass (2048-bit key) header.d=lists.infradead.org header.i=@lists.infradead.org header.b="TYW5hFk2" DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 57DF22051A Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=pengutronix.de Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=linux-amlogic-bounces+linux-amlogic=archiver.kernel.org@lists.infradead.org DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=lists.infradead.org; s=bombadil.20170209; h=Sender: Content-Transfer-Encoding:Content-Type:Cc:List-Subscribe:List-Help:List-Post: List-Archive:List-Unsubscribe:List-Id:In-Reply-To:MIME-Version:References: Message-ID:Subject:To:From:Date:Reply-To:Content-ID:Content-Description: Resent-Date:Resent-From:Resent-Sender:Resent-To:Resent-Cc:Resent-Message-ID: List-Owner; bh=UuWnwcvfEShXjMfHaCllXbfFAiiA7vQnVMVeRnfAOrQ=; b=TYW5hFk2DuzZCW 2Cv2hMkbuOO75u93ymdX7AolOleZN26zYETSbAyN0jmApXVSEemb7hWaABRxZ0A2jL+3rQzdP4YyI tC9PC0WDrZyrqomPIxmR9BiBuxOhp6CRdFYa4HdImdFX7e7uL+Pcf2+Yonuows5O+eJG/jdccTF6k C0gLfuVXJc0VreG3vhwubBDmOtJEkKaWYaRc5G+jEecR8gn/lg63vLVpkVp/bQRWaL1iB66S1P/jZ DO78CEoRIF49jvFHl9k6sNtMtkzMnq2imOj0TVnVHGGfQCWr9pg6L4slod5tJvWYIF7b4tDr2cj8g EzWXxYbCyX4UPXQXR9CA==; Received: from localhost ([127.0.0.1] helo=bombadil.infradead.org) by bombadil.infradead.org with esmtp (Exim 4.92.3 #3 (Red Hat Linux)) id 1jEJL8-0007Yx-JM; Tue, 17 Mar 2020 21:01:30 +0000 Received: from metis.ext.pengutronix.de ([2001:67c:670:201:290:27ff:fe1d:cc33]) by bombadil.infradead.org with esmtps (Exim 4.92.3 #3 (Red Hat Linux)) id 1jEJL5-0007Xc-Mj for linux-amlogic@lists.infradead.org; Tue, 17 Mar 2020 21:01:29 +0000 Received: from pty.hi.pengutronix.de ([2001:67c:670:100:1d::c5]) by metis.ext.pengutronix.de with esmtps (TLS1.2:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1jEJKW-00039f-Bg; Tue, 17 Mar 2020 22:00:52 +0100 Received: from ukl by pty.hi.pengutronix.de with local (Exim 4.89) (envelope-from ) id 1jEJKM-0003eU-V8; Tue, 17 Mar 2020 22:00:42 +0100 Date: Tue, 17 Mar 2020 22:00:42 +0100 From: Uwe =?iso-8859-1?Q?Kleine-K=F6nig?= To: Thierry Reding Subject: Re: [RFC PATCH 1/7] pwm: rename the PWM_POLARITY_INVERSED enum Message-ID: <20200317210042.ryrof3amr7fxp4w5@pengutronix.de> References: <20200317123231.2843297-1-oleksandr.suvorov@toradex.com> <20200317123231.2843297-2-oleksandr.suvorov@toradex.com> <20200317174043.GA1464607@ulmo> MIME-Version: 1.0 Content-Disposition: inline In-Reply-To: <20200317174043.GA1464607@ulmo> User-Agent: NeoMutt/20170113 (1.7.2) X-SA-Exim-Connect-IP: 2001:67c:670:100:1d::c5 X-SA-Exim-Mail-From: ukl@pengutronix.de X-SA-Exim-Scanned: No (on metis.ext.pengutronix.de); SAEximRunCond expanded to false X-PTX-Original-Recipient: linux-amlogic@lists.infradead.org X-CRM114-Version: 20100106-BlameMichelson ( TRE 0.8.0 (BSD) ) MR-646709E3 X-CRM114-CacheID: sfid-20200317_140127_741216_AE938C85 X-CRM114-Status: GOOD ( 16.62 ) X-BeenThere: linux-amlogic@lists.infradead.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Cc: Alexandre Belloni , Heiko Stuebner , linux-pwm@vger.kernel.org, Marcel Ziswiler , linux-kernel@vger.kernel.org, Oleksandr Suvorov , Laurent Pinchart , linux-riscv@lists.infradead.org, Fabio Estevam , Florian Fainelli , Kevin Hilman , Chen-Yu Tsai , linux-rockchip@lists.infradead.org, Ludovic Desroches , bcm-kernel-feedback-list@broadcom.com, NXP Linux Team , devicetree@vger.kernel.org, Ray Jui , Sascha Hauer , Maxime Ripard , Philippe Schenker , Paul Barker , Paul Walmsley , linux-amlogic@lists.infradead.org, linux-arm-kernel@lists.infradead.org, Paul Cercueil , Igor Opaniuk , Scott Branden , Nicolas Ferre , Tony Prisk , Palmer Dabbelt , Pengutronix Kernel Team , Shawn Guo , Claudiu Beznea Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Sender: "linux-amlogic" Errors-To: linux-amlogic-bounces+linux-amlogic=archiver.kernel.org@lists.infradead.org Hello, On Tue, Mar 17, 2020 at 06:40:43PM +0100, Thierry Reding wrote: > On Tue, Mar 17, 2020 at 02:32:25PM +0200, Oleksandr Suvorov wrote: > > The polarity enum definition PWM_POLARITY_INVERSED is misspelled. > > Rename it to PWM_POLARITY_INVERTED. > = > It isn't misspelled. "inversed" is a synonym for "inverted". Both > spellings are correct. Some time ago I stumbled about "inversed", too. My spell checker doesn't know it and I checked some dictionaries and none of them knew that word: https://www.lexico.com/search?utf8=3D%E2%9C%93&filter=3Ddictionary&dictiona= ry=3Den&query=3Dinversed https://de.pons.com/%C3%BCbersetzung/englisch-deutsch/inversed https://dictionary.cambridge.org/spellcheck/english-german/?q=3Dinversed https://en.wiktionary.org/wiki/inverse#Verb mentions "inverse" as a verb having "inversed" as past participle. Having said this I think (independent of the question if "inversed" exists) using two similar terms for the same thing just results in confusion. I hit that in the past already and I like it being addressed. > And as you noted in the cover letter, there's a conflict between the > macro defined in dt-bindings/pwm/pwm.txt. If they end up being included > in the wrong order you'll get a compile error. There are also other symbols that exist twice (GPIO_ACTIVE_HIGH was the first to come to my mind). I'm not aware of any problems related to these. What am I missing? = > The enum was named this way on purpose to make it separate from the > definition for the DT bindings. Then please let's make it different by picking a different prefix or something like that. > Note that DT bindings are an ABI and can > never change, whereas the enum pwm_polarity is part of a Linux internal > API and doesn't have the same restrictions as an ABI. I thought only binary device trees (dtb) are supposed to be ABI. Best regards Uwe -- = Pengutronix e.K. | Uwe Kleine-K=F6nig | Industrial Linux Solutions | https://www.pengutronix.de/ | _______________________________________________ linux-amlogic mailing list linux-amlogic@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-amlogic