mirror of https://lore.kernel.org/linux-amlogic/
 help / color / mirror / Atom feed
From: Marek Szyprowski <m.szyprowski@samsung.com>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	Neil Armstrong <narmstrong@baylibre.com>,
	linux-gpio@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
	linux-amlogic@lists.infradead.org, linux-kernel@vger.kernel.org
Cc: Linus Walleij <linus.walleij@linaro.org>,
	Kevin Hilman <khilman@baylibre.com>,
	Jerome Brunet <jbrunet@baylibre.com>,
	Martin Blumenstingl <martin.blumenstingl@googlemail.com>,
	Andrew Lunn <andrew@lunn.ch>,
	Gregory Clement <gregory.clement@bootlin.com>,
	Sebastian Hesselbarth <sebastian.hesselbarth@gmail.com>,
	Bartosz Golaszewski <brgl@bgdev.pl>
Subject: Re: [PATCH v5 0/6] gpiolib: more helpers and fwnode conversion
Date: Thu, 14 Apr 2022 22:28:41 +0200	[thread overview]
Message-ID: <2f0f0bf4-ceb7-b226-dd76-aea64ee517c4@samsung.com> (raw)
In-Reply-To: <20220414190242.22178-1-andriy.shevchenko@linux.intel.com>

Hi Andy,

On 14.04.2022 21:02, Andy Shevchenko wrote:
> This is a spin-off (*) of the previous work of switching GPIO library
> to use fwnode instead of of_node. Here we introduce a couple of
> a new macro helpers, which allows to switch some of the drivers
> to use fwnode and partially fwnode APIs. As a result of this cleanup
> a few drivers switched to use GPIO fwnode instead of of_node.
>
> *) it's subset of it with a new (patch 1) helper.
>
> Marek, Martin, can you give this a try?
> This requires at least two patches for GPIO library to be applied.

I've applied patch #1 and #6 on top of linux next-20220413 with commit 
88834c75cae5 ("pinctrl: meson: Replace custom code by 
gpiochip_node_count() call") reverted. All my Meson-based test boards 
(Odroid C4, N2, Khadas VIM3/3l) work fine now. Thanks! Feel free to add:

Tested-by: Marek Szyprowski <m.szyprowski@samsung.com>

> Bart, Linus, I can take it thru my tree with an immutable branch if
> it's the way you prefer, otherwise please suggest on how to proceed.
>
> Changelog v5:
> - dropped tested patches (this series based on them, though)
> - introduced a new helper (thanks Marek and Martin for reporting an issue)
> - redone Armada and Meson code using newly introduced helper
>
> Changelog v4:
> - fixed compilation of the Samsung pin control drivers (LKP)
> - explained in the commit message why namespacing is good for meson defs
> - added tag to one of meson patches (Neil)
>
> Changelog v3:
> - moved count initialization to the definition in patch 2 (Geert)
> - replaced of_args by args, used %pfwP in patch 7 (Geert)
> - fixed kernel doc warning in patch 7
> - added tags to patches 1, 2, 6, and 7 (Geert)
> - added tag to patch 4 (Fabien)
> - renamed MREG to MESON_REG in patch 9 (Neil)
> - added tag to patch 10 (Neil)
> - used --base for cover-letter
>
> Changelog v2:
> - properly based, so kbuild bot may test it (LKP)
> - fixed typo in the macro (Geert)
> - split to two macro helpers and rename the gpiochip_count()
> - tagged one of stm32 and one of meson patches (Fabien, Neil)
> - unified previously standalone armada patch
> - due to above rewrote the armada patch from v1 completely (Sergey)
> - added a lot of a new patches
> - compile tested all of them on x86
>
> Andy Shevchenko (6):
>    gpiolib: Introduce a helper to get first GPIO controller node
>    pinctrl: armada-37xx: Switch to use fwnode instead of of_node
>    pinctrl: armada-37xx: Reuse GPIO fwnode in
>      armada_37xx_irqchip_register()
>    pinctrl: meson: Rename REG_* to MESON_REG_*
>    pinctrl: meson: Enable COMPILE_TEST
>    pinctrl: meson: Replace custom code by gpiochip_node_count() call
>
>   drivers/pinctrl/meson/Kconfig               |  2 +-
>   drivers/pinctrl/meson/pinctrl-meson.c       | 52 ++++++++++-----------
>   drivers/pinctrl/meson/pinctrl-meson.h       | 28 +++++------
>   drivers/pinctrl/mvebu/pinctrl-armada-37xx.c | 34 ++++----------
>   include/linux/gpio/driver.h                 | 10 ++++
>   5 files changed, 59 insertions(+), 67 deletions(-)
>
Best regards
-- 
Marek Szyprowski, PhD
Samsung R&D Institute Poland


_______________________________________________
linux-amlogic mailing list
linux-amlogic@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-amlogic

  parent reply	other threads:[~2022-04-14 20:29 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <CGME20220414190251eucas1p1ef520fa995057550fa533eb34a02ae63@eucas1p1.samsung.com>
2022-04-14 19:02 ` Andy Shevchenko
2022-04-14 19:02   ` [PATCH v5 1/6] gpiolib: Introduce a helper to get first GPIO controller node Andy Shevchenko
2022-04-25 18:52     ` Bartosz Golaszewski
2022-04-26 10:29       ` Andy Shevchenko
2022-05-05 13:05         ` Bartosz Golaszewski
2022-05-05 13:17           ` Andy Shevchenko
2022-04-14 19:02   ` [PATCH v5 2/6] pinctrl: armada-37xx: Switch to use fwnode instead of of_node Andy Shevchenko
2022-04-14 19:02   ` [PATCH v5 3/6] pinctrl: armada-37xx: Reuse GPIO fwnode in armada_37xx_irqchip_register() Andy Shevchenko
2022-04-14 19:02   ` [PATCH v5 4/6] pinctrl: meson: Rename REG_* to MESON_REG_* Andy Shevchenko
2022-04-14 19:02   ` [PATCH v5 5/6] pinctrl: meson: Enable COMPILE_TEST Andy Shevchenko
2022-04-14 19:02   ` [PATCH v5 6/6] pinctrl: meson: Replace custom code by gpiochip_node_count() call Andy Shevchenko
2022-04-14 20:28   ` Marek Szyprowski [this message]
2022-04-19 21:51   ` [PATCH v5 0/6] gpiolib: more helpers and fwnode conversion Linus Walleij

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2f0f0bf4-ceb7-b226-dd76-aea64ee517c4@samsung.com \
    --to=m.szyprowski@samsung.com \
    --cc=andrew@lunn.ch \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=brgl@bgdev.pl \
    --cc=gregory.clement@bootlin.com \
    --cc=jbrunet@baylibre.com \
    --cc=khilman@baylibre.com \
    --cc=linus.walleij@linaro.org \
    --cc=linux-amlogic@lists.infradead.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=martin.blumenstingl@googlemail.com \
    --cc=narmstrong@baylibre.com \
    --cc=sebastian.hesselbarth@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®