From: Liang Yang <liang.yang@amlogic.com>
To: Arseniy Krasnov <avkrasnov@sberdevices.ru>,
Miquel Raynal <miquel.raynal@bootlin.com>,
Richard Weinberger <richard@nod.at>,
Vignesh Raghavendra <vigneshr@ti.com>,
Neil Armstrong <neil.armstrong@linaro.org>,
Kevin Hilman <khilman@baylibre.com>,
Jerome Brunet <jbrunet@baylibre.com>,
Martin Blumenstingl <martin.blumenstingl@googlemail.com>
Cc: oxffffaa@gmail.com, kernel@sberdevices.ru,
linux-mtd@lists.infradead.org,
linux-arm-kernel@lists.infradead.org,
linux-amlogic@lists.infradead.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v1] mtd: rawnand: meson: remove unneeded bitwise OR with zeroes
Date: Thu, 8 Jun 2023 11:23:46 +0800 [thread overview]
Message-ID: <429589f6-d946-9bc9-d54e-e892d513a91b@amlogic.com> (raw)
In-Reply-To: <9319a8f6-3774-0dc8-2262-8033f8016a50@sberdevices.ru>
On 2023/6/8 5:18, Arseniy Krasnov wrote:
> [ EXTERNAL EMAIL ]
>
> Hi again Miquel, Liang!
>
> What do You think about this patch?
>
> Thanks, Arseniy
>
> On 05.06.2023 22:15, Arseniy Krasnov wrote:
>> Both operations have no effect.
>>
>> Signed-off-by: Arseniy Krasnov <AVKrasnov@sberdevices.ru>
>> ---
>> drivers/mtd/nand/raw/meson_nand.c | 4 ++--
>> 1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/mtd/nand/raw/meson_nand.c b/drivers/mtd/nand/raw/meson_nand.c
>> index 074e14225c06..50d3110ad321 100644
>> --- a/drivers/mtd/nand/raw/meson_nand.c
>> +++ b/drivers/mtd/nand/raw/meson_nand.c
>> @@ -595,12 +595,12 @@ static int meson_nfc_rw_cmd_prepare_and_execute(struct nand_chip *nand,
>> cmd0 = in ? NAND_CMD_READ0 : NAND_CMD_SEQIN;
>> nfc->cmdfifo.rw.cmd0 = cs | NFC_CMD_CLE | cmd0;
>>
>> - addrs[0] = cs | NFC_CMD_ALE | 0;
>> + addrs[0] = cs | NFC_CMD_ALE;
>> if (mtd->writesize <= 512) {
>> cmd_num--;
>> row_start = 1;
>> } else {
>> - addrs[1] = cs | NFC_CMD_ALE | 0;
>> + addrs[1] = cs | NFC_CMD_ALE;
>> row_start = 2;
>> }
Hi Arseniy and Miquel,
The two zeros indcates two column address. maybe we could use the micro
"COLUMN_ADDR_0" and "COLUMN_ADDR_1" to keep the nfc command format "CE |
ALE | addr" consistency and also let function
"meson_nfc_rw_cmd_prepare_and_execute" be more readable.
Thanks,
Liang
>>
_______________________________________________
linux-amlogic mailing list
linux-amlogic@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-amlogic
next prev parent reply other threads:[~2023-06-08 3:24 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-06-05 19:15 Arseniy Krasnov
2023-06-07 21:18 ` Arseniy Krasnov
2023-06-08 3:23 ` Liang Yang [this message]
2023-06-08 4:37 ` Arseniy Krasnov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=429589f6-d946-9bc9-d54e-e892d513a91b@amlogic.com \
--to=liang.yang@amlogic.com \
--cc=avkrasnov@sberdevices.ru \
--cc=jbrunet@baylibre.com \
--cc=kernel@sberdevices.ru \
--cc=khilman@baylibre.com \
--cc=linux-amlogic@lists.infradead.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mtd@lists.infradead.org \
--cc=martin.blumenstingl@googlemail.com \
--cc=miquel.raynal@bootlin.com \
--cc=neil.armstrong@linaro.org \
--cc=oxffffaa@gmail.com \
--cc=richard@nod.at \
--cc=vigneshr@ti.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®