From: Jerome Brunet <jbrunet@baylibre.com>
To: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
Cc: Kevin Hilman <khilman@baylibre.com>,
devicetree@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-amlogic@lists.infradead.org
Subject: Re: [PATCH] arm64: dts: meson: fix g12a buses
Date: Thu, 17 Jan 2019 21:39:04 +0100 [thread overview]
Message-ID: <ba1f56258e7873041a0f75996e376170563c9e6e.camel@baylibre.com> (raw)
In-Reply-To: <CAFBinCDhryOWHmRKp7GhWp2O+NpJziEgHoUE4HKVitTPDMrrBQ@mail.gmail.com>
On Thu, 2019-01-17 at 21:27 +0100, Martin Blumenstingl wrote:
> OK, but we had incorrect documentation in the past. did you check this
> with someone from Amlogic?
>
> I'm curious because there seem to be two different approaches here:
> 1) hiubus name and offsets are being fixed within this patch
> 2) aobus is being dropped here and re-introduced with a different name later
> on
>
because hiu exist and aobus does not, for which both the name and size was
wrong
> approach 1) can also be used for the "rti" region (at least in my
> opinion, the patch doesn't explain why it can't be done):
THe patch remove aobus (instead of fixing name and size) because, of the
multiple region documented covered by this 'made region', I did not anticipate
which one will be required and I did not want to add them all.
Better to add them as needed, which is want I done for pinctrl as you pointed
out
> rename "aobus" to "rti" and change the size to either 0x1000 or 0xb000
> (both values can be found in mesong12a.dtsi from
> buildroot_openlinux_kernel_4.9_fbdev_20180706)
RTI is added here:
https://lkml.kernel.org/r/20190117103151.3349-1-jbrunet@baylibre.com
I don't really understand the problem ? result is the same
_______________________________________________
linux-amlogic mailing list
linux-amlogic@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-amlogic
next prev parent reply other threads:[~2019-01-17 21:06 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-01-16 16:52 Jerome Brunet
2019-01-17 19:55 ` Kevin Hilman
2019-01-17 20:02 ` Kevin Hilman
2019-01-17 20:03 ` Martin Blumenstingl
2019-01-17 20:12 ` Jerome Brunet
2019-01-17 20:27 ` Martin Blumenstingl
2019-01-17 20:39 ` Jerome Brunet [this message]
2019-01-17 21:20 ` Martin Blumenstingl
2019-01-17 21:45 ` Jerome Brunet
2019-01-17 22:42 ` Martin Blumenstingl
2019-01-17 23:03 ` Jerome Brunet
2019-01-18 18:09 ` Jianxin Pan
2019-01-18 21:06 ` Jerome Brunet
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ba1f56258e7873041a0f75996e376170563c9e6e.camel@baylibre.com \
--to=jbrunet@baylibre.com \
--cc=devicetree@vger.kernel.org \
--cc=khilman@baylibre.com \
--cc=linux-amlogic@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=martin.blumenstingl@googlemail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®