mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Chen, Kenneth W" <kenneth.w.chen@intel.com>
To: "'Benjamin LaHaise'" <bcrl@kvack.org>
Cc: "'Zach Brown'" <zach.brown@oracle.com>,
	"'Suparna Bhattacharya'" <suparna@in.ibm.com>,
	"Lahaise, Benjamin C" <benjamin.c.lahaise@intel.com>,
	<linux-kernel@vger.kernel.org>,
	"'linux-aio'" <linux-aio@kvack.org>
Subject: RE: [patch] clarify AIO_EVENTS_OFFSET constant
Date: Fri, 13 Oct 2006 13:38:01 -0700	[thread overview]
Message-ID: <000501c6ef07$79c1c770$ff0da8c0@amr.corp.intel.com> (raw)
In-Reply-To: <20061013142257.GJ4141@kvack.org>

Benjamin LaHaise wrote on Friday, October 13, 2006 7:23 AM
> On Thu, Oct 12, 2006 at 05:00:24PM -0700, Chen, Kenneth W wrote:
> > A clean up patch: I think it is a lot easier to read AIO_EVENTS_OFFSET
> > as an offset because of aio_ring at the beginning of a head page, instead
> > of doing arithmetic of (event on 2nd page - event on 1st page).
> 
> Nak.  Your change fails if aio_ring is not an exact multiple of the 
> io_event size due to rounding errors, while the original code rounds 
> correctly.


Yeah, neither form is bullet proof, even the original one will break down
when io_event size is not in power of 2.  The good news is that no where
near in sight that these two data structures size will change.

To make it a real bullet proof, it should be something like the following:

#define AIO_EVENTS_OFFSET       ((sizeof(struct aio_ring) +             \
                                  sizeof(struct io_event) - 1 ) /       \
                                  sizeof(struct io_event))


      reply	other threads:[~2006-10-13 20:38 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-10-13  0:00 Chen, Kenneth W
2006-10-13 14:22 ` Benjamin LaHaise
2006-10-13 20:38   ` Chen, Kenneth W [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='000501c6ef07$79c1c770$ff0da8c0@amr.corp.intel.com' \
    --to=kenneth.w.chen@intel.com \
    --cc=bcrl@kvack.org \
    --cc=benjamin.c.lahaise@intel.com \
    --cc=linux-aio@kvack.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=suparna@in.ibm.com \
    --cc=zach.brown@oracle.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®