From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751378Ab0IAERF (ORCPT ); Wed, 1 Sep 2010 00:17:05 -0400 Received: from sm-d311v.smileserver.ne.jp ([203.211.202.206]:18610 "EHLO sm-d311v.smileserver.ne.jp" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750779Ab0IAERC (ORCPT ); Wed, 1 Sep 2010 00:17:02 -0400 Message-ID: <000b01cb498c$86736670$66f8800a@maildom.okisemi.com> From: "Masayuki Ohtake" To: "Joe Perches" Cc: "Jean Delvare \(PC drivers, core\)" , "Ben Dooks \(embedded platforms\)" , "Crane Cai" , "Samuel Ortiz" , "Linus Walleij" , "Ralf Baechle" , "srinidhi kasagar" , , , "Wang Yong Y\"" , "Wang Qi\"" , "Andrew\"" , , "Tomoya MORINAGA" , "Arnd Bergmann" References: <4C7DB9CF.5000905@dsn.okisemi.com> <1283309032.1797.123.camel@Joe-Laptop> Subject: Re: [MeeGo-Dev][PATCH] Topcliff: Update PCH_I2C driver to 2.6.35 Date: Wed, 1 Sep 2010 13:16:54 +0900 X-Priority: 3 X-MSMail-Priority: Normal X-Mailer: Microsoft Outlook Express 6.00.2800.1983 X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1983 X-Hosting-Pf: 0 X-NAI-Spam-Score: 1 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Joe, Thank you for your comments. We will update. Thanks, Ohtake(OKISemi) ----- Original Message ----- From: "Joe Perches" To: "Masayuki Ohtak" Cc: "Jean Delvare (PC drivers, core)" ; "Ben Dooks (embedded platforms)" ; "Crane Cai" ; "Samuel Ortiz" ; "Linus Walleij" ; "Ralf Baechle" ; "srinidhi kasagar" ; ; ; "Wang Yong Y"" ; "Wang Qi"" ; "Andrew"" ; ; "Tomoya MORINAGA" ; "Arnd Bergmann" Sent: Wednesday, September 01, 2010 11:43 AM Subject: Re: [MeeGo-Dev][PATCH] Topcliff: Update PCH_I2C driver to 2.6.35 > On Wed, 2010-09-01 at 11:26 +0900, Masayuki Ohtak wrote: > > I2C driver of Topcliff PCH > > +++ b/drivers/i2c/busses/i2c-pch.c > [] > > +static void pch_init(struct i2c_algo_pch_data *adap) > [] > > + if (pch_i2c_speed == FAST_MODE_CLK) { > > + reg_value |= FAST_MODE_EN; > > + dev_dbg(adap->pch_adapter.dev.parent, "Fast mode enabled\n"); > > + } > > Just a suggestion below, ignore it at your pleasure... > > These dev_ calls might be easier to read if you had > some #defines like: > > #define pch_dbg(adap, fmt, arg...) \ > dev_dbg(adap->pch_adapter.dev.parent, fmt, ##arg) > #define pch_err(adap, fmt, arg...) \ > dev_err(adap->pch_adapter.dev.parent, fmt, ##arg) > #define pch_info(adap, fmt, arg...) \ > dev_info(adap->pch_adapter.dev.parent, fmt, ##arg) > > then the last dev_dbg becomes: > > pch_dbg(adap, "Fast mode enabled\n"); > > Many modules use similar wrapper #defines. > > > + dev_dbg(adap->pch_adapter.dev.parent, > > + "%s: I2CCTL=%x pch_i2cbc=%x pch_i2ctmr=%x Enable interrupts\n", > > + __func__, ioread32(p + PCH_I2CCTL), > > + pch_i2cbc, pch_i2ctmr); > > pch_dbg(adap, etc...) > > etc. > > cheers, Joe >