From: Jingoo Han <jg1.han@samsung.com>
To: "'Anton Vorontsov'" <anton@enomsg.org>
Cc: "'David Woodhouse'" <dwmw2@infradead.org>,
linux-kernel@vger.kernel.org,
"'Dan Carpenter'" <dan.carpenter@oracle.com>,
"'Joe Perches'" <joe@perches.com>,
"'Greg Kroah-Hartman'" <gregkh@linuxfoundation.org>,
"'Andrew Morton'" <akpm@linux-foundation.org>,
"'Mark Brown'" <broonie@kernel.org>,
"'Jingoo Han'" <jg1.han@samsung.com>
Subject: Re: [PATCH 33/35] power: use dev_get_platdata()
Date: Wed, 28 Aug 2013 11:19:43 +0900 [thread overview]
Message-ID: <002d01cea395$0ef33ec0$2cd9bc40$%han@samsung.com> (raw)
In-Reply-To: <20130828015834.GH10506@lizard>
On Wednesday, August 28, 2013 10:59 AM, Anton Vorontsov wrote:
> On Tue, Aug 13, 2013 at 12:00:39PM +0300, Dan Carpenter wrote:
> > > > > Use the wrapper function for retrieving the platform data instead of
> > > > > accessing dev->platform_data directly.
> > > >
> > > > Um.. what is the benefit or rationale of this patch?
> > >
> > > CC'ed Joe Perches, Dan Carpenter
> > >
> > > Hi Anton Vorontsov,
> > >
> > > Usually, using the wrapper function makes the code simpler.
> > > Also, it make the code more readable.
> >
> > Since people are asking my opinion, then yes using
> > dev_get_platdata() as intended is better than open coding. It's a
> > coding standard thing.
>
> I don't see any immediate benefit of applying this patch... It does not
> fix anything now or in the near future (or we are about to add something
> into dev_get_platdata() wrapper, or get rid of dev.platform_data member?
> Any plans for this? Then it should be in the commit message.)
CC'ed Greg Kroah-Hartman, Andrew Morton, Mark Brown
The benefit is that this wrapper function makes the code simpler and
enhances readability. I don't know why you disagree. :(
Also, this is a cosmetic change which does not have harmful effect.
There is no special plan.
I just want to make the best use of this wrapper function in order to
enhance readability and make the code simpler.
>
> Without any plans to actually use the wrapper the patch is just a churn
> [that might result into patch conflicts that I'll have to deal with], so
> I'll refrain from applying it.
Um, if you want, I will send v2 patch re-based on the latest git tree.
Please, consider this patch positively. :-)
Thank you.
Best regards,
Jingoo Han
next prev parent reply other threads:[~2013-08-28 2:19 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-07-30 8:19 Jingoo Han
2013-08-09 22:04 ` Anton Vorontsov
2013-08-12 0:22 ` Jingoo Han
2013-08-13 9:00 ` Dan Carpenter
2013-08-28 1:58 ` Anton Vorontsov
2013-08-28 2:19 ` Jingoo Han [this message]
2013-08-28 8:36 ` Dan Carpenter
2013-08-29 0:25 ` Jingoo Han
2013-08-29 1:18 ` Anton Vorontsov
2013-08-29 2:07 ` 'Greg Kroah-Hartman'
2013-08-29 2:18 ` Jingoo Han
2013-08-29 3:07 ` Anton Vorontsov
2013-08-29 10:41 ` Mark Brown
2013-08-29 2:14 ` Jingoo Han
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to='002d01cea395$0ef33ec0$2cd9bc40$%han@samsung.com' \
--to=jg1.han@samsung.com \
--cc=akpm@linux-foundation.org \
--cc=anton@enomsg.org \
--cc=broonie@kernel.org \
--cc=dan.carpenter@oracle.com \
--cc=dwmw2@infradead.org \
--cc=gregkh@linuxfoundation.org \
--cc=joe@perches.com \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome