mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Kukjin Kim <kgene.kim@samsung.com>
To: "'Kyungmin Park'" <kmpark@infradead.org>,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org
Cc: jy0922.shim@samsung.com, m.szyprowski@samsung.com, ben-linux@fluff.org
Subject: RE: [PATCH 1/3] ARM: Samsung S5P: Move the common Samsung S5P series GPIO level type
Date: Mon, 30 Aug 2010 21:01:15 +0900	[thread overview]
Message-ID: <006201cb483b$0e1727e0$2a4577a0$%kim@samsung.com> (raw)
In-Reply-To: <20100830114708.GA13140@july>

Kyungmin Park wrote:
> 
> From: Kyungmin Park <kyungmin.park@samsung.com>
> 
> Samsung S5P series has common level type. It's different from S3C series.
> 
> Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com>
> ---
>  arch/arm/plat-samsung/include/plat/gpio-core.h |    6 ++++++
>  1 files changed, 6 insertions(+), 0 deletions(-)
> 
> diff --git a/arch/arm/plat-samsung/include/plat/gpio-core.h
b/arch/arm/plat-
> samsung/include/plat/gpio-core.h
> index e358c7d..c8681e0 100644
> --- a/arch/arm/plat-samsung/include/plat/gpio-core.h
> +++ b/arch/arm/plat-samsung/include/plat/gpio-core.h
> @@ -14,6 +14,12 @@
>  #define GPIOCON_OFF	(0x00)
>  #define GPIODAT_OFF	(0x04)
> 
> +#define S5P_GPIO_LEVEL_LOW		(0x00)
> +#define S5P_GPIO_LEVEL_HIGH		(0x01)
> +#define S5P_GPIO_EDGE_FALLING		(0x02)
> +#define S5P_GPIO_EDGE_RISING		(0x03)
> +#define S5P_GPIO_EDGE_BOTH		(0x04)

Why should we change the name of definition from S5P_EXTINT_XXX?
If we use that, we don't need to change other files.

> +
>  #define con_4bit_shift(__off) ((__off) * 4)
> 
>  /* Define the core gpiolib support functions that the s3c platforms may
> --

Thanks.

Best regards,
Kgene.
--
Kukjin Kim <kgene.kim@samsung.com>, Senior Engineer,
SW Solution Development Team, Samsung Electronics Co., Ltd.


  parent reply	other threads:[~2010-08-30 12:01 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-08-30 11:47 Kyungmin Park
2010-08-30 11:59 ` Sergei Shtylyov
2010-08-30 12:01 ` Kukjin Kim [this message]
2010-08-30 13:35   ` Kyungmin Park
2010-09-01  0:36     ` Kukjin Kim

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='006201cb483b$0e1727e0$2a4577a0$%kim@samsung.com' \
    --to=kgene.kim@samsung.com \
    --cc=ben-linux@fluff.org \
    --cc=jy0922.shim@samsung.com \
    --cc=kmpark@infradead.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=m.szyprowski@samsung.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®