mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "David Flynn" <Dave@keston.u-net.com>
To: "Jeff Garzik" <jgarzik@mandrakesoft.com>,
	"Daniel Phillips" <phillips@bonn-fries.net>
Cc: <rjd@xyzzy.clara.co.uk>,
	"Bill Pringlemeir" <bpringle@sympatico.ca>,
	<linux-kernel@vger.kernel.org>
Subject: Re: Newbie idiotic questions.
Date: Sun, 17 Jun 2001 16:38:54 +0100	[thread overview]
Message-ID: <00c301c0f743$9da4d9f0$1901a8c0@node0.idium.eu.org> (raw)
In-Reply-To: <200106171227.f5HCRZu10829@xyzzy.clara.co.uk> <0106171701100P.00879@starship> <3B2CC7DC.EEAF3253@mandrakesoft.com>



> Daniel Phillips wrote:
> > Yep, the only thing left to resolve is whether Jeff had coffee or not.
;-)
> >
> > -       if ((card->mpuout = kmalloc(sizeof(struct emu10k1_mpuout),
GFP_KERNEL))
> > +       if ((card->mpuout = kmalloc(sizeof(*card->mpuout), GFP_KERNEL))
>
> Yeah, this is fine.  The original posted omitted the '*' which was not
> fine :)

The only other thing left to ask, is which is easier to read when glancing
through the code, and which is easier to read when maintaining the code.
imho, ist the former for reading the code, i dont know about maintaing the
code since i dont do that, however in my own projects i prefere the former
when maintaing the code.

What are others oppinions on this ?

Thanks,

Dave Flynn

>
> --
> Jeff Garzik      | Andre the Giant has a posse.
> Building 1024    |
> MandrakeSoft     |
>



  reply	other threads:[~2001-06-17 15:39 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2001-06-17  1:19 Bill Pringlemeir
2001-06-17  1:32 ` Jeff Garzik
2001-06-17 10:48   ` Daniel Phillips
2001-06-17 12:27     ` rjd
2001-06-17 15:01       ` Daniel Phillips
2001-06-17 15:08         ` Jeff Garzik
2001-06-17 15:38           ` David Flynn [this message]
2001-06-17 15:54             ` Jeff Garzik
2001-06-17 19:18               ` Geert Uytterhoeven
2001-06-17 20:08                 ` Daniel Phillips
2001-06-17 20:37                   ` Alexander Viro
2001-06-17 21:28                     ` Daniel Phillips
2001-06-17 22:33                       ` Alexander Viro
2001-06-18  9:14                         ` Roman Zippel
2001-06-18  9:30                           ` Alexander Viro
2001-06-17 21:17               ` Bill Pringlemeir
2001-06-17  1:35 ` Richard B. Johnson
2001-06-17  3:01   ` Arnaldo Carvalho de Melo
2001-06-17  8:06 ` rjd

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='00c301c0f743$9da4d9f0$1901a8c0@node0.idium.eu.org' \
    --to=dave@keston.u-net.com \
    --cc=bpringle@sympatico.ca \
    --cc=jgarzik@mandrakesoft.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=phillips@bonn-fries.net \
    --cc=rjd@xyzzy.clara.co.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®