From: Zhao Lei <zhaolei@cn.fujitsu.com>
To: "'Tejun Heo'" <tj@kernel.org>
Cc: <cgroups@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
<mingo@redhat.com>, <peterz@infradead.org>
Subject: RE: [RESEND PATCH 2/2] cpuacct: split usage into user_usage and sys_usage.
Date: Tue, 1 Mar 2016 18:35:56 +0800 [thread overview]
Message-ID: <010801d173a6$237a2d70$6a6e8850$@cn.fujitsu.com> (raw)
In-Reply-To: <20151221213328.GP4026@mtj.duckdns.org>
Hi, Tejun Heo
> From: linux-kernel-owner@vger.kernel.org
> [mailto:linux-kernel-owner@vger.kernel.org] On Behalf Of Tejun Heo
> Sent: Tuesday, December 22, 2015 5:33 AM
> To: Dongsheng Yang <yangds.fnst@cn.fujitsu.com>
> Cc: cgroups@vger.kernel.org; linux-kernel@vger.kernel.org;
> mingo@redhat.com; peterz@infradead.org
> Subject: Re: [RESEND PATCH 2/2] cpuacct: split usage into user_usage and
> sys_usage.
>
> On Mon, Dec 21, 2015 at 07:14:43PM +0800, Dongsheng Yang wrote:
> > Sometimes, cpuacct.usage is not detialed enough to user
> > to see how much usage a group used. We want to know how
> > much time it used in user mode and how much in kernel mode.
>
Yang gave this patch to me :)
I'm plan to continue this function.
> cpuusage is being phased out. If you need these stats, please
> implement it on cpu side.
>
Currently, old stats are put in cpuacct, if we put new stats into cpu side,
we have following way:
1: Only put new stats into cpu side, and don't change old interface,
we'll see following content in cgroup dir:
/cgroup/cpuacct:
cpuacct.usage
cpuacct.usage_percpu
/cgroup/cpu:
cpu.usage_sys
cpu.usage_percpu_sys
cpu.usage_user
cpu.usage_percpu_user
It is obviously not unify.
2: Move old stats into cpu side, and add new stats:
we'll see following content in cgroup dir:
/cgroup/cpuacct:
[NONE]
/cgroup/cpu:
cpu.usage
cpu.usage_percpu
cpu.usage_sys
cpu.usage_percpu_sys
cpu.usage_user
cpu.usage_percpu_user
It have compatibility issues with old system.
3: Clone old stats into cpu side(share one copy of code), and add new stats
Into cpu side, we'll see following content in cgroup dir:
/cgroup/cpuacct:
cpuacct.usage
cpuacct.usage_percpu
/cgroup/cpu:
cpu.usage
cpu.usage_percpu
cpu.usage_sys
cpu.usage_percpu_sys
cpu.usage_user
cpu.usage_percpu_user
It can support both old and new systems, and we can remove old interface
in future, but we if mount both cpu and cpuacct into same dir,
we'll see following duplicated files:
/cgroup/cpu,cpuacct
cpu.usage
cpuacct.usage
cpu.usage_percpu
cpuacct.usage_percpu
...
Maybe above way3 looks having less defect, cound you talk about
your opinion on it.
Thanks
Zhaolei
next prev parent reply other threads:[~2016-03-01 10:36 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-12-21 11:14 [RESEND PATCH 1/2] cpuacct: rename parameter in cpuusage_write for readability Dongsheng Yang
2015-12-21 11:14 ` [RESEND PATCH 2/2] cpuacct: split usage into user_usage and sys_usage Dongsheng Yang
2015-12-21 21:33 ` Tejun Heo
2015-12-22 8:12 ` Dongsheng Yang
2016-03-01 10:35 ` Zhao Lei [this message]
2016-03-02 16:12 ` 'Tejun Heo'
2016-03-21 11:17 ` [tip:sched/urgent] sched/cpuacct: Rename parameter in cpuusage_write() for readability tip-bot for Dongsheng Yang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to='010801d173a6$237a2d70$6a6e8850$@cn.fujitsu.com' \
--to=zhaolei@cn.fujitsu.com \
--cc=cgroups@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=peterz@infradead.org \
--cc=tj@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome