mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Vincenzo Frascino <vincenzo.frascino@arm.com>
To: Catalin Marinas <catalin.marinas@arm.com>,
	Andrey Konovalov <andreyknvl@google.com>
Cc: Will Deacon <will.deacon@arm.com>,
	Dmitry Vyukov <dvyukov@google.com>,
	Andrey Ryabinin <aryabinin@virtuozzo.com>,
	Alexander Potapenko <glider@google.com>,
	Marco Elver <elver@google.com>,
	Evgenii Stepanov <eugenis@google.com>,
	Branislav Rankov <Branislav.Rankov@arm.com>,
	Kevin Brodsky <kevin.brodsky@arm.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	kasan-dev@googlegroups.com, linux-arm-kernel@lists.infradead.org,
	linux-mm@kvack.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v8 28/43] arm64: mte: Reset the page tag in page->flags
Date: Fri, 6 Nov 2020 11:46:15 +0000	[thread overview]
Message-ID: <01a55e00-0d82-7e62-cc40-c282149dbb08@arm.com> (raw)
In-Reply-To: <20201105155859.GA30030@gaia>

Hi Catalin,

On 11/5/20 3:59 PM, Catalin Marinas wrote:
> On Thu, Nov 05, 2020 at 12:18:43AM +0100, Andrey Konovalov wrote:
>> diff --git a/arch/arm64/kernel/mte.c b/arch/arm64/kernel/mte.c
>> index 8f99c65837fd..06ba6c923ab7 100644
>> --- a/arch/arm64/kernel/mte.c
>> +++ b/arch/arm64/kernel/mte.c
>> @@ -34,6 +34,7 @@ static void mte_sync_page_tags(struct page *page, pte_t *ptep, bool check_swap)
>>  			return;
>>  	}
>>  
>> +	page_kasan_tag_reset(page);
>>  	mte_clear_page_tags(page_address(page));
> 
> I think we need an smp_wmb() between setting the flags and clearing the
> actual tags. If another threads reads page->flags and builds a tagged
> address out of it (see page_to_virt) there's an address dependency to
> the actual memory access. However, on the current thread, we don't
> guarantee that the new page->flags are visible before the tags were
> updated.
> 

Indeed, and I will add a comment as well to explain why.

>>  }
>>  
>> diff --git a/arch/arm64/mm/copypage.c b/arch/arm64/mm/copypage.c
>> index 70a71f38b6a9..348f4627da08 100644
>> --- a/arch/arm64/mm/copypage.c
>> +++ b/arch/arm64/mm/copypage.c
>> @@ -22,6 +22,7 @@ void copy_highpage(struct page *to, struct page *from)
>>  	copy_page(kto, kfrom);
>>  
>>  	if (system_supports_mte() && test_bit(PG_mte_tagged, &from->flags)) {
>> +		page_kasan_tag_reset(to);
>>  		set_bit(PG_mte_tagged, &to->flags);
>>  		mte_copy_page_tags(kto, kfrom);
> 
> Nitpick: move page_kasan_tag_reset() just above mte_copy_page_tags() for
> consistency with the other places where PG_mte_tagged is set before or
> after the actual tag setting.
> 

Fine, I will add it to the next iteration.

>>  	}
>> diff --git a/arch/arm64/mm/mteswap.c b/arch/arm64/mm/mteswap.c
>> index c52c1847079c..0e7eccbe598a 100644
>> --- a/arch/arm64/mm/mteswap.c
>> +++ b/arch/arm64/mm/mteswap.c
>> @@ -53,6 +53,7 @@ bool mte_restore_tags(swp_entry_t entry, struct page *page)
>>  	if (!tags)
>>  		return false;
>>  
>> +	page_kasan_tag_reset(page);
>>  	mte_restore_page_tags(page_address(page), tags);

I just realized based on your comment above that we need smp_wmb() here as well.
I will add it with a comment as well.

> 
> There is another mte_restore_page_tags() caller in hibernate.c. That one
> doesn't need page_kasan_tag_reset() since the page->flags would have
> been already restored but please add a comment in that file why its not
> needed.
> 

Yes I will do, I agree on the reasoning, I will report it in the comments.

-- 
Regards,
Vincenzo

  reply	other threads:[~2020-11-06 11:43 UTC|newest]

Thread overview: 65+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-04 23:18 [PATCH v8 00/43] kasan: add hardware tag-based mode for arm64 Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 01/43] kasan: drop unnecessary GPL text from comment headers Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 02/43] kasan: KASAN_VMALLOC depends on KASAN_GENERIC Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 03/43] kasan: group vmalloc code Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 04/43] s390/kasan: include asm/page.h from asm/kasan.h Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 05/43] kasan: shadow declarations only for software modes Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 06/43] kasan: rename (un)poison_shadow to (un)poison_memory Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 07/43] kasan: rename KASAN_SHADOW_* to KASAN_GRANULE_* Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 08/43] kasan: only build init.c for software modes Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 09/43] kasan: split out shadow.c from common.c Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 10/43] kasan: define KASAN_GRANULE_PAGE Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 11/43] kasan: rename report and tags files Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 12/43] kasan: don't duplicate config dependencies Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 13/43] kasan: hide invalid free check implementation Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 14/43] kasan: decode stack frame only with KASAN_STACK_ENABLE Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 15/43] kasan, arm64: only init shadow for software modes Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 16/43] kasan, arm64: only use kasan_depth " Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 17/43] kasan, arm64: move initialization message Andrey Konovalov
2020-11-05 15:59   ` Catalin Marinas
2020-11-04 23:18 ` [PATCH v8 18/43] kasan, arm64: rename kasan_init_tags and mark as __init Andrey Konovalov
2020-11-05 16:00   ` Catalin Marinas
2020-11-04 23:18 ` [PATCH v8 19/43] kasan: rename addr_has_shadow to addr_has_metadata Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 20/43] kasan: rename print_shadow_for_address to print_memory_metadata Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 21/43] kasan: kasan_non_canonical_hook only for software modes Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 22/43] kasan: rename SHADOW layout macros to META Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 23/43] kasan: separate metadata_fetch_row for each mode Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 24/43] kasan, arm64: don't allow SW_TAGS with ARM64_MTE Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 25/43] kasan: introduce CONFIG_KASAN_HW_TAGS Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 26/43] arm64: Enable armv8.5-a asm-arch option Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 27/43] arm64: mte: Add in-kernel MTE helpers Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 28/43] arm64: mte: Reset the page tag in page->flags Andrey Konovalov
2020-11-05 15:59   ` Catalin Marinas
2020-11-06 11:46     ` Vincenzo Frascino [this message]
2020-11-04 23:18 ` [PATCH v8 29/43] arm64: mte: Add in-kernel tag fault handler Andrey Konovalov
2020-11-05 16:57   ` Catalin Marinas
2020-11-04 23:18 ` [PATCH v8 30/43] arm64: kasan: Allow enabling in-kernel MTE Andrey Konovalov
2020-11-05 11:16   ` Vincenzo Frascino
2020-11-05 11:35     ` Andrey Konovalov
2020-11-05 11:42       ` Vincenzo Frascino
2020-11-05 12:14         ` Andrey Konovalov
2020-11-05 14:17           ` Vincenzo Frascino
2020-11-05 17:27             ` Andrey Konovalov
2020-11-05 17:25   ` Catalin Marinas
2020-11-05 17:29     ` Andrey Konovalov
2020-11-05 17:39       ` Catalin Marinas
2020-11-05 18:09         ` Andrey Konovalov
2020-11-06 11:11           ` Vincenzo Frascino
2020-11-04 23:18 ` [PATCH v8 31/43] arm64: mte: Convert gcr_user into an exclude mask Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 32/43] arm64: mte: Switch GCR_EL1 in kernel entry and exit Andrey Konovalov
2020-11-05 17:30   ` Catalin Marinas
2020-11-05 17:33     ` Andrey Konovalov
2020-11-05 17:42   ` Catalin Marinas
2020-11-04 23:18 ` [PATCH v8 33/43] arm64: kasan: Align allocations for HW_TAGS Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 34/43] arm64: kasan: Add arch layer for memory tagging helpers Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 35/43] kasan: define KASAN_GRANULE_SIZE for HW_TAGS Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 36/43] kasan, x86, s390: update undef CONFIG_KASAN Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 37/43] kasan, arm64: expand CONFIG_KASAN checks Andrey Konovalov
2020-11-05 17:32   ` Catalin Marinas
2020-11-04 23:18 ` [PATCH v8 38/43] kasan, arm64: implement HW_TAGS runtime Andrey Konovalov
2020-11-04 23:48   ` Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 39/43] kasan, arm64: print report from tag fault handler Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 40/43] kasan, mm: reset tags when accessing metadata Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 41/43] kasan, arm64: enable CONFIG_KASAN_HW_TAGS Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 42/43] kasan: add documentation for hardware tag-based mode Andrey Konovalov
2020-11-04 23:18 ` [PATCH v8 43/43] kselftest/arm64: Check GCR_EL1 after context switch Andrey Konovalov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=01a55e00-0d82-7e62-cc40-c282149dbb08@arm.com \
    --to=vincenzo.frascino@arm.com \
    --cc=Branislav.Rankov@arm.com \
    --cc=akpm@linux-foundation.org \
    --cc=andreyknvl@google.com \
    --cc=aryabinin@virtuozzo.com \
    --cc=catalin.marinas@arm.com \
    --cc=dvyukov@google.com \
    --cc=elver@google.com \
    --cc=eugenis@google.com \
    --cc=glider@google.com \
    --cc=kasan-dev@googlegroups.com \
    --cc=kevin.brodsky@arm.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®