From: Changwoo Min <changwoo@igalia.com>
To: Honglei Wang <jameshongleiwang@126.com>,
tj@kernel.org, void@manifault.com, arighi@nvidia.com
Cc: mingo@redhat.com, peterz@infradead.org, juri.lelli@redhat.com,
vincent.guittot@linaro.org, dietmar.eggemann@arm.com,
rostedt@goodmis.org, bsegall@google.com, mgorman@suse.de,
vschneid@redhat.com, joshdon@google.com, brho@google.com,
linux-kernel@vger.kernel.org, bpf@vger.kernel.org
Subject: Re: [PATCH v2 0/2] rename var for slice refill event and add helper
Date: Fri, 18 Apr 2025 12:55:51 +0900 [thread overview]
Message-ID: <01d5eb3b-f312-46a1-b8d2-22be8bcfa5f9@igalia.com> (raw)
In-Reply-To: <20250418032603.61803-1-jameshongleiwang@126.com>
Hi Honglei,
Thanks for the contribution. The change looks good to me.
Acked-by: Changwoo Min <changwoo@igalia.com>
On 4/18/25 12:26, Honglei Wang wrote:
> SCX_EV_ENQ_SLICE_DFL gives the impression that the event only occurs
> when the tasks were enqueued, which seems not accurate. So rename the
> variable to SCX_EV_REFILL_SLICE_DFL.
>
> The slice refilling with default slice always come with event
> statistics together, add a helper routine to make it cleaner.
>
> Changes in v2:
> Refine the comments base on Andrea's suggestion.
>
> Honglei Wang (2):
> sched_ext: change the variable name for slice refill event
> sched_ext: add helper for refill task with default slice
>
> kernel/sched/ext.c | 36 +++++++++++++++++-----------------
> tools/sched_ext/scx_qmap.bpf.c | 4 ++--
> 2 files changed, 20 insertions(+), 20 deletions(-)
>
next prev parent reply other threads:[~2025-04-18 3:56 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-04-18 3:26 Honglei Wang
2025-04-18 3:26 ` [PATCH v2 1/2] sched_ext: change the variable name for slice refill event Honglei Wang
2025-04-18 3:26 ` [PATCH v2 2/2] sched_ext: add helper for refill task with default slice Honglei Wang
2025-04-18 3:55 ` Changwoo Min [this message]
2025-04-18 5:53 ` [PATCH v2 0/2] rename var for slice refill event and add helper Andrea Righi
2025-04-19 3:28 ` Tejun Heo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=01d5eb3b-f312-46a1-b8d2-22be8bcfa5f9@igalia.com \
--to=changwoo@igalia.com \
--cc=arighi@nvidia.com \
--cc=bpf@vger.kernel.org \
--cc=brho@google.com \
--cc=bsegall@google.com \
--cc=dietmar.eggemann@arm.com \
--cc=jameshongleiwang@126.com \
--cc=joshdon@google.com \
--cc=juri.lelli@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mgorman@suse.de \
--cc=mingo@redhat.com \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
--cc=tj@kernel.org \
--cc=vincent.guittot@linaro.org \
--cc=void@manifault.com \
--cc=vschneid@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®