From: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>
To: Cezary Rojewski <cezary.rojewski@intel.com>
Cc: alsa-devel@alsa-project.org, linux-kernel@vger.kernel.org,
tiwai@suse.de, broonie@kernel.org, vkoul@kernel.org,
gregkh@linuxfoundation.org, jank@cadence.com,
srinivas.kandagatla@linaro.org, slawomir.blauciak@intel.com,
Bard liao <yung-chuan.liao@linux.intel.com>,
Rander Wang <rander.wang@linux.intel.com>,
Ranjani Sridharan <ranjani.sridharan@linux.intel.com>,
Sanyog Kale <sanyog.r.kale@intel.com>
Subject: Re: [PATCH 10/14] soundwire: intel: add prepare support in sdw dai driver
Date: Mon, 4 Nov 2019 15:31:16 -0600 [thread overview]
Message-ID: <02ef59ba-66da-3ba9-1fe7-0b7e256e3ac1@linux.intel.com> (raw)
In-Reply-To: <7a49fcce-5b36-81c1-6041-dda263ebb200@intel.com>
On 11/4/19 1:45 PM, Cezary Rojewski wrote:
> On 2019-10-23 23:28, Pierre-Louis Bossart wrote:
>> From: Rander Wang <rander.wang@linux.intel.com>
>>
>> It gets sdw runtime information from dai to prepare stream.
>>
>> Signed-off-by: Rander Wang <rander.wang@linux.intel.com>
>> Signed-off-by: Pierre-Louis Bossart
>> <pierre-louis.bossart@linux.intel.com>
>
> While the patch looks good, the commit message is questionable. You may
> simply state why it is added only just now. Judging from the commit
> title, it has been added to make the sdw dai driver interface complete.
The commit message is not great but it's not wrong either...
next prev parent reply other threads:[~2019-11-04 21:56 UTC|newest]
Thread overview: 33+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-10-23 21:28 [PATCH 00/14] soundwire: intel: implement new ASoC interfaces Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 01/14] soundwire: renames to prepare support for master drivers/devices Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 02/14] soundwire: rename dev_to_sdw_dev macro Pierre-Louis Bossart
2019-11-03 5:28 ` Vinod Koul
2019-10-23 21:28 ` [PATCH 03/14] soundwire: rename drv_to_sdw_slave_driver macro Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 04/14] soundwire: bus_type: rename sdw_drv_ to sdw_slave_drv Pierre-Louis Bossart
2019-11-03 5:30 ` Vinod Koul
2019-11-04 14:34 ` [alsa-devel] " Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 05/14] soundwire: intel: rename res field as link_res Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 06/14] soundwire: add support for sdw_slave_type Pierre-Louis Bossart
2019-11-03 5:32 ` Vinod Koul
2019-11-04 14:35 ` [alsa-devel] " Pierre-Louis Bossart
2019-11-04 19:33 ` Cezary Rojewski
2019-11-04 19:41 ` [alsa-devel] " Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 07/14] soundwire: add initial definitions for sdw_master_device Pierre-Louis Bossart
2019-11-03 6:30 ` Vinod Koul
2019-11-04 14:42 ` [alsa-devel] " Pierre-Louis Bossart
2019-11-08 4:04 ` Vinod Koul
2019-11-08 14:41 ` Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 08/14] soundwire: intel: remove platform devices and provide new interface Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 09/14] soundwire: add device driver to sdw_md_driver Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 10/14] soundwire: intel: add prepare support in sdw dai driver Pierre-Louis Bossart
2019-11-04 19:45 ` Cezary Rojewski
2019-11-04 21:31 ` Pierre-Louis Bossart [this message]
2019-11-08 4:05 ` Vinod Koul
2019-10-23 21:28 ` [PATCH 11/14] soundwire: intel: add trigger " Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 12/14] soundwire: intel: add sdw_stream_setup helper for .startup callback Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 13/14] soundwire: intel: free all resources on hw_free() Pierre-Louis Bossart
2019-11-04 20:08 ` Cezary Rojewski
2019-11-04 21:46 ` [alsa-devel] " Pierre-Louis Bossart
2019-11-08 4:14 ` Vinod Koul
2019-11-08 14:39 ` Pierre-Louis Bossart
2019-10-23 21:28 ` [PATCH 14/14] soundwire: intel_init: add implementation of sdw_intel_enable_irq() Pierre-Louis Bossart
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=02ef59ba-66da-3ba9-1fe7-0b7e256e3ac1@linux.intel.com \
--to=pierre-louis.bossart@linux.intel.com \
--cc=alsa-devel@alsa-project.org \
--cc=broonie@kernel.org \
--cc=cezary.rojewski@intel.com \
--cc=gregkh@linuxfoundation.org \
--cc=jank@cadence.com \
--cc=linux-kernel@vger.kernel.org \
--cc=rander.wang@linux.intel.com \
--cc=ranjani.sridharan@linux.intel.com \
--cc=sanyog.r.kale@intel.com \
--cc=slawomir.blauciak@intel.com \
--cc=srinivas.kandagatla@linaro.org \
--cc=tiwai@suse.de \
--cc=vkoul@kernel.org \
--cc=yung-chuan.liao@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome