From: Jijie Shao <shaojijie@huawei.com>
To: Paolo Abeni <pabeni@redhat.com>, <davem@davemloft.net>,
<edumazet@google.com>, <kuba@kernel.org>
Cc: <shaojijie@huawei.com>, <shenjian15@huawei.com>,
<wangpeiyang1@huawei.com>, <liuyonglong@huawei.com>,
<chenhao418@huawei.com>, <sudongming1@huawei.com>,
<xujunsheng@huawei.com>, <shiyongbang@huawei.com>,
<libaihan@huawei.com>, <andrew@lunn.ch>, <jdamato@fastly.com>,
<horms@kernel.org>, <jonathan.cameron@huawei.com>,
<shameerali.kolothum.thodi@huawei.com>, <salil.mehta@huawei.com>,
<netdev@vger.kernel.org>, <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH V6 net-next 03/11] net: hibmcge: Add mdio and hardware configuration supported in this module
Date: Tue, 3 Sep 2024 20:13:58 +0800 [thread overview]
Message-ID: <0341f08c-fe8b-4f9c-961e-9b773d67d7bf@huawei.com> (raw)
In-Reply-To: <0ff20687-74de-4e63-90f4-57cf06795990@redhat.com>
on 2024/9/3 19:59, Paolo Abeni wrote:
> On 8/30/24 14:15, Jijie Shao wrote:
> [...]
>> +static int hbg_mdio_wait_ready(struct hbg_mac *mac)
>> +{
>> +#define HBG_MDIO_OP_TIMEOUT_US (1 * 1000 * 1000)
>> +#define HBG_MDIO_OP_INTERVAL_US (5 * 1000)
>
> Minor nit: I find the define inside the function body less readable
> than placing them just before the function itself.
These two macros are only used in this function.
Is it necessary to move them to the header file?
>
>> +
>> + struct hbg_priv *priv = HBG_MAC_GET_PRIV(mac);
>> + u32 cmd;
>> +
>> + return readl_poll_timeout(priv->io_base +
>> HBG_REG_MDIO_COMMAND_ADDR, cmd,
>> + !FIELD_GET(HBG_REG_MDIO_COMMAND_START_B, cmd),
>> + HBG_MDIO_OP_INTERVAL_US,
>> + HBG_MDIO_OP_TIMEOUT_US);
>> +}
>
> [...]> +static void hbg_phy_adjust_link(struct net_device *netdev)
>> +{
>> + struct hbg_priv *priv = netdev_priv(netdev);
>> + struct phy_device *phydev = priv->mac.phydev;
>
> Minor nit: please respect the reverse x-mas tree order
Here, I need to get the *priv first, so I'm not following the reverse x-mas tree order here.
I respect the reverse x-mas tree order everywhere else.
Thanks,
Jijie Shao
next prev parent reply other threads:[~2024-09-03 12:14 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-08-30 12:15 [PATCH V6 net-next 00/11] Add support of HIBMCGE Ethernet Driver Jijie Shao
2024-08-30 12:15 ` [PATCH V6 net-next 01/11] net: hibmcge: Add pci table supported in this module Jijie Shao
2024-08-30 12:15 ` [PATCH V6 net-next 02/11] net: hibmcge: Add read/write registers supported through the bar space Jijie Shao
2024-08-30 12:15 ` [PATCH V6 net-next 03/11] net: hibmcge: Add mdio and hardware configuration supported in this module Jijie Shao
2024-09-03 11:59 ` Paolo Abeni
2024-09-03 12:13 ` Jijie Shao [this message]
2024-09-03 13:15 ` Andrew Lunn
2024-09-03 14:42 ` Jijie Shao
2024-09-03 17:44 ` Jakub Kicinski
2024-09-04 1:34 ` Jijie Shao
2024-08-30 12:15 ` [PATCH V6 net-next 04/11] net: hibmcge: Add interrupt " Jijie Shao
2024-08-30 12:15 ` [PATCH V6 net-next 05/11] net: hibmcge: Implement some .ndo functions Jijie Shao
2024-08-30 12:15 ` [PATCH V6 net-next 06/11] net: hibmcge: Implement .ndo_start_xmit function Jijie Shao
2024-09-03 13:31 ` Paolo Abeni
2024-09-03 14:41 ` Jijie Shao
2024-08-30 12:16 ` [PATCH V6 net-next 07/11] net: hibmcge: Implement rx_poll function to receive packets Jijie Shao
2024-09-03 12:08 ` Paolo Abeni
2024-09-03 12:57 ` Jijie Shao
2024-08-30 12:16 ` [PATCH V6 net-next 08/11] net: hibmcge: Implement some ethtool_ops functions Jijie Shao
2024-08-30 12:16 ` [PATCH V6 net-next 09/11] net: hibmcge: Add a Makefile and update Kconfig for hibmcge Jijie Shao
2024-08-30 12:16 ` [PATCH V6 net-next 10/11] net: hibmcge: Add maintainer " Jijie Shao
2024-08-30 12:16 ` [PATCH V6 net-next 11/11] net: add ndo_validate_addr check in dev_set_mac_address Jijie Shao
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=0341f08c-fe8b-4f9c-961e-9b773d67d7bf@huawei.com \
--to=shaojijie@huawei.com \
--cc=andrew@lunn.ch \
--cc=chenhao418@huawei.com \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=horms@kernel.org \
--cc=jdamato@fastly.com \
--cc=jonathan.cameron@huawei.com \
--cc=kuba@kernel.org \
--cc=libaihan@huawei.com \
--cc=linux-kernel@vger.kernel.org \
--cc=liuyonglong@huawei.com \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=salil.mehta@huawei.com \
--cc=shameerali.kolothum.thodi@huawei.com \
--cc=shenjian15@huawei.com \
--cc=shiyongbang@huawei.com \
--cc=sudongming1@huawei.com \
--cc=wangpeiyang1@huawei.com \
--cc=xujunsheng@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®