From: Jacek Kowalski <jacek@jacekk.info>
To: Simon Horman <horms@kernel.org>
Cc: Tony Nguyen <anthony.l.nguyen@intel.com>,
Przemek Kitszel <przemyslaw.kitszel@intel.com>,
Andrew Lunn <andrew+netdev@lunn.ch>,
"David S. Miller" <davem@davemloft.net>,
Eric Dumazet <edumazet@google.com>,
Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
intel-wired-lan@lists.osuosl.org, netdev@vger.kernel.org,
linux-kernel@vger.kernel.org, Vlad URSU <vlad@ursu.me>
Subject: Re: [PATCH v3 2/2] e1000e: ignore factory-default checksum value on TGP platform
Date: Tue, 24 Jun 2025 23:05:05 +0200 [thread overview]
Message-ID: <0407b67d-e63f-4a85-b3b4-1563335607dc@jacekk.info> (raw)
In-Reply-To: <20250624194237.GI1562@horms.kernel.org>
>> Unfortunately some systems have left the factory with an empty
>> checksum. NVM is not modifiable on this platform, hence ignore
>> checksum 0xFFFF on Tiger Lake systems to work around this.
>
> I think that you need to update the patch description. As of v3 it's
> the last word of the checksum that is being checked, not the entire
> checksum.
As I understood it, "sum" is the resulting value while "checksum" is the
value appended so that the "sum" is equal to some constant.
But my understanding is utterly broken by this line:
>> if (checksum != (u16)NVM_SUM) {
Where variable checksum (shall it be "sum"?) that includes
"checksum" (or maybe checksum word?) from the *checksum* register
address (NVM_CHECKSUM_REG) is compared to a constant called "NVM_SUM".
Is something like this fine by you:
> Unfortunately some systems have left the factory with an unmodified
> value of 0xFFFF at register address 0x3F (checksum word location).
> So on Tiger Lake platform we ignore the computed checksum when such
> condition is encountered.
?
>> +#define NVM_CHECKSUM_FACTORY_DEFAULT 0xFFFF
>
> Perhaps it is too long, but I liked Vlad's suggestion of naming this
> NVM_CHECKSUM_WORD_FACTORY_DEFAULT.
I can update it as well once we agree on the wording.
>> + if (hw->mac.type == e1000_pch_tgp && nvm_data == NVM_CHECKSUM_FACTORY_DEFAULT) {
>
> Please wrap the line above so it is 80 columns wide or less.
Wilco.
--
Best regards,
Jacek Kowalski
next prev parent reply other threads:[~2025-06-24 21:05 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-24 19:07 [PATCH v3 1/2] e1000e: disregard NVM checksum on tgp when valid checksum mask is not set Jacek Kowalski
2025-06-24 19:14 ` [PATCH v3 2/2] e1000e: ignore factory-default checksum value on TGP platform Jacek Kowalski
2025-06-24 19:42 ` Simon Horman
2025-06-24 21:05 ` Jacek Kowalski [this message]
2025-06-25 9:44 ` Simon Horman
2025-06-25 13:05 ` Jacek Kowalski
2025-06-25 14:06 ` Vlad URSU
2025-06-25 17:00 ` Simon Horman
2025-06-29 9:36 ` David Laight
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=0407b67d-e63f-4a85-b3b4-1563335607dc@jacekk.info \
--to=jacek@jacekk.info \
--cc=andrew+netdev@lunn.ch \
--cc=anthony.l.nguyen@intel.com \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=horms@kernel.org \
--cc=intel-wired-lan@lists.osuosl.org \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=przemyslaw.kitszel@intel.com \
--cc=vlad@ursu.me \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®