mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com>
To: Andy Shevchenko <andy.shevchenko@gmail.com>,
	Tvrtko Ursulin <tursulin@ursulin.net>
Cc: Masahiro Yamada <yamada.masahiro@socionext.com>,
	Intel-gfx@lists.freedesktop.org,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
Subject: Re: [Intel-gfx] [PATCH v4] lib/scatterlist: Avoid potential scatterlist entry overflow
Date: Fri, 13 Jan 2017 08:37:10 +0000	[thread overview]
Message-ID: <05250677-7414-a4bd-8645-96da6a8b2df6@linux.intel.com> (raw)
In-Reply-To: <CAHp75Vdo_EPSxA2gd=R1Erp1x6=P1tLpoWxrRE4LEuFUobUPmg@mail.gmail.com>


Hi,

On 11/01/2017 23:59, Andy Shevchenko wrote:
> On Wed, Jan 11, 2017 at 1:58 PM, Tvrtko Ursulin <tursulin@ursulin.net> wrote:
>> Since the scatterlist length field is an unsigned int, make
>> sure that sg_alloc_table_from_pages does not overflow it while
>> coallescing pages to a single entry.
>
>
>>  /*
>> + * Since the above length field is an unsigned int, below we define the maximum
>> + * lenght in bytes that can be stored in one scatterlist entry.
>
> length
>
>> + */
>> +#define SCATTERLIST_MAX_SEGMENT (0xfffff000)
>
> Shouldn't be calculated from PAGE_SIZE (PAGE bits, etc)?

Yep, and at the same time I would potentially change the name to be 
consistent with the other defines in the file as Joonas suggested. 
Something like:

#define SG_MAX_SEGMENT (UINT_MAX & PAGE_MASK)

But would need a better name since SG_MAX_SEGMENT*S* already exists and 
means something else. If we can't come up with a better name then leave 
it as SCATTERLIST_MAX_SEGMENT?

>> --- a/lib/scatterlist.c
>> +++ b/lib/scatterlist.c
>
>> @@ -402,9 +403,16 @@ int sg_alloc_table_from_pages(struct sg_table *sgt,
>>
>>         /* compute number of contiguous chunks */
>>         chunks = 1;
>> -       for (i = 1; i < n_pages; ++i)
>> -               if (page_to_pfn(pages[i]) != page_to_pfn(pages[i - 1]) + 1)
>> +       seg_len = PAGE_SIZE;
>> +       for (i = 1; i < n_pages; ++i) {
>> +               if (seg_len >= max_segment ||
>> +                   page_to_pfn(pages[i]) != page_to_pfn(pages[i - 1]) + 1) {
>>                         ++chunks;
>> +                       seg_len = PAGE_SIZE;
>> +               } else {
>> +                       seg_len += PAGE_SIZE;
>> +               }
>> +       }
>
> Wouldn't be following looks more readable?
>
> seg_len = 0;
> // Are compilers so stupid doing calculation per iteration in for-conditional?
> // for (i = 0; i + 1 < n_pages; i++) ?

I didn't get what you meant here?

> for (i = 1; i < n_pages; ++i) {
>   seg_len += PAGE_SIZE;
>   if (seg_len >= max_segment || page_to_pfn(pages[i]) !=
> page_to_pfn(pages[i - 1]) + 1) {
>     ++chunks;
>     seg_len = PAGE_SIZE;
>   }
> }

Tried it in my unit tester but it doesn't work for all scenarios, guess 
there is a subtle bug somewhere. I don't find it that unreadable so 
would prefer to leave it since it works.

> Perhaps while() or do-while() will increase readability even more, but
> I didn't check.
>
>>                 /* look for the end of the current chunk */
>> +               seg_len = PAGE_SIZE;
>>                 for (j = cur_page + 1; j < n_pages; ++j)
>> -                       if (page_to_pfn(pages[j]) !=
>> +                       if (seg_len >= max_segment ||
>> +                           page_to_pfn(pages[j]) !=
>>                             page_to_pfn(pages[j - 1]) + 1)
>>                                 break;
>> +                       else
>> +                               seg_len += PAGE_SIZE;
>
> Something similar here (didn't you get warning from checkpath about
> curly braces?).

It didn't, but agreed that I should have added them. Will do.

Regards,

Tvrtko

  reply	other threads:[~2017-01-13  8:37 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-01-11  9:00 [PATCH 1/4] lib/scatterlist: Fix offset type in sg_alloc_table_from_pages Tvrtko Ursulin
2017-01-11  9:00 ` [PATCH 2/4] lib/scatterlist: Avoid potential scatterlist entry overflow Tvrtko Ursulin
2017-01-11 11:58   ` [PATCH v4] " Tvrtko Ursulin
2017-01-11 23:59     ` Andy Shevchenko
2017-01-13  8:37       ` Tvrtko Ursulin [this message]
2017-01-13 22:23         ` [Intel-gfx] " Andy Shevchenko
2017-01-16 10:05           ` Tvrtko Ursulin
2017-01-16 10:12             ` Andy Shevchenko
2017-01-11  9:00 ` [PATCH 3/4] lib/scatterlist: Introduce and export __sg_alloc_table_from_pages Tvrtko Ursulin
2017-01-11  9:00 ` [PATCH 4/4] drm/i915: Use __sg_alloc_table_from_pages for userptr allocations Tvrtko Ursulin
2017-01-11 11:59   ` [PATCH v6] " Tvrtko Ursulin
2017-01-12 18:20     ` [Intel-gfx] " kbuild test robot
2017-01-11 11:59 ` [PATCH v5] lib/scatterlist: Introduce and export __sg_alloc_table_from_pages Tvrtko Ursulin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=05250677-7414-a4bd-8645-96da6a8b2df6@linux.intel.com \
    --to=tvrtko.ursulin@linux.intel.com \
    --cc=Intel-gfx@lists.freedesktop.org \
    --cc=andy.shevchenko@gmail.com \
    --cc=joonas.lahtinen@linux.intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=tursulin@ursulin.net \
    --cc=yamada.masahiro@socionext.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®