From: Philipp Hortmann <philipp.g.hortmann@gmail.com>
To: Forest Bond <forest@alittletooquiet.net>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: [PATCH v2 1/5] staging: vt6655: Convert macro MACvReceive0 to function
Date: Fri, 29 Jul 2022 10:14:14 +0200 [thread overview]
Message-ID: <059aca149bd0c1d75df4fb3cd8a177aa4948fb02.1659080988.git.philipp.g.hortmann@gmail.com> (raw)
In-Reply-To: <cover.1659080988.git.philipp.g.hortmann@gmail.com>
Convert macro to static function. Multiline macros are not liked by
kernel community. Rename variable dwData to reg_value to avoid
CamelCase which is not accepted by checkpatch.pl. Change variable
declaration to u32 as this improves readability.
Signed-off-by: Philipp Hortmann <philipp.g.hortmann@gmail.com>
---
V1 -> V2: Combind patch "Rename dwData to reg_value ..." with this one
Changed order of renaming function and conversion to function
Removed function declaration
Changed variable declaration
Improved patch description
---
drivers/staging/vt6655/device_main.c | 11 +++++++++++
drivers/staging/vt6655/mac.h | 10 ----------
2 files changed, 11 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/vt6655/device_main.c b/drivers/staging/vt6655/device_main.c
index 92583ee8bffd..39bfbb1ab742 100644
--- a/drivers/staging/vt6655/device_main.c
+++ b/drivers/staging/vt6655/device_main.c
@@ -205,6 +205,17 @@ static void vt6655_mac_read_ether_addr(void __iomem *iobase, u8 *mac_addr)
iowrite8(0, iobase + MAC_REG_PAGE1SEL);
}
+static void MACvReceive0(void __iomem *iobase)
+{
+ u32 reg_value;
+
+ reg_value = ioread32(iobase + MAC_REG_RXDMACTL0);
+ if (reg_value & DMACTL_RUN)
+ iowrite32(DMACTL_WAKE, iobase + MAC_REG_RXDMACTL0);
+ else
+ iowrite32(DMACTL_RUN, iobase + MAC_REG_RXDMACTL0);
+}
+
/*
* Initialisation of MAC & BBP registers
*/
diff --git a/drivers/staging/vt6655/mac.h b/drivers/staging/vt6655/mac.h
index 0122c4603c66..d21313f3067e 100644
--- a/drivers/staging/vt6655/mac.h
+++ b/drivers/staging/vt6655/mac.h
@@ -537,16 +537,6 @@
/*--------------------- Export Macros ------------------------------*/
-#define MACvReceive0(iobase) \
-do { \
- unsigned long dwData; \
- dwData = ioread32(iobase + MAC_REG_RXDMACTL0); \
- if (dwData & DMACTL_RUN) \
- iowrite32(DMACTL_WAKE, iobase + MAC_REG_RXDMACTL0); \
- else \
- iowrite32(DMACTL_RUN, iobase + MAC_REG_RXDMACTL0); \
-} while (0)
-
#define MACvReceive1(iobase) \
do { \
unsigned long dwData; \
--
2.37.1
next prev parent reply other threads:[~2022-07-29 8:14 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-07-29 8:14 [PATCH v2 0/5] staging: vt6655: Convert four macros to one function Philipp Hortmann
2022-07-29 8:14 ` Philipp Hortmann [this message]
2022-07-29 8:14 ` [PATCH v2 2/5] staging: vt6655: Rename function MACvReceive0 and add parameter Philipp Hortmann
2022-07-29 8:14 ` [PATCH v2 3/5] staging: vt6655: Replace MACvReceive1 with function vt6655_mac_dma_ctl Philipp Hortmann
2022-07-29 8:14 ` [PATCH v2 4/5] staging: vt6655: Replace MACvTransmit0 " Philipp Hortmann
2022-07-29 8:14 ` [PATCH v2 5/5] staging: vt6655: Replace MACvTransmitAC0 " Philipp Hortmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=059aca149bd0c1d75df4fb3cd8a177aa4948fb02.1659080988.git.philipp.g.hortmann@gmail.com \
--to=philipp.g.hortmann@gmail.com \
--cc=forest@alittletooquiet.net \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®