From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757428AbaAJKkh (ORCPT ); Fri, 10 Jan 2014 05:40:37 -0500 Received: from mx0.aculab.com ([213.249.233.131]:38645 "HELO mx0.aculab.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with SMTP id S1757365AbaAJKkc convert rfc822-to-8bit (ORCPT ); Fri, 10 Jan 2014 05:40:32 -0500 From: David Laight To: "'David Miller'" , "dan.j.williams@intel.com" CC: "ncardwell@google.com" , "dmaengine@vger.kernel.org" , "yoshfuji@linux-ipv6.org" , "netdev@vger.kernel.org" , "jmorris@namei.org" , "kuznet@ms2.inr.ac.ru" , "kaber@trash.net" , "linux-kernel@vger.kernel.org" Subject: RE: [PATCH v2 3/4] net: make tcp_cleanup_rbuf private Thread-Topic: [PATCH v2 3/4] net: make tcp_cleanup_rbuf private Thread-Index: AQHPDXsaS76szjOCsU6CpluxDV9eDJp9xFlQ Date: Fri, 10 Jan 2014 10:38:40 +0000 Message-ID: <063D6719AE5E284EB5DD2968C1650D6D4579D9@AcuExch.aculab.com> References: <20140109201642.28381.82141.stgit@viggo.jf.intel.com> <20140109.154232.65818281679170677.davem@davemloft.net> In-Reply-To: <20140109.154232.65818281679170677.davem@davemloft.net> Accept-Language: en-GB, en-US Content-Language: en-US X-MS-Has-Attach: X-MS-TNEF-Correlator: x-originating-ip: [10.202.99.200] Content-Type: text/plain; charset="Windows-1252" Content-Transfer-Encoding: 8BIT MIME-Version: 1.0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org From: David Miller ... > > On Thu, Jan 9, 2014 at 12:26 PM, Neal Cardwell wrote: > >> On Thu, Jan 9, 2014 at 3:16 PM, Dan Williams wrote: > >>> net_dma was the only external user so this can become local to tcp.c > >>> again. > >> ... > >>> -void tcp_cleanup_rbuf(struct sock *sk, int copied) > >>> +static void cleanup_rbuf(struct sock *sk, int copied) > >> > >> I would vote to keep the tcp_ prefix. In the TCP code base that is the > >> more common idiom, even for internal/static TCP functions, and > >> personally I find it easier to read and work with in stack traces, > >> etc. My 2 cents. > >> > > > > Ok. It was cleanup_rbuf() in a former life, but one vote for leaving > > the name as is is enough for me. > > You can make that two votes :) I suspect DM adds 2000 votes :-) Keeping the prefix makes it easier to grep for, and makes it more obvious that it isn't a generic function (when being called). David