From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755592AbcECJqK (ORCPT ); Tue, 3 May 2016 05:46:10 -0400 Received: from smtp-out6.electric.net ([192.162.217.182]:51735 "EHLO smtp-out6.electric.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751131AbcECJqI convert rfc822-to-8bit (ORCPT ); Tue, 3 May 2016 05:46:08 -0400 From: David Laight To: "'Konstantin Shkolnyy'" , "johan@kernel.org" CC: "linux-usb@vger.kernel.org" , "linux-kernel@vger.kernel.org" Subject: RE: [PATCH v2 2/3] USB: serial: cp210x: Added comments to CRTSCTS flag code. Thread-Topic: [PATCH v2 2/3] USB: serial: cp210x: Added comments to CRTSCTS flag code. Thread-Index: AQHRoocnCiK3guwLO0urajCgF3UBrZ+m+0ug Date: Tue, 3 May 2016 09:44:08 +0000 Message-ID: <063D6719AE5E284EB5DD2968C1650D6D5F4B2EEA@AcuExch.aculab.com> References: <1461982943-19664-1-git-send-email-konstantin.shkolnyy@gmail.com> In-Reply-To: <1461982943-19664-1-git-send-email-konstantin.shkolnyy@gmail.com> Accept-Language: en-GB, en-US Content-Language: en-US X-MS-Has-Attach: X-MS-TNEF-Correlator: x-originating-ip: [10.202.99.200] Content-Type: text/plain; charset="Windows-1252" Content-Transfer-Encoding: 8BIT MIME-Version: 1.0 X-Outbound-IP: 213.249.233.130 X-Env-From: David.Laight@ACULAB.COM X-PolicySMART: 3396946, 3397078 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org From: Konstantin Shkolnyy > Sent: 30 April 2016 03:22 > Replaced magic numbers used in the CRTSCTS flag code with symbolic names > from the chip specification. > > Signed-off-by: Konstantin Shkolnyy > --- > Changes in v2: > Improved CRTSCTS fix based on feedback. Dropped get_termios error handling. > > drivers/usb/serial/cp210x.c | 93 +++++++++++++++++++++++++++++++++------------ > 1 file changed, 69 insertions(+), 24 deletions(-) > > diff --git a/drivers/usb/serial/cp210x.c b/drivers/usb/serial/cp210x.c ... > +/* cp210x_flow_ctl::ulControlHandshake */ > +#define SERIAL_DTR_MASK 0x00000003 > +#define SERIAL_CTS_HANDSHAKE 0x00000008 > +#define SERIAL_DSR_HANDSHAKE 0x00000010 > +#define SERIAL_DCD_HANDSHAKE 0x00000020 > +#define SERIAL_DSR_SENSITIVITY 0x00000040 ... I'd have thought the names ought to start CP210X_ David