mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: David Laight <David.Laight@ACULAB.COM>
To: "'Baole Ni'" <baolex.ni@intel.com>,
	"3chas3@gmail.com" <3chas3@gmail.com>,
	"tj@kernel.org" <tj@kernel.org>,
	"lenb@kernel.org" <lenb@kernel.org>,
	"x86@kernel.org" <x86@kernel.org>,
	"hpa@zytor.com" <hpa@zytor.com>
Cc: "linux-atm-general@lists.sourceforge.net" 
	<linux-atm-general@lists.sourceforge.net>,
	"netdev@vger.kernel.org" <netdev@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"chuansheng.liu@intel.com" <chuansheng.liu@intel.com>
Subject: RE: [PATCH 0071/1285] Replace numeric parameter like 0444 with macro
Date: Wed, 3 Aug 2016 15:47:14 +0000	[thread overview]
Message-ID: <063D6719AE5E284EB5DD2968C1650D6D5F50893F@AcuExch.aculab.com> (raw)
In-Reply-To: <20160802103831.18486-1-baolex.ni@intel.com>

From: Baole Ni
> Sent: 02 August 2016 11:39
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
...
> -module_param(debug, ulong, 0644);
> +module_param(debug, ulong, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
...

If you're as old as I am the octal constant is easier to read!

	David

      reply	other threads:[~2016-08-03 15:49 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-08-02 10:38 Baole Ni
2016-08-03 15:47 ` David Laight [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=063D6719AE5E284EB5DD2968C1650D6D5F50893F@AcuExch.aculab.com \
    --to=david.laight@aculab.com \
    --cc=3chas3@gmail.com \
    --cc=baolex.ni@intel.com \
    --cc=chuansheng.liu@intel.com \
    --cc=hpa@zytor.com \
    --cc=lenb@kernel.org \
    --cc=linux-atm-general@lists.sourceforge.net \
    --cc=linux-kernel@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=tj@kernel.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®