From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751606AbdAMKzq (ORCPT ); Fri, 13 Jan 2017 05:55:46 -0500 Received: from smtp-out6.electric.net ([192.162.217.193]:60605 "EHLO smtp-out6.electric.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751482AbdAMKzp (ORCPT ); Fri, 13 Jan 2017 05:55:45 -0500 From: David Laight To: "'Florian Fainelli'" , David Miller CC: "netdev@vger.kernel.org" , "jason@lakedaemon.net" , "andrew@lunn.ch" , "sebastian.hesselbarth@gmail.com" , "gregory.clement@free-electrons.com" , "linux@armlinux.org.uk" , "vivien.didelot@savoirfairelinux.com" , "linux-arm-kernel@lists.infradead.org" , "linux-kernel@vger.kernel.org" , "gregkh@linuxfoundation.org" Subject: RE: [PATCH net-next v2 05/10] drivers: base: Add device_find_class() Thread-Topic: [PATCH net-next v2 05/10] drivers: base: Add device_find_class() Thread-Index: AQHSbSZ8VSJ8mL8XP0eGjv2hKIN+aKE2PIUw Date: Fri, 13 Jan 2017 10:55:38 +0000 Message-ID: <063D6719AE5E284EB5DD2968C1650D6DB02620D3@AcuExch.aculab.com> References: <20170112034121.27697-1-f.fainelli@gmail.com> <20170112034121.27697-6-f.fainelli@gmail.com> <20170112.162135.441956368122992032.davem@davemloft.net> <81f5965c-3484-92d9-5c04-94c5b73735d0@gmail.com> In-Reply-To: <81f5965c-3484-92d9-5c04-94c5b73735d0@gmail.com> Accept-Language: en-GB, en-US Content-Language: en-US X-MS-Has-Attach: X-MS-TNEF-Correlator: x-originating-ip: [10.202.99.200] Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 X-Outbound-IP: 213.249.233.130 X-Env-From: David.Laight@ACULAB.COM X-Proto: esmtps X-Revdns: X-HELO: AcuExch.aculab.com X-TLS: TLSv1:AES128-SHA:128 X-Authenticated_ID: X-PolicySMART: 3396946, 3397078 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Transfer-Encoding: 8bit X-MIME-Autoconverted: from base64 to 8bit by mail.home.local id v0DAtpXq020273 From: Florian Fainelli > Sent: 12 January 2017 22:51 > On 01/12/2017 01:21 PM, David Miller wrote: > > From: Florian Fainelli > > Date: Wed, 11 Jan 2017 19:41:16 -0800 > > > >> Add a helper function to lookup a device reference given a class name. > >> This is a preliminary patch to remove adhoc code from net/dsa/dsa.c and > >> make it more generic. ... > >> +static int dev_is_class(struct device *dev, void *class) > > > > I know you are just moving code, but this class argumnet is a string > > and thus should be "char *" or even "const char *". > > Well, this is really so that we don't need to cast the arguments passed > to device_find_child(), which takes a void *data as well. If we made > that a const char *class, we'd get warnings that look like these: > > drivers/base/core.c: In function 'device_find_class': > drivers/base/core.c:2083:2: warning: passing argument 2 of > 'device_find_child' discards 'const' qualifier from pointer target type > [enabled by default] > return device_find_child(parent, class, dev_is_class); > ^ > drivers/base/core.c:2050:16: note: expected 'void *' but argument is of > type 'const char *' > struct device *device_find_child(struct device *parent, void *data, > ^ ... Maybe device_find_child() needs changing to take 'const void *' ? David