From: Robin Murphy <robin.murphy@arm.com>
To: Jeffy Chen <jeffy.chen@rock-chips.com>,
linux-kernel@vger.kernel.org, tfiga@chromium.org
Cc: jcliang@chromium.org, xxm@rock-chips.com,
Heiko Stuebner <heiko@sntech.de>,
linux-rockchip@lists.infradead.org,
iommu@lists.linux-foundation.org, Joerg Roedel <joro@8bytes.org>,
linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v4 05/13] iommu/rockchip: Use iopoll helpers to wait for hardware
Date: Thu, 18 Jan 2018 13:09:27 +0000 [thread overview]
Message-ID: <064794b9-98ae-221e-76bd-e11130514826@arm.com> (raw)
In-Reply-To: <20180118115251.5542-6-jeffy.chen@rock-chips.com>
On 18/01/18 11:52, Jeffy Chen wrote:
> From: Tomasz Figa <tfiga@chromium.org>
>
> This patch converts the rockchip-iommu driver to use the in-kernel
> iopoll helpers to wait for certain status bits to change in registers
> instead of an open-coded custom macro.
>
> Signed-off-by: Tomasz Figa <tfiga@chromium.org>
> Signed-off-by: Jeffy Chen <jeffy.chen@rock-chips.com>
> ---
>
> Changes in v4: None
> Changes in v3: None
> Changes in v2: None
>
> drivers/iommu/rockchip-iommu.c | 68 ++++++++++++++++++++----------------------
> 1 file changed, 32 insertions(+), 36 deletions(-)
>
> diff --git a/drivers/iommu/rockchip-iommu.c b/drivers/iommu/rockchip-iommu.c
> index 37065a7127c9..4a1c710408af 100644
> --- a/drivers/iommu/rockchip-iommu.c
> +++ b/drivers/iommu/rockchip-iommu.c
> @@ -13,7 +13,7 @@
> #include <linux/interrupt.h>
> #include <linux/io.h>
> #include <linux/iommu.h>
> -#include <linux/jiffies.h>
> +#include <linux/iopoll.h>
> #include <linux/list.h>
> #include <linux/mm.h>
> #include <linux/module.h>
> @@ -36,7 +36,8 @@
> #define RK_MMU_AUTO_GATING 0x24
>
> #define DTE_ADDR_DUMMY 0xCAFEBABE
> -#define FORCE_RESET_TIMEOUT 100 /* ms */
> +#define FORCE_RESET_TIMEOUT 100000 /* us */
> +#define POLL_TIMEOUT 1000 /* us */
Nit: the callsites look a bit odd with the combination of POLL_TIMEOUT
and the magic number 100 - should we not also define something like
POLL_PERIOD for that? Also POLL_TIMEOUT is a rather generic name and
overlaps with several other drivers, so a namespace prefix would be
helpful (i.e. RK_IOMMU_POLL*, or at least RK_POLL*).
FWIW, my personal preference would be to also suffix these with _US for
absolute clarity, but it's not essential (especially if longer names
lead to more linebreaks at the callsites).
With those undocumented "100"s fixed up,
Reviewed-by: Robin Murphy <robin.murphy@arm.com>
> /* RK_MMU_STATUS fields */
> #define RK_MMU_STATUS_PAGING_ENABLED BIT(0)
> @@ -73,8 +74,6 @@
> */
> #define RK_IOMMU_PGSIZE_BITMAP 0x007ff000
>
> -#define IOMMU_REG_POLL_COUNT_FAST 1000
> -
> struct rk_iommu_domain {
> struct list_head iommus;
> struct platform_device *pdev;
> @@ -109,27 +108,6 @@ static struct rk_iommu_domain *to_rk_domain(struct iommu_domain *dom)
> return container_of(dom, struct rk_iommu_domain, domain);
> }
>
> -/**
> - * Inspired by _wait_for in intel_drv.h
> - * This is NOT safe for use in interrupt context.
> - *
> - * Note that it's important that we check the condition again after having
> - * timed out, since the timeout could be due to preemption or similar and
> - * we've never had a chance to check the condition before the timeout.
> - */
> -#define rk_wait_for(COND, MS) ({ \
> - unsigned long timeout__ = jiffies + msecs_to_jiffies(MS) + 1; \
> - int ret__ = 0; \
> - while (!(COND)) { \
> - if (time_after(jiffies, timeout__)) { \
> - ret__ = (COND) ? 0 : -ETIMEDOUT; \
> - break; \
> - } \
> - usleep_range(50, 100); \
> - } \
> - ret__; \
> -})
> -
> /*
> * The Rockchip rk3288 iommu uses a 2-level page table.
> * The first level is the "Directory Table" (DT).
> @@ -333,9 +311,21 @@ static bool rk_iommu_is_paging_enabled(struct rk_iommu *iommu)
> return enable;
> }
>
> +static bool rk_iommu_is_reset_done(struct rk_iommu *iommu)
> +{
> + bool done = true;
> + int i;
> +
> + for (i = 0; i < iommu->num_mmu; i++)
> + done &= rk_iommu_read(iommu->bases[i], RK_MMU_DTE_ADDR) == 0;
> +
> + return done;
> +}
> +
> static int rk_iommu_enable_stall(struct rk_iommu *iommu)
> {
> int ret, i;
> + bool val;
>
> if (rk_iommu_is_stall_active(iommu))
> return 0;
> @@ -346,7 +336,8 @@ static int rk_iommu_enable_stall(struct rk_iommu *iommu)
>
> rk_iommu_command(iommu, RK_MMU_CMD_ENABLE_STALL);
>
> - ret = rk_wait_for(rk_iommu_is_stall_active(iommu), 1);
> + ret = readx_poll_timeout(rk_iommu_is_stall_active, iommu, val,
> + val, 100, POLL_TIMEOUT);
> if (ret)
> for (i = 0; i < iommu->num_mmu; i++)
> dev_err(iommu->dev, "Enable stall request timed out, status: %#08x\n",
> @@ -358,13 +349,15 @@ static int rk_iommu_enable_stall(struct rk_iommu *iommu)
> static int rk_iommu_disable_stall(struct rk_iommu *iommu)
> {
> int ret, i;
> + bool val;
>
> if (!rk_iommu_is_stall_active(iommu))
> return 0;
>
> rk_iommu_command(iommu, RK_MMU_CMD_DISABLE_STALL);
>
> - ret = rk_wait_for(!rk_iommu_is_stall_active(iommu), 1);
> + ret = readx_poll_timeout(rk_iommu_is_stall_active, iommu, val,
> + !val, 100, POLL_TIMEOUT);
> if (ret)
> for (i = 0; i < iommu->num_mmu; i++)
> dev_err(iommu->dev, "Disable stall request timed out, status: %#08x\n",
> @@ -376,13 +369,15 @@ static int rk_iommu_disable_stall(struct rk_iommu *iommu)
> static int rk_iommu_enable_paging(struct rk_iommu *iommu)
> {
> int ret, i;
> + bool val;
>
> if (rk_iommu_is_paging_enabled(iommu))
> return 0;
>
> rk_iommu_command(iommu, RK_MMU_CMD_ENABLE_PAGING);
>
> - ret = rk_wait_for(rk_iommu_is_paging_enabled(iommu), 1);
> + ret = readx_poll_timeout(rk_iommu_is_paging_enabled, iommu, val,
> + val, 100, POLL_TIMEOUT);
> if (ret)
> for (i = 0; i < iommu->num_mmu; i++)
> dev_err(iommu->dev, "Enable paging request timed out, status: %#08x\n",
> @@ -394,13 +389,15 @@ static int rk_iommu_enable_paging(struct rk_iommu *iommu)
> static int rk_iommu_disable_paging(struct rk_iommu *iommu)
> {
> int ret, i;
> + bool val;
>
> if (!rk_iommu_is_paging_enabled(iommu))
> return 0;
>
> rk_iommu_command(iommu, RK_MMU_CMD_DISABLE_PAGING);
>
> - ret = rk_wait_for(!rk_iommu_is_paging_enabled(iommu), 1);
> + ret = readx_poll_timeout(rk_iommu_is_paging_enabled, iommu, val,
> + !val, 100, POLL_TIMEOUT);
> if (ret)
> for (i = 0; i < iommu->num_mmu; i++)
> dev_err(iommu->dev, "Disable paging request timed out, status: %#08x\n",
> @@ -413,6 +410,7 @@ static int rk_iommu_force_reset(struct rk_iommu *iommu)
> {
> int ret, i;
> u32 dte_addr;
> + bool val;
>
> if (iommu->reset_disabled)
> return 0;
> @@ -433,13 +431,11 @@ static int rk_iommu_force_reset(struct rk_iommu *iommu)
>
> rk_iommu_command(iommu, RK_MMU_CMD_FORCE_RESET);
>
> - for (i = 0; i < iommu->num_mmu; i++) {
> - ret = rk_wait_for(rk_iommu_read(iommu->bases[i], RK_MMU_DTE_ADDR) == 0x00000000,
> - FORCE_RESET_TIMEOUT);
> - if (ret) {
> - dev_err(iommu->dev, "FORCE_RESET command timed out\n");
> - return ret;
> - }
> + ret = readx_poll_timeout(rk_iommu_is_reset_done, iommu, val,
> + val, 100, FORCE_RESET_TIMEOUT);
> + if (ret) {
> + dev_err(iommu->dev, "FORCE_RESET command timed out\n");
> + return ret;
> }
>
> return 0;
>
next prev parent reply other threads:[~2018-01-18 13:09 UTC|newest]
Thread overview: 37+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-01-18 11:52 [PATCH v4 00/13] iommu/rockchip: Use OF_IOMMU Jeffy Chen
2018-01-18 11:52 ` [PATCH v4 01/13] iommu/rockchip: Prohibit unbind and remove Jeffy Chen
2018-01-18 11:52 ` [PATCH v4 02/13] iommu/rockchip: Fix error handling in probe Jeffy Chen
2018-01-18 11:52 ` [PATCH v4 03/13] iommu/rockchip: Request irqs in rk_iommu_probe() Jeffy Chen
2018-01-18 11:52 ` [PATCH v4 04/13] iommu/rockchip: Fix error handling in attach Jeffy Chen
2018-01-18 13:23 ` Robin Murphy
2018-01-18 14:22 ` JeffyChen
2018-01-18 11:52 ` [PATCH v4 05/13] iommu/rockchip: Use iopoll helpers to wait for hardware Jeffy Chen
2018-01-18 13:09 ` Robin Murphy [this message]
2018-01-18 14:11 ` JeffyChen
2018-01-18 11:52 ` [PATCH v4 06/13] iommu/rockchip: Fix TLB flush of secondary IOMMUs Jeffy Chen
2018-01-18 11:52 ` [PATCH v4 07/13] ARM: dts: rockchip: add clocks in vop iommu nodes Jeffy Chen
2018-01-19 3:23 ` Tomasz Figa
2018-01-19 4:55 ` JeffyChen
2018-01-19 5:12 ` Tomasz Figa
2018-01-18 11:52 ` [PATCH v4 08/13] iommu/rockchip: Control clocks needed to access the IOMMU Jeffy Chen
2018-01-18 12:27 ` Robin Murphy
2018-01-18 14:25 ` JeffyChen
2018-01-22 1:18 ` Randy Li
2018-01-22 2:15 ` JeffyChen
2018-01-22 4:09 ` JeffyChen
2018-01-24 9:51 ` Tomasz Figa
2018-01-25 9:42 ` Randy Li
2018-01-25 10:24 ` JeffyChen
2018-02-23 10:36 ` JeffyChen
2018-01-18 11:52 ` [PATCH v4 09/13] iommu/rockchip: Use IOMMU device for dma mapping operations Jeffy Chen
2018-01-18 12:35 ` Robin Murphy
2018-01-18 11:52 ` [PATCH v4 10/13] iommu/rockchip: Use OF_IOMMU to attach devices automatically Jeffy Chen
2018-01-18 12:46 ` Robin Murphy
2018-01-18 11:52 ` [PATCH v4 11/13] iommu/rockchip: Fix error handling in init Jeffy Chen
2018-01-18 12:47 ` Robin Murphy
2018-01-18 11:52 ` [PATCH v4 12/13] iommu/rockchip: Add runtime PM support Jeffy Chen
2018-01-19 4:01 ` Tomasz Figa
2018-01-18 11:52 ` [PATCH v4 13/13] iommu/rockchip: Support sharing IOMMU between masters Jeffy Chen
2018-01-18 12:49 ` Robin Murphy
2018-01-18 12:44 ` [PATCH v4 00/13] iommu/rockchip: Use OF_IOMMU Joerg Roedel
2018-01-18 14:07 ` JeffyChen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=064794b9-98ae-221e-76bd-e11130514826@arm.com \
--to=robin.murphy@arm.com \
--cc=heiko@sntech.de \
--cc=iommu@lists.linux-foundation.org \
--cc=jcliang@chromium.org \
--cc=jeffy.chen@rock-chips.com \
--cc=joro@8bytes.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=tfiga@chromium.org \
--cc=xxm@rock-chips.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®