From: Santosh Shilimkar <santosh.shilimkar@oracle.com>
To: Bjorn Andersson <bjorn.andersson@linaro.org>, ssantosh@kernel.org
Cc: Lee Jones <lee.jones@linaro.org>,
linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org, kernel@stlinux.com,
patrice.chotard@st.com, ohad@wizery.com,
linux-remoteproc@vger.kernel.org, ludovic.barre@st.com,
s-anna@ti.com
Subject: Re: [PATCH 2/2] remoteproc: core: Rework obtaining a rproc from a DT phandle
Date: Wed, 10 Aug 2016 11:27:02 -0700 [thread overview]
Message-ID: <06677af9-e994-6bb4-98b0-c0434340b092@oracle.com> (raw)
In-Reply-To: <20160810171546.GN26240@tuxbot>
+Suman,
On 8/10/2016 10:15 AM, Bjorn Andersson wrote:
> On Tue 19 Jul 08:49 PDT 2016, Lee Jones wrote:
>
>> In this patch we;
>> - Use a subsystem generic phandle to obtain an rproc
>> - We have to support TI's bespoke version for the time being
>> - Convert wkup_m3_ipc driver to new API
>> - Rename the call to be more like other, similar OF calls
>> - Move feature-not-enabled inline stub to the headers
>> - Strip out duplicate code by calling into of_get_rproc_by_index()
>>
>> Signed-off-by: Lee Jones <lee.jones@linaro.org>
>> ---
>> drivers/remoteproc/remoteproc_core.c | 41 ++++++++----------------------------
>> drivers/soc/ti/wkup_m3_ipc.c | 14 +++---------
>> include/linux/remoteproc.h | 4 ++--
>> 3 files changed, 14 insertions(+), 45 deletions(-)
>>
> [..]
>> diff --git a/drivers/soc/ti/wkup_m3_ipc.c b/drivers/soc/ti/wkup_m3_ipc.c
>> index 8823cc8..15481f3 100644
>> --- a/drivers/soc/ti/wkup_m3_ipc.c
>> +++ b/drivers/soc/ti/wkup_m3_ipc.c
>> @@ -385,7 +385,6 @@ static int wkup_m3_ipc_probe(struct platform_device *pdev)
>> {
>> struct device *dev = &pdev->dev;
>> int irq, ret;
>> - phandle rproc_phandle;
>> struct rproc *m3_rproc;
>> struct resource *res;
>> struct task_struct *task;
>> @@ -430,16 +429,9 @@ static int wkup_m3_ipc_probe(struct platform_device *pdev)
>> return PTR_ERR(m3_ipc->mbox);
>> }
>>
>> - if (of_property_read_u32(dev->of_node, "ti,rproc", &rproc_phandle)) {
>> - dev_err(&pdev->dev, "could not get rproc phandle\n");
>> - ret = -ENODEV;
>> - goto err_free_mbox;
>> - }
>> -
>> - m3_rproc = rproc_get_by_phandle(rproc_phandle);
>> - if (!m3_rproc) {
>> - dev_err(&pdev->dev, "could not get rproc handle\n");
>> - ret = -EPROBE_DEFER;
>> + m3_rproc = of_get_rproc_by_phandle(dev->of_node);
>> + if (IS_ERR(m3_rproc)) {
>> + ret = PTR_ERR(m3_rproc);
>> goto err_free_mbox;
>> }
>>
>
> Santosh, do you have any objections to me merging this?
>
This looks ok to me but I have not been merdging the remote
proc code. Looping Suman who IIRC, was looking at it along
with Ohad.
> of_get_rproc_by_phandle() will fall back and attempt to acquire the
> handle from ti,rproc if the generic "rprocs" property doesn't exist.
>
Suman,
Can you please check this series and see if you can line this up ?
Am not sure if Ohad still maintaining it.
Regards,
Santosh
next prev parent reply other threads:[~2016-08-10 20:14 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-07-19 15:49 [PATCH 1/2] remoteproc: core: Add rproc OF look-up functions Lee Jones
2016-07-19 15:49 ` [PATCH 2/2] remoteproc: core: Rework obtaining a rproc from a DT phandle Lee Jones
2016-08-10 17:15 ` Bjorn Andersson
2016-08-10 18:27 ` Santosh Shilimkar [this message]
2016-08-10 20:31 ` Bjorn Andersson
2016-08-11 18:40 ` Bjorn Andersson
2016-08-10 17:40 ` [PATCH 1/2] remoteproc: core: Add rproc OF look-up functions Bjorn Andersson
2016-08-10 19:37 ` Suman Anna
2016-08-10 20:40 ` Bjorn Andersson
2016-08-10 21:04 ` Suman Anna
2016-08-10 21:19 ` Bjorn Andersson
2016-08-10 22:44 ` Suman Anna
2016-08-11 7:31 ` Lee Jones
2016-08-11 16:04 ` Suman Anna
2016-08-11 16:23 ` Suman Anna
2016-08-12 16:37 ` Suman Anna
2016-08-12 18:07 ` Bjorn Andersson
2016-08-12 18:45 ` Suman Anna
2016-08-15 13:55 ` Lee Jones
2016-08-11 18:23 ` Bjorn Andersson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=06677af9-e994-6bb4-98b0-c0434340b092@oracle.com \
--to=santosh.shilimkar@oracle.com \
--cc=bjorn.andersson@linaro.org \
--cc=kernel@stlinux.com \
--cc=lee.jones@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-remoteproc@vger.kernel.org \
--cc=ludovic.barre@st.com \
--cc=ohad@wizery.com \
--cc=patrice.chotard@st.com \
--cc=s-anna@ti.com \
--cc=ssantosh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®