mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Huang, Kai" <kai.huang@intel.com>
To: "pbonzini@redhat.com" <pbonzini@redhat.com>,
	"kas@kernel.org" <kas@kernel.org>,
	"seanjc@google.com" <seanjc@google.com>,
	"vkuznets@redhat.com" <vkuznets@redhat.com>,
	"dwmw2@infradead.org" <dwmw2@infradead.org>,
	"paul@xen.org" <paul@xen.org>
Cc: "Edgecombe, Rick P" <rick.p.edgecombe@intel.com>,
	"x86@kernel.org" <x86@kernel.org>,
	"binbin.wu@linux.intel.com" <binbin.wu@linux.intel.com>,
	"dave.hansen@linux.intel.com" <dave.hansen@linux.intel.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"yosry@kernel.org" <yosry@kernel.org>,
	"kvm@vger.kernel.org" <kvm@vger.kernel.org>,
	"linux-coco@lists.linux.dev" <linux-coco@lists.linux.dev>
Subject: Re: [PATCH v2 15/15] KVM: x86: Move the bulk of register specific code from x86.c to regs.c
Date: Tue, 19 May 2026 12:16:39 +0000	[thread overview]
Message-ID: <074e209fe4c78a735868099f13d76b9dde2c88e3.camel@intel.com> (raw)
In-Reply-To: <20260514215355.1648463-16-seanjc@google.com>


> +void kvm_run_get_regs(struct kvm_vcpu *vcpu)
> +{
> +	BUILD_BUG_ON(sizeof(struct kvm_sync_regs) > SYNC_REGS_SIZE_BYTES);
> +
> +	if (vcpu->run->kvm_valid_regs & KVM_SYNC_X86_REGS)
> +		__get_regs(vcpu, &vcpu->run->s.regs.regs);
> +
> +	if (vcpu->run->kvm_valid_regs & KVM_SYNC_X86_SREGS)
> +		__get_sregs(vcpu, &vcpu->run->s.regs.sregs);
> +}
> +
> +int kvm_run_set_regs(struct kvm_vcpu *vcpu)
> +{
> +	if (vcpu->run->kvm_dirty_regs & KVM_SYNC_X86_REGS) {
> +		__set_regs(vcpu, &vcpu->run->s.regs.regs);
> +		vcpu->run->kvm_dirty_regs &= ~KVM_SYNC_X86_REGS;
> +	}
> +
> +	if (vcpu->run->kvm_dirty_regs & KVM_SYNC_X86_SREGS) {
> +		struct kvm_sregs sregs = vcpu->run->s.regs.sregs;
> +
> +		if (__set_sregs(vcpu, &sregs))
> +			return -EINVAL;
> +
> +		vcpu->run->kvm_dirty_regs &= ~KVM_SYNC_X86_SREGS;
> +	}
> +
> +	return 0;
> +}
> 

[...]

> @@ -12699,11 +11904,7 @@ static void store_regs(struct kvm_vcpu *vcpu)
>  {
>  	BUILD_BUG_ON(sizeof(struct kvm_sync_regs) > SYNC_REGS_SIZE_BYTES);
>  
> -	if (vcpu->run->kvm_valid_regs & KVM_SYNC_X86_REGS)
> -		__get_regs(vcpu, &vcpu->run->s.regs.regs);
> -
> -	if (vcpu->run->kvm_valid_regs & KVM_SYNC_X86_SREGS)
> -		__get_sregs(vcpu, &vcpu->run->s.regs.sregs);
> +	kvm_run_get_regs(vcpu);
>  
>  	if (vcpu->run->kvm_valid_regs & KVM_SYNC_X86_EVENTS)
>  		kvm_vcpu_ioctl_x86_get_vcpu_events(
> @@ -12712,19 +11913,8 @@ static void store_regs(struct kvm_vcpu *vcpu)
>  
>  static int sync_regs(struct kvm_vcpu *vcpu)
>  {
> -	if (vcpu->run->kvm_dirty_regs & KVM_SYNC_X86_REGS) {
> -		__set_regs(vcpu, &vcpu->run->s.regs.regs);
> -		vcpu->run->kvm_dirty_regs &= ~KVM_SYNC_X86_REGS;
> -	}
> -
> -	if (vcpu->run->kvm_dirty_regs & KVM_SYNC_X86_SREGS) {
> -		struct kvm_sregs sregs = vcpu->run->s.regs.sregs;
> -
> -		if (__set_sregs(vcpu, &sregs))
> -			return -EINVAL;
> -
> -		vcpu->run->kvm_dirty_regs &= ~KVM_SYNC_X86_SREGS;
> -	}
> +	if (kvm_run_set_regs(vcpu))
> +		return -EINVAL;

Nit:

Do you think 'kvm_run_sync_regs()' is better than 'kvm_run_set_regs()'?

Because I think "sync" reflects better that vcpu->run->kvm_dirty_regs is cleared
after the "set" operation.

>  
>  	if (vcpu->run->kvm_dirty_regs & KVM_SYNC_X86_EVENTS) {
>  		struct kvm_vcpu_events events = vcpu->run->s.regs.events;

Also, I wonder whether it's better to add a helper for events so sync_regs() and
store_regs() can be simplified to:

static int sync_regs(struct kvm_vcpu *vcpu)
{
	if (kvm_run_sync_regs(vcpu))
		return -EINVAL;
	return kvm_run_sync_events(vcpu);
}

static void store_regs(struct kvm_vcpu *vcpu)
{
	kvm_run_get_regs(vcpu);
	kvm_run_get_events(vcpu);
}

And maybe 'kvm_run_get_regs()' could be 'kvm_run_store_regs()' too , so that the
store_regs() could be:

static void store_regs(struct kvm_vcpu *vcpu)
{
	kvm_run_store_regs(vcpu);
	kvm_run_store_events(vcpu);
}

> diff --git a/arch/x86/kvm/x86.h b/arch/x86/kvm/x86.h
> index 185062a26924..fd55cd031b1c 100644
> --- a/arch/x86/kvm/x86.h
> +++ b/arch/x86/kvm/x86.h
> @@ -414,6 +414,7 @@ int handle_ud(struct kvm_vcpu *vcpu);
>  
>  void kvm_deliver_exception_payload(struct kvm_vcpu *vcpu,
>  				   struct kvm_queued_exception *ex);
> +void kvm_handle_exception_payload_quirk(struct kvm_vcpu *vcpu);
>  
>  int kvm_mtrr_set_msr(struct kvm_vcpu *vcpu, u32 msr, u64 data);
>  int kvm_mtrr_get_msr(struct kvm_vcpu *vcpu, u32 msr, u64 *pdata);
> @@ -604,6 +605,7 @@ static inline void kvm_machine_check(void)
>  int kvm_spec_ctrl_test_value(u64 value);
>  int kvm_handle_memory_failure(struct kvm_vcpu *vcpu, int r,
>  			      struct x86_exception *e);
> +void kvm_invalidate_pcid(struct kvm_vcpu *vcpu, unsigned long pcid);
> 

If I read correct, this is because "regs.c" calls kvm_invalidate_pcid() but you
want to keep it in x86.c.  But it seems the "x86.h" isn't included by "regs.c"
directly but via other headers ("mmu.h" does include "x86.h").

Should the "regs.c" include "x86.h" directly?

Btw, I am a bit confused the relationship between "x86.h" and other headers like
"mmu.h" and the new "regs.h".  That is, headers like "mmu.h" include "x86.h",
but headers like "regs.h" do not (instead, "x86.h" includes them).

  reply	other threads:[~2026-05-19 12:16 UTC|newest]

Thread overview: 52+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-05-14 21:53 [PATCH v2 00/15] KVM: x86: Clean up kvm_<reg>_{read,write}() mess Sean Christopherson
2026-05-14 21:53 ` [PATCH v2 01/15] KVM: SVM: Truncate INVLPGA address in compatibility mode Sean Christopherson
2026-05-15  6:36   ` Binbin Wu
2026-05-14 21:53 ` [PATCH v2 02/15] KVM: x86/xen: Bug the VM if 32-bit KVM observes a 64-bit mode hypercall Sean Christopherson
2026-05-15  6:46   ` Binbin Wu
2026-05-14 21:53 ` [PATCH v2 03/15] KVM: x86/xen: Don't truncate RAX when handling hypercall from protected guest Sean Christopherson
2026-05-15  7:21   ` Binbin Wu
2026-05-15 12:55     ` Sean Christopherson
2026-05-18  2:19       ` Binbin Wu
2026-05-18  7:15         ` David Woodhouse
2026-05-18  9:43           ` Binbin Wu
2026-05-18  9:50             ` David Woodhouse
2026-05-18  9:55               ` Binbin Wu
2026-05-20  5:02                 ` Binbin Wu
2026-05-20  8:27                   ` David Woodhouse
2026-06-04 21:48                 ` David Woodhouse
2026-05-20  8:32   ` David Woodhouse
2026-05-14 21:53 ` [PATCH v2 04/15] KVM: VMX: Read 32-bit GPR values for ENCLS instructions outside of 64-bit mode Sean Christopherson
2026-05-15  7:26   ` Binbin Wu
2026-05-14 21:53 ` [PATCH v2 05/15] KVM: x86: Trace hypercall register *after* truncating values for 32-bit Sean Christopherson
2026-05-15  7:32   ` Binbin Wu
2026-05-14 21:53 ` [PATCH v2 06/15] KVM: x86: Rename kvm_cache_regs.h => regs.h Sean Christopherson
2026-05-14 22:28   ` Yosry Ahmed
2026-05-15  7:45   ` Binbin Wu
2026-05-14 21:53 ` [PATCH v2 07/15] KVM: x86: Move inlined CR and DR helpers from x86.h to regs.h Sean Christopherson
2026-05-14 22:30   ` Yosry Ahmed
2026-05-15  8:07   ` Binbin Wu
2026-05-14 21:53 ` [PATCH v2 08/15] KVM: x86: Add mode-aware versions of kvm_<reg>_{read,write}() helpers Sean Christopherson
2026-05-15  8:46   ` Binbin Wu
2026-05-18 11:31   ` Huang, Kai
2026-05-18 20:51     ` Sean Christopherson
2026-05-18 22:29       ` Huang, Kai
2026-05-18 23:44       ` Huang, Kai
2026-05-14 21:53 ` [PATCH v2 09/15] KVM: x86: Drop non-raw kvm_<reg>_write() helpers Sean Christopherson
2026-05-15  9:11   ` Binbin Wu
2026-05-14 21:53 ` [PATCH v2 10/15] KVM: nSVM: Use kvm_rax_read() now that it's mode-aware Sean Christopherson
2026-05-14 21:53 ` [PATCH v2 11/15] Revert "KVM: VMX: Read 32-bit GPR values for ENCLS instructions outside of 64-bit mode" Sean Christopherson
2026-05-15  9:26   ` Binbin Wu
2026-05-14 21:53 ` [PATCH v2 12/15] KVM: x86: Harden is_64_bit_hypercall() against bugs on 32-bit kernels Sean Christopherson
2026-05-15  9:31   ` Binbin Wu
2026-05-14 21:53 ` [PATCH v2 13/15] KVM: x86: Move update_cr8_intercept() to lapic.c Sean Christopherson
2026-05-14 21:53 ` [PATCH v2 14/15] KVM: x86: Move kvm_pv_async_pf_enabled() to x86.h (as an inline) Sean Christopherson
2026-05-14 21:53 ` [PATCH v2 15/15] KVM: x86: Move the bulk of register specific code from x86.c to regs.c Sean Christopherson
2026-05-19 12:16   ` Huang, Kai [this message]
2026-05-19 15:04     ` Sean Christopherson
2026-05-20  0:59       ` Huang, Kai
2026-05-20  1:25         ` Sean Christopherson
2026-05-20  2:29           ` Huang, Kai
2026-05-20 18:11             ` Sean Christopherson
2026-05-20 22:22               ` Huang, Kai
2026-05-21 18:47                 ` Sean Christopherson
2026-05-14 22:31 ` [PATCH v2 00/15] KVM: x86: Clean up kvm_<reg>_{read,write}() mess Yosry Ahmed

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=074e209fe4c78a735868099f13d76b9dde2c88e3.camel@intel.com \
    --to=kai.huang@intel.com \
    --cc=binbin.wu@linux.intel.com \
    --cc=dave.hansen@linux.intel.com \
    --cc=dwmw2@infradead.org \
    --cc=kas@kernel.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-coco@lists.linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=paul@xen.org \
    --cc=pbonzini@redhat.com \
    --cc=rick.p.edgecombe@intel.com \
    --cc=seanjc@google.com \
    --cc=vkuznets@redhat.com \
    --cc=x86@kernel.org \
    --cc=yosry@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome