From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from foss.arm.com (foss.arm.com [217.140.110.172]) by smtp.subspace.kernel.org (Postfix) with ESMTP id BE4A619D88F; Thu, 11 Sep 2025 16:20:21 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=217.140.110.172 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1757607623; cv=none; b=THvRF4n+Sb2N6Yrjw1/SUYS7tVSKdUFj8TmnAjsmDkNkEWb0KMutE7r/MA70KOwO7EbWTO83K1hhbNmrdZ4naoTAUsN4zNIVy3YGL8C5Yy0Ft58j48s1PknD96VlIWAwhTjnSgGgiHIT8FXJCb7pTsX4VeXyBNjv8Hcajx2k/Z0= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1757607623; c=relaxed/simple; bh=MUCy2q9vMw8ioDr48jZmAFItWaAOEsqUD4pLsZQbVHo=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=SlRsic5ZjppT3DAqstveAlmQgiU6Y7q/0f2QC1y2cdMdxF9NyvvO0RAaSOMuI9kV5l8560V571R/EkDlnt0oL6kYyk6Wqf5ADxLWaQmfMTmXdiiD7fHRJwqqSTL6y31GmhAsabVvD8rAoAZGRzNA7cy4FaiHSgCFaSPkZVLyEv8= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=arm.com; spf=pass smtp.mailfrom=arm.com; arc=none smtp.client-ip=217.140.110.172 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=arm.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=arm.com Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14]) by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id D43CB1756; Thu, 11 Sep 2025 09:20:12 -0700 (PDT) Received: from [10.57.70.14] (unknown [10.57.70.14]) by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id 462913F694; Thu, 11 Sep 2025 09:20:14 -0700 (PDT) Message-ID: <076c7f16-fe56-49a8-910e-7d71d3f8f0b4@arm.com> Date: Thu, 11 Sep 2025 18:20:11 +0200 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH v2 2/7] mm: introduce local state for lazy_mmu sections To: Alexander Gordeev Cc: David Hildenbrand , linux-mm@kvack.org, linux-kernel@vger.kernel.org, Andreas Larsson , Andrew Morton , Boris Ostrovsky , Borislav Petkov , Catalin Marinas , Christophe Leroy , Dave Hansen , "David S. Miller" , "H. Peter Anvin" , Ingo Molnar , Jann Horn , Juergen Gross , "Liam R. Howlett" , Lorenzo Stoakes , Madhavan Srinivasan , Michael Ellerman , Michal Hocko , Mike Rapoport , Nicholas Piggin , Peter Zijlstra , Ryan Roberts , Suren Baghdasaryan , Thomas Gleixner , Vlastimil Babka , Will Deacon , Yeoreum Yun , linux-arm-kernel@lists.infradead.org, linuxppc-dev@lists.ozlabs.org, sparclinux@vger.kernel.org, xen-devel@lists.xenproject.org, Mark Rutland References: <20250908073931.4159362-1-kevin.brodsky@arm.com> <20250908073931.4159362-3-kevin.brodsky@arm.com> <2fecfae7-1140-4a23-a352-9fd339fcbae5-agordeev@linux.ibm.com> <47ee1df7-1602-4200-af94-475f84ca8d80@arm.com> <250835cd-f07a-4b8a-bc01-ace24b407efc@arm.com> <80be36e5-d6e1-4b37-a1ca-47e92ac21b02-agordeev@linux.ibm.com> Content-Language: en-GB From: Kevin Brodsky In-Reply-To: <80be36e5-d6e1-4b37-a1ca-47e92ac21b02-agordeev@linux.ibm.com> Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit On 11/09/2025 14:06, Alexander Gordeev wrote: > On Wed, Sep 10, 2025 at 06:11:54PM +0200, Kevin Brodsky wrote: > > Hi Kevin, > >> On 09/09/2025 16:38, Alexander Gordeev wrote: >>>>>>> Would that integrate well with LAZY_MMU_DEFAULT etc? >>>>>> Hmm... I though the idea is to use LAZY_MMU_* by architectures that >>>>>> want to use it - at least that is how I read the description above. >>>>>> >>>>>> It is only kasan_populate|depopulate_vmalloc_pte() in generic code >>>>>> that do not follow this pattern, and it looks as a problem to me. >>>> This discussion also made me realise that this is problematic, as the >>>> LAZY_MMU_{DEFAULT,NESTED} macros were meant only for architectures' >>>> convenience, not for generic code (where lazy_mmu_state_t should ideally >>>> be an opaque type as mentioned above). It almost feels like the kasan >>>> case deserves a different API, because this is not how enter() and >>>> leave() are meant to be used. This would mean quite a bit of churn >>>> though, so maybe just introduce another arch-defined value to pass to >>>> leave() for such a situation - for instance, >>>> arch_leave_lazy_mmu_mode(LAZY_MMU_FLUSH)? >>> What about to adjust the semantics of apply_to_page_range() instead? >>> >>> It currently assumes any caller is fine with apply_to_pte_range() to >>> enter the lazy mode. By contrast, kasan_(de)populate_vmalloc_pte() are >>> not fine at all and must leave the lazy mode. That literally suggests >>> the original assumption is incorrect. >>> >>> We could change int apply_to_pte_range(..., bool create, ...) to e.g. >>> apply_to_pte_range(..., unsigned int flags, ...) and introduce a flag >>> that simply skips entering the lazy mmu mode. >> This is pretty much what Ryan proposed [1r] some time ago, although for >> a different purpose (avoiding nesting). There wasn't much appetite for >> it then, but I agree that this would be a more logical way to go about it. >> >> - Kevin >> >> [1r] >> https://lore.kernel.org/all/20250530140446.2387131-4-ryan.roberts@arm.com/ > May be I missing the point, but I read it as an opposition to the whole > series in general and to the way apply_to_pte_range() would be altered > in particular: > > static int apply_to_pte_range(struct mm_struct *mm, pmd_t *pmd, > unsigned long addr, unsigned long end, > pte_fn_t fn, void *data, bool create, > - pgtbl_mod_mask *mask) > + pgtbl_mod_mask *mask, bool lazy_mmu) > > The idea of instructing apply_to_page_range() to skip the lazy mmu mode > was not countered. Quite opposite, Liam suggested exactly the same: Yes that's a fair point. It would be sensible to post a new series trying to eliminate the leave()/enter() calls in mm/kasan as you suggested. Still I think that it makes sense to define an API to handle that situation ("pausing" lazy_mmu), as discussed with David H. - Kevin > > > Could we do something like the pgtbl_mod_mask or zap_details and pass > through a struct or one unsigned int for create and lazy_mmu? > > These wrappers are terrible for readability and annoying for argument > lists too. > > Could we do something like the pgtbl_mod_mask or zap_details and pass > through a struct or one unsigned int for create and lazy_mmu? > > At least we'd have better self-documenting code in the wrappers.. and if > we ever need a third boolean, we could avoid multiplying the wrappers > again. > > > Thanks!