From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S937416AbdAFRSv (ORCPT ); Fri, 6 Jan 2017 12:18:51 -0500 Received: from mx1.redhat.com ([209.132.183.28]:56912 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S936306AbdAFRSl (ORCPT ); Fri, 6 Jan 2017 12:18:41 -0500 Subject: Re: [PATCH v6 07/18] iommu: Implement reserved_regions iommu-group sysfs file To: Joerg Roedel References: <1483643086-2883-1-git-send-email-eric.auger@redhat.com> <1483643086-2883-8-git-send-email-eric.auger@redhat.com> <20170106110039.GL17255@8bytes.org> <888d3750-817c-77d1-8154-e77cf8c3ad4b@redhat.com> <20170106124816.GQ17255@8bytes.org> Cc: eric.auger.pro@gmail.com, christoffer.dall@linaro.org, marc.zyngier@arm.com, robin.murphy@arm.com, alex.williamson@redhat.com, will.deacon@arm.com, tglx@linutronix.de, jason@lakedaemon.net, linux-arm-kernel@lists.infradead.org, kvm@vger.kernel.org, drjones@redhat.com, linux-kernel@vger.kernel.org, pranav.sawargaonkar@gmail.com, iommu@lists.linux-foundation.org, punit.agrawal@arm.com, diana.craciun@nxp.com, gpkulkarni@gmail.com, shankerd@codeaurora.org, bharat.bhushan@nxp.com, geethasowjanya.akula@gmail.com From: Auger Eric Message-ID: <0858b719-2888-0645-66d2-56fe698f4e2f@redhat.com> Date: Fri, 6 Jan 2017 18:18:33 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.4.0 MIME-Version: 1.0 In-Reply-To: <20170106124816.GQ17255@8bytes.org> Content-Type: text/plain; charset=windows-1252 Content-Transfer-Encoding: 7bit X-Greylist: Sender IP whitelisted, not delayed by milter-greylist-4.5.16 (mx1.redhat.com [10.5.110.26]); Fri, 06 Jan 2017 17:18:41 +0000 (UTC) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Joerg, Robin, On 06/01/2017 13:48, Joerg Roedel wrote: > On Fri, Jan 06, 2017 at 12:46:05PM +0100, Auger Eric wrote: >> On 06/01/2017 12:00, Joerg Roedel wrote: > >>> I think it also makes sense to report the type of the reserved region. >> >> What is the best practice in that case? Shall we put the type enum >> values as strings such as: >> - direct >> - nomap >> - msi >> >> and document that in Documentation/ABI/testing/sysfs-kernel-iommu_groups > > Yes, a string would be good. An probably 'reserved' is a better name > than nomap? the iommu_insert_resv_region() function that builds the group reserved region list sorts all regions and handles the case where there is an overlap between regions. Current code does not care about the type of regions. So in case a NOMAP region overlaps with a direct-mapped region, what is reported to the user space is the superset and the type depends on the overlap. This was suggested by Robin at some point to handle overlaps. I guess I should merge regions only in case the types equal? I remember that Alex thought that user-space should not care so much about the type of the regions so I tought it was better for the user-space to have a minimal view of the regions. On the other hand, this issue of merging regions of different types should not happen often but I prefer to highlight the potential issue. What is your guidance? Thanks Eric > > > Joerg >