From: Hans Zhang <18255117159@163.com>
To: kernel test robot <lkp@intel.com>,
lpieralisi@kernel.org, bhelgaas@google.com
Cc: oe-kbuild-all@lists.linux.dev, kw@linux.com,
manivannan.sadhasivam@linaro.org, ilpo.jarvinen@linux.intel.com,
robh@kernel.org, jingoohan1@gmail.com,
thomas.richard@bootlin.com, linux-pci@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v9 4/6] PCI: dwc: Use common PCI host bridge APIs for finding the capabilities
Date: Thu, 10 Apr 2025 14:56:48 +0800 [thread overview]
Message-ID: <085d0e48-436d-46af-8bdf-8477169e8939@163.com> (raw)
In-Reply-To: <202504101228.CX8tAgfW-lkp@intel.com>
On 2025/4/10 14:02, kernel test robot wrote:
> Hi Hans,
>
> kernel test robot noticed the following build errors:
>
> [auto build test ERROR on a24588245776dafc227243a01bfbeb8a59bafba9]
>
> url: https://github.com/intel-lab-lkp/linux/commits/Hans-Zhang/PCI-Introduce-generic-bus-config-read-helper-function/20250409-115839
> base: a24588245776dafc227243a01bfbeb8a59bafba9
> patch link: https://lore.kernel.org/r/20250409034156.92686-5-18255117159%40163.com
> patch subject: [PATCH v9 4/6] PCI: dwc: Use common PCI host bridge APIs for finding the capabilities
> config: arc-randconfig-001-20250410 (https://download.01.org/0day-ci/archive/20250410/202504101228.CX8tAgfW-lkp@intel.com/config)
> compiler: arc-linux-gcc (GCC) 14.2.0
> reproduce (this is a W=1 build): (https://download.01.org/0day-ci/archive/20250410/202504101228.CX8tAgfW-lkp@intel.com/reproduce)
>
> If you fix the issue in a separate patch/commit (i.e. not just a new version of
> the same patch/commit), kindly add following tags
> | Reported-by: kernel test robot <lkp@intel.com>
> | Closes: https://lore.kernel.org/oe-kbuild-all/202504101228.CX8tAgfW-lkp@intel.com/
>
> All errors (new ones prefixed by >>):
>
> drivers/pci/controller/dwc/pcie-designware.c: In function '__dw_pcie_find_vsec_capability':
>>> drivers/pci/controller/dwc/pcie-designware.c:239:24: error: implicit declaration of function 'dw_pcie_find_next_ext_capability'; did you mean 'pci_find_next_ext_capability'? [-Wimplicit-function-declaration]
> 239 | while ((vsec = dw_pcie_find_next_ext_capability(pci, vsec,
> | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> | pci_find_next_ext_capability
>
>
> vim +239 drivers/pci/controller/dwc/pcie-designware.c
>
> 5b0841fa653f6c Vidya Sagar 2019-08-13 229
> efaf16de43f599 Shradha Todi 2025-02-21 230 static u16 __dw_pcie_find_vsec_capability(struct dw_pcie *pci, u16 vendor_id,
> efaf16de43f599 Shradha Todi 2025-02-21 231 u16 vsec_id)
> efaf16de43f599 Shradha Todi 2025-02-21 232 {
> efaf16de43f599 Shradha Todi 2025-02-21 233 u16 vsec = 0;
> efaf16de43f599 Shradha Todi 2025-02-21 234 u32 header;
> efaf16de43f599 Shradha Todi 2025-02-21 235
> efaf16de43f599 Shradha Todi 2025-02-21 236 if (vendor_id != dw_pcie_readw_dbi(pci, PCI_VENDOR_ID))
> efaf16de43f599 Shradha Todi 2025-02-21 237 return 0;
> efaf16de43f599 Shradha Todi 2025-02-21 238
> efaf16de43f599 Shradha Todi 2025-02-21 @239 while ((vsec = dw_pcie_find_next_ext_capability(pci, vsec,
> efaf16de43f599 Shradha Todi 2025-02-21 240 PCI_EXT_CAP_ID_VNDR))) {
> efaf16de43f599 Shradha Todi 2025-02-21 241 header = dw_pcie_readl_dbi(pci, vsec + PCI_VNDR_HEADER);
> efaf16de43f599 Shradha Todi 2025-02-21 242 if (PCI_VNDR_HEADER_ID(header) == vsec_id)
> efaf16de43f599 Shradha Todi 2025-02-21 243 return vsec;
> efaf16de43f599 Shradha Todi 2025-02-21 244 }
> efaf16de43f599 Shradha Todi 2025-02-21 245
> efaf16de43f599 Shradha Todi 2025-02-21 246 return 0;
> efaf16de43f599 Shradha Todi 2025-02-21 247 }
> efaf16de43f599 Shradha Todi 2025-02-21 248
>
I'm terribly sorry. The latest 6.15 rc1 merge
__dw_pcie_find_vsec_capability, which uses
dw_pcie_find_next_ext_capability. This should be replaced with
PCI_FIND_NEXT_CAP_TTL.
This will be changed in the next version.
Best regards,
Hans
next prev parent reply other threads:[~2025-04-10 6:57 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-04-09 3:41 [PATCH v9 0/6] Refactor capability search into common macros Hans Zhang
2025-04-09 3:41 ` [PATCH v9 1/6] PCI: Introduce generic bus config read helper function Hans Zhang
2025-04-09 3:41 ` [PATCH v9 2/6] PCI: Clean up __pci_find_next_cap_ttl() readability Hans Zhang
2025-04-09 3:41 ` [PATCH v9 3/6] PCI: Refactor capability search into common macros Hans Zhang
2025-04-09 3:41 ` [PATCH v9 4/6] PCI: dwc: Use common PCI host bridge APIs for finding the capabilities Hans Zhang
2025-04-10 6:02 ` kernel test robot
2025-04-10 6:56 ` Hans Zhang [this message]
2025-04-09 3:41 ` [PATCH v9 5/6] PCI: cadence: " Hans Zhang
2025-04-09 3:41 ` [PATCH v9 6/6] PCI: cadence: Use cdns_pcie_find_*capability to avoid hardcode Hans Zhang
2025-04-24 15:07 ` [PATCH v9 0/6] Refactor capability search into common macros Hans Zhang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=085d0e48-436d-46af-8bdf-8477169e8939@163.com \
--to=18255117159@163.com \
--cc=bhelgaas@google.com \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=jingoohan1@gmail.com \
--cc=kw@linux.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=lkp@intel.com \
--cc=lpieralisi@kernel.org \
--cc=manivannan.sadhasivam@linaro.org \
--cc=oe-kbuild-all@lists.linux.dev \
--cc=robh@kernel.org \
--cc=thomas.richard@bootlin.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®