From: Javier Martinez Canillas <javierm@redhat.com>
To: "Maxime Ripard" <maxime@cerno.tech>,
"Maíra Canal" <mairacanal@riseup.net>
Cc: michal.winiarski@intel.com, "David Gow" <davidgow@google.com>,
siqueirajordao@riseup.net, magalilemes00@gmail.com,
"David Airlie" <airlied@linux.ie>,
tales.aparecida@gmail.com, "Arthur Grillo" <arthur.grillo@usp.br>,
brendanhiggins@google.com, linux-kernel@vger.kernel.org,
mwen@igalia.com, dri-devel@lists.freedesktop.org,
kunit-dev@googlegroups.com,
"José Expósito" <jose.exposito89@gmail.com>,
"Isabella Basso" <isabbasso@riseup.net>,
andrealmeid@riseup.net
Subject: Re: [PATCH v2 2/2] drm/tests: Change "igt_" prefix to "test_drm_"
Date: Thu, 1 Sep 2022 15:17:25 +0200 [thread overview]
Message-ID: <087acab2-c230-fe5d-9ab3-2b8a18e42175@redhat.com> (raw)
In-Reply-To: <20220901125530.b56s4zisnkfuigvc@houat>
On 9/1/22 14:55, Maxime Ripard wrote:
> Hi,
>
> On Thu, Sep 01, 2022 at 09:42:10AM -0300, Maíra Canal wrote:
>> With the introduction of KUnit, IGT is no longer the only option to run
>> the DRM unit tests, as the tests can be run through kunit-tool or on
>> real hardware with CONFIG_KUNIT.
>>
>> Therefore, remove the "igt_" prefix from the tests and replace it with
>> the "test_drm_" prefix, making the tests' names independent from the tool
>> used.
>>
>> Signed-off-by: Maíra Canal <mairacanal@riseup.net>
>>
>> ---
>> v1 -> v2: https://lore.kernel.org/dri-devel/20220830211603.191734-1-mairacanal@riseup.net/
>> - Change "drm_" prefix to "test_drm_", as "drm_" can be a bit confusing (Jani Nikula).
>
> I appreciate it's a bit of a bikeshed but I disagree with this. The
> majority of the kunit tests already out there start with the framework
> name, including *all* the examples in the kunit doc. Plus, it's fairly
> obvious that it's a test, kunit is only about running tests in the first
> place.
>
Agree with Maxime on this.
--
Best regards,
Javier Martinez Canillas
Core Platforms
Red Hat
next prev parent reply other threads:[~2022-09-01 13:20 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-09-01 12:42 [PATCH v2 1/2] drm/tests: Split drm_framebuffer_create_test into parameterized tests Maíra Canal
2022-09-01 12:42 ` [PATCH v2 2/2] drm/tests: Change "igt_" prefix to "test_drm_" Maíra Canal
2022-09-01 12:55 ` Maxime Ripard
2022-09-01 13:17 ` Javier Martinez Canillas [this message]
2022-09-01 22:33 ` Maíra Canal
2022-09-02 8:04 ` Jani Nikula
2022-09-02 12:34 ` Maxime Ripard
2022-09-02 13:03 ` Jani Nikula
2022-09-02 13:38 ` Michał Winiarski
2022-09-02 13:56 ` Jani Nikula
2022-09-02 22:53 ` Maíra Canal
2022-09-05 12:10 ` Maxime Ripard
2022-09-05 13:11 ` Michał Winiarski
2022-09-05 13:37 ` Maíra Canal
2022-09-02 8:08 ` Maxime Ripard
2022-09-02 8:24 ` Jani Nikula
2022-09-02 7:52 ` [PATCH v2 1/2] drm/tests: Split drm_framebuffer_create_test into parameterized tests David Gow
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=087acab2-c230-fe5d-9ab3-2b8a18e42175@redhat.com \
--to=javierm@redhat.com \
--cc=airlied@linux.ie \
--cc=andrealmeid@riseup.net \
--cc=arthur.grillo@usp.br \
--cc=brendanhiggins@google.com \
--cc=davidgow@google.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=isabbasso@riseup.net \
--cc=jose.exposito89@gmail.com \
--cc=kunit-dev@googlegroups.com \
--cc=linux-kernel@vger.kernel.org \
--cc=magalilemes00@gmail.com \
--cc=mairacanal@riseup.net \
--cc=maxime@cerno.tech \
--cc=michal.winiarski@intel.com \
--cc=mwen@igalia.com \
--cc=siqueirajordao@riseup.net \
--cc=tales.aparecida@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®