From: Marek Szyprowski <m.szyprowski@samsung.com>
To: Leon Romanovsky <leon@kernel.org>
Cc: Leon Romanovsky <leonro@nvidia.com>,
Jason Gunthorpe <jgg@nvidia.com>,
Abdiel Janulgue <abdiel.janulgue@gmail.com>,
Alexander Potapenko <glider@google.com>,
Alex Gaynor <alex.gaynor@gmail.com>,
Andrew Morton <akpm@linux-foundation.org>,
Christoph Hellwig <hch@lst.de>,
Danilo Krummrich <dakr@kernel.org>,
David Hildenbrand <david@redhat.com>,
iommu@lists.linux.dev, Jason Wang <jasowang@redhat.com>,
Jens Axboe <axboe@kernel.dk>, Joerg Roedel <joro@8bytes.org>,
Jonathan Corbet <corbet@lwn.net>, Juergen Gross <jgross@suse.com>,
kasan-dev@googlegroups.com, Keith Busch <kbusch@kernel.org>,
linux-block@vger.kernel.org, linux-doc@vger.kernel.org,
linux-kernel@vger.kernel.org, linux-mm@kvack.org,
linux-nvme@lists.infradead.org, linuxppc-dev@lists.ozlabs.org,
linux-trace-kernel@vger.kernel.org,
Madhavan Srinivasan <maddy@linux.ibm.com>,
Masami Hiramatsu <mhiramat@kernel.org>,
Michael Ellerman <mpe@ellerman.id.au>,
"Michael S. Tsirkin" <mst@redhat.com>,
Miguel Ojeda <ojeda@kernel.org>,
Robin Murphy <robin.murphy@arm.com>,
rust-for-linux@vger.kernel.org, Sagi Grimberg <sagi@grimberg.me>,
Stefano Stabellini <sstabellini@kernel.org>,
Steven Rostedt <rostedt@goodmis.org>,
virtualization@lists.linux.dev, Will Deacon <will@kernel.org>,
xen-devel@lists.xenproject.org
Subject: Re: [PATCH v5 07/16] dma-mapping: convert dma_direct_*map_page to be phys_addr_t based
Date: Fri, 5 Sep 2025 18:21:44 +0200 [thread overview]
Message-ID: <087e7f3d-1e0d-4efe-822f-72d16d161a60@samsung.com> (raw)
In-Reply-To: <6b2f4cb436c98d6342db69e965a5621707b9711f.1756822782.git.leon@kernel.org>
On 02.09.2025 16:48, Leon Romanovsky wrote:
> From: Leon Romanovsky <leonro@nvidia.com>
>
> Convert the DMA direct mapping functions to accept physical addresses
> directly instead of page+offset parameters. The functions were already
> operating on physical addresses internally, so this change eliminates
> the redundant page-to-physical conversion at the API boundary.
>
> The functions dma_direct_map_page() and dma_direct_unmap_page() are
> renamed to dma_direct_map_phys() and dma_direct_unmap_phys() respectively,
> with their calling convention changed from (struct page *page,
> unsigned long offset) to (phys_addr_t phys).
>
> Architecture-specific functions arch_dma_map_page_direct() and
> arch_dma_unmap_page_direct() are similarly renamed to
> arch_dma_map_phys_direct() and arch_dma_unmap_phys_direct().
>
> The is_pci_p2pdma_page() checks are replaced with DMA_ATTR_MMIO checks
> to allow integration with dma_direct_map_resource and dma_direct_map_phys()
> is extended to support MMIO path either.
>
> Reviewed-by: Jason Gunthorpe <jgg@nvidia.com>
> Signed-off-by: Leon Romanovsky <leonro@nvidia.com>
> ---
> arch/powerpc/kernel/dma-iommu.c | 4 +--
> include/linux/dma-map-ops.h | 8 ++---
> kernel/dma/direct.c | 6 ++--
> kernel/dma/direct.h | 57 +++++++++++++++++++++------------
> kernel/dma/mapping.c | 8 ++---
> 5 files changed, 49 insertions(+), 34 deletions(-)
>
> diff --git a/arch/powerpc/kernel/dma-iommu.c b/arch/powerpc/kernel/dma-iommu.c
> index 4d64a5db50f3..0359ab72cd3b 100644
> --- a/arch/powerpc/kernel/dma-iommu.c
> +++ b/arch/powerpc/kernel/dma-iommu.c
> @@ -14,7 +14,7 @@
> #define can_map_direct(dev, addr) \
> ((dev)->bus_dma_limit >= phys_to_dma((dev), (addr)))
>
> -bool arch_dma_map_page_direct(struct device *dev, phys_addr_t addr)
> +bool arch_dma_map_phys_direct(struct device *dev, phys_addr_t addr)
> {
> if (likely(!dev->bus_dma_limit))
> return false;
> @@ -24,7 +24,7 @@ bool arch_dma_map_page_direct(struct device *dev, phys_addr_t addr)
>
> #define is_direct_handle(dev, h) ((h) >= (dev)->archdata.dma_offset)
>
> -bool arch_dma_unmap_page_direct(struct device *dev, dma_addr_t dma_handle)
> +bool arch_dma_unmap_phys_direct(struct device *dev, dma_addr_t dma_handle)
> {
> if (likely(!dev->bus_dma_limit))
> return false;
> diff --git a/include/linux/dma-map-ops.h b/include/linux/dma-map-ops.h
> index f48e5fb88bd5..71f5b3025415 100644
> --- a/include/linux/dma-map-ops.h
> +++ b/include/linux/dma-map-ops.h
> @@ -392,15 +392,15 @@ void *arch_dma_set_uncached(void *addr, size_t size);
> void arch_dma_clear_uncached(void *addr, size_t size);
>
> #ifdef CONFIG_ARCH_HAS_DMA_MAP_DIRECT
> -bool arch_dma_map_page_direct(struct device *dev, phys_addr_t addr);
> -bool arch_dma_unmap_page_direct(struct device *dev, dma_addr_t dma_handle);
> +bool arch_dma_map_phys_direct(struct device *dev, phys_addr_t addr);
> +bool arch_dma_unmap_phys_direct(struct device *dev, dma_addr_t dma_handle);
> bool arch_dma_map_sg_direct(struct device *dev, struct scatterlist *sg,
> int nents);
> bool arch_dma_unmap_sg_direct(struct device *dev, struct scatterlist *sg,
> int nents);
> #else
> -#define arch_dma_map_page_direct(d, a) (false)
> -#define arch_dma_unmap_page_direct(d, a) (false)
> +#define arch_dma_map_phys_direct(d, a) (false)
> +#define arch_dma_unmap_phys_direct(d, a) (false)
> #define arch_dma_map_sg_direct(d, s, n) (false)
> #define arch_dma_unmap_sg_direct(d, s, n) (false)
> #endif
> diff --git a/kernel/dma/direct.c b/kernel/dma/direct.c
> index 24c359d9c879..fa75e3070073 100644
> --- a/kernel/dma/direct.c
> +++ b/kernel/dma/direct.c
> @@ -453,7 +453,7 @@ void dma_direct_unmap_sg(struct device *dev, struct scatterlist *sgl,
> if (sg_dma_is_bus_address(sg))
> sg_dma_unmark_bus_address(sg);
> else
> - dma_direct_unmap_page(dev, sg->dma_address,
> + dma_direct_unmap_phys(dev, sg->dma_address,
> sg_dma_len(sg), dir, attrs);
> }
> }
> @@ -476,8 +476,8 @@ int dma_direct_map_sg(struct device *dev, struct scatterlist *sgl, int nents,
> */
> break;
> case PCI_P2PDMA_MAP_NONE:
> - sg->dma_address = dma_direct_map_page(dev, sg_page(sg),
> - sg->offset, sg->length, dir, attrs);
> + sg->dma_address = dma_direct_map_phys(dev, sg_phys(sg),
> + sg->length, dir, attrs);
> if (sg->dma_address == DMA_MAPPING_ERROR) {
> ret = -EIO;
> goto out_unmap;
> diff --git a/kernel/dma/direct.h b/kernel/dma/direct.h
> index d2c0b7e632fc..3f4792910604 100644
> --- a/kernel/dma/direct.h
> +++ b/kernel/dma/direct.h
> @@ -80,42 +80,57 @@ static inline void dma_direct_sync_single_for_cpu(struct device *dev,
> arch_dma_mark_clean(paddr, size);
> }
>
> -static inline dma_addr_t dma_direct_map_page(struct device *dev,
> - struct page *page, unsigned long offset, size_t size,
> - enum dma_data_direction dir, unsigned long attrs)
> +static inline dma_addr_t dma_direct_map_phys(struct device *dev,
> + phys_addr_t phys, size_t size, enum dma_data_direction dir,
> + unsigned long attrs)
> {
> - phys_addr_t phys = page_to_phys(page) + offset;
> - dma_addr_t dma_addr = phys_to_dma(dev, phys);
> + dma_addr_t dma_addr;
>
> if (is_swiotlb_force_bounce(dev)) {
> - if (is_pci_p2pdma_page(page))
> - return DMA_MAPPING_ERROR;
> + if (attrs & DMA_ATTR_MMIO)
> + goto err_overflow;
> +
> return swiotlb_map(dev, phys, size, dir, attrs);
> }
>
> - if (unlikely(!dma_capable(dev, dma_addr, size, true)) ||
> - dma_kmalloc_needs_bounce(dev, size, dir)) {
> - if (is_pci_p2pdma_page(page))
> - return DMA_MAPPING_ERROR;
> - if (is_swiotlb_active(dev))
> - return swiotlb_map(dev, phys, size, dir, attrs);
> -
> - dev_WARN_ONCE(dev, 1,
> - "DMA addr %pad+%zu overflow (mask %llx, bus limit %llx).\n",
> - &dma_addr, size, *dev->dma_mask, dev->bus_dma_limit);
> - return DMA_MAPPING_ERROR;
> + if (attrs & DMA_ATTR_MMIO) {
> + dma_addr = phys;
> + if (unlikely(dma_capable(dev, dma_addr, size, false)))
"!dma_capable(dev, dma_addr, size, false)" in the above line.
It took me a while to find this after noticing that this patchset breaks booting some of me test systems.
> + goto err_overflow;
> + } else {
> + dma_addr = phys_to_dma(dev, phys);
> + if (unlikely(!dma_capable(dev, dma_addr, size, true)) ||
> + dma_kmalloc_needs_bounce(dev, size, dir)) {
> + if (is_swiotlb_active(dev))
> + return swiotlb_map(dev, phys, size, dir, attrs);
> +
> + goto err_overflow;
> + }
> }
>
> - if (!dev_is_dma_coherent(dev) && !(attrs & DMA_ATTR_SKIP_CPU_SYNC))
> + if (!dev_is_dma_coherent(dev) &&
> + !(attrs & (DMA_ATTR_SKIP_CPU_SYNC | DMA_ATTR_MMIO)))
> arch_sync_dma_for_device(phys, size, dir);
> return dma_addr;
> +
> +err_overflow:
> + dev_WARN_ONCE(
> + dev, 1,
> + "DMA addr %pad+%zu overflow (mask %llx, bus limit %llx).\n",
> + &dma_addr, size, *dev->dma_mask, dev->bus_dma_limit);
> + return DMA_MAPPING_ERROR;
> }
>
> -static inline void dma_direct_unmap_page(struct device *dev, dma_addr_t addr,
> +static inline void dma_direct_unmap_phys(struct device *dev, dma_addr_t addr,
> size_t size, enum dma_data_direction dir, unsigned long attrs)
> {
> - phys_addr_t phys = dma_to_phys(dev, addr);
> + phys_addr_t phys;
> +
> + if (attrs & DMA_ATTR_MMIO)
> + /* nothing to do: uncached and no swiotlb */
> + return;
>
> + phys = dma_to_phys(dev, addr);
> if (!(attrs & DMA_ATTR_SKIP_CPU_SYNC))
> dma_direct_sync_single_for_cpu(dev, addr, size, dir);
>
> diff --git a/kernel/dma/mapping.c b/kernel/dma/mapping.c
> index 58482536db9b..80481a873340 100644
> --- a/kernel/dma/mapping.c
> +++ b/kernel/dma/mapping.c
> @@ -166,8 +166,8 @@ dma_addr_t dma_map_page_attrs(struct device *dev, struct page *page,
> return DMA_MAPPING_ERROR;
>
> if (dma_map_direct(dev, ops) ||
> - arch_dma_map_page_direct(dev, phys + size))
> - addr = dma_direct_map_page(dev, page, offset, size, dir, attrs);
> + arch_dma_map_phys_direct(dev, phys + size))
> + addr = dma_direct_map_phys(dev, phys, size, dir, attrs);
> else if (use_dma_iommu(dev))
> addr = iommu_dma_map_phys(dev, phys, size, dir, attrs);
> else
> @@ -187,8 +187,8 @@ void dma_unmap_page_attrs(struct device *dev, dma_addr_t addr, size_t size,
>
> BUG_ON(!valid_dma_direction(dir));
> if (dma_map_direct(dev, ops) ||
> - arch_dma_unmap_page_direct(dev, addr + size))
> - dma_direct_unmap_page(dev, addr, size, dir, attrs);
> + arch_dma_unmap_phys_direct(dev, addr + size))
> + dma_direct_unmap_phys(dev, addr, size, dir, attrs);
> else if (use_dma_iommu(dev))
> iommu_dma_unmap_phys(dev, addr, size, dir, attrs);
> else
Best regards
--
Marek Szyprowski, PhD
Samsung R&D Institute Poland
next prev parent reply other threads:[~2025-09-05 16:21 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-09-02 14:48 [PATCH v5 00/16] dma-mapping: migrate to physical address-based API Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 01/16] dma-mapping: introduce new DMA attribute to indicate MMIO memory Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 02/16] iommu/dma: implement DMA_ATTR_MMIO for dma_iova_link() Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 03/16] dma-debug: refactor to use physical addresses for page mapping Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 04/16] dma-mapping: rename trace_dma_*map_page to trace_dma_*map_phys Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 05/16] iommu/dma: rename iommu_dma_*map_page to iommu_dma_*map_phys Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 06/16] iommu/dma: implement DMA_ATTR_MMIO for iommu_dma_(un)map_phys() Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 07/16] dma-mapping: convert dma_direct_*map_page to be phys_addr_t based Leon Romanovsky
2025-09-05 16:21 ` Marek Szyprowski [this message]
2025-09-05 16:50 ` Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 08/16] kmsan: convert kmsan_handle_dma to use physical addresses Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 09/16] dma-mapping: implement DMA_ATTR_MMIO for dma_(un)map_page_attrs() Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 10/16] xen: swiotlb: Open code map_resource callback Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 11/16] dma-mapping: export new dma_*map_phys() interface Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 12/16] mm/hmm: migrate to physical address-based DMA mapping API Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 13/16] mm/hmm: properly take MMIO path Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 14/16] block-dma: migrate to dma_map_phys instead of map_page Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 15/16] block-dma: properly take MMIO path Leon Romanovsky
2025-09-02 14:48 ` [PATCH v5 16/16] nvme-pci: unmap MMIO pages with appropriate interface Leon Romanovsky
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=087e7f3d-1e0d-4efe-822f-72d16d161a60@samsung.com \
--to=m.szyprowski@samsung.com \
--cc=abdiel.janulgue@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=alex.gaynor@gmail.com \
--cc=axboe@kernel.dk \
--cc=corbet@lwn.net \
--cc=dakr@kernel.org \
--cc=david@redhat.com \
--cc=glider@google.com \
--cc=hch@lst.de \
--cc=iommu@lists.linux.dev \
--cc=jasowang@redhat.com \
--cc=jgg@nvidia.com \
--cc=jgross@suse.com \
--cc=joro@8bytes.org \
--cc=kasan-dev@googlegroups.com \
--cc=kbusch@kernel.org \
--cc=leon@kernel.org \
--cc=leonro@nvidia.com \
--cc=linux-block@vger.kernel.org \
--cc=linux-doc@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=linux-nvme@lists.infradead.org \
--cc=linux-trace-kernel@vger.kernel.org \
--cc=linuxppc-dev@lists.ozlabs.org \
--cc=maddy@linux.ibm.com \
--cc=mhiramat@kernel.org \
--cc=mpe@ellerman.id.au \
--cc=mst@redhat.com \
--cc=ojeda@kernel.org \
--cc=robin.murphy@arm.com \
--cc=rostedt@goodmis.org \
--cc=rust-for-linux@vger.kernel.org \
--cc=sagi@grimberg.me \
--cc=sstabellini@kernel.org \
--cc=virtualization@lists.linux.dev \
--cc=will@kernel.org \
--cc=xen-devel@lists.xenproject.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®