From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id 314F2C7EE26 for ; Tue, 23 May 2023 15:20:35 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S237504AbjEWPUe (ORCPT ); Tue, 23 May 2023 11:20:34 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:60302 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S231152AbjEWPUb (ORCPT ); Tue, 23 May 2023 11:20:31 -0400 Received: from bombadil.infradead.org (bombadil.infradead.org [IPv6:2607:7c80:54:3::133]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id BA398185; Tue, 23 May 2023 08:20:28 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=infradead.org; s=bombadil.20210309; h=Content-Transfer-Encoding: Content-Type:In-Reply-To:From:References:Cc:To:Subject:MIME-Version:Date: Message-ID:Sender:Reply-To:Content-ID:Content-Description; bh=IwWt8vm7YxokOuC3jq5/50QuiT4RbHvoQwVnGhf4iNQ=; b=txnGef5Iy6+K4m6cCJI53kCfJP 9YlrYhFEVXZ/e+zxsxl6tGrvVyceNIKnqDpS6+PYQMuAVxmyUln+aNkK9Pqwj+xRzrtoGmNZWFOED lbIrvSLhGFUY7BbZY6/U8sC8FYX+rZJjgtHHJ58wZ0D3e0NWUuCyX6qNDH91/dCPmDvN1IiiW260m gmgUfCTu1oJB6m8J0tp3phRE+ZprQB6o9Xnq8oqzqR/KomVZ3iNGMw6sQZ7ch7DodmS8/rX2p9Gtv 1LBIcROOWkEWmexLOBE5xHfOGNPTfIyvjOVix/YpDeBPCokMEigpmol8FWSRAZimBArIe88uS16yi DFGxlLZQ==; Received: from [2601:1c2:980:9ec0::2764] by bombadil.infradead.org with esmtpsa (Exim 4.96 #2 (Red Hat Linux)) id 1q1ToI-00AcZ9-0L; Tue, 23 May 2023 15:20:26 +0000 Message-ID: <09f31255-e214-01d7-318a-13d712f73837@infradead.org> Date: Tue, 23 May 2023 08:20:23 -0700 MIME-Version: 1.0 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.11.0 Subject: Re: [PATCH] dmaengine: pl330: rename _start to prevent build error Content-Language: en-US To: Vinod Koul Cc: linux-kernel@vger.kernel.org, Jaswinder Singh , Jaswinder Singh , Boojin Kim , Krzysztof Kozlowski , Russell King , dmaengine@vger.kernel.org, linux-riscv@lists.infradead.org References: <20230523000606.9405-1-rdunlap@infradead.org> From: Randy Dunlap In-Reply-To: Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 5/23/23 07:08, Vinod Koul wrote: > On 22-05-23, 17:06, Randy Dunlap wrote: >> "_start" is used in several arches and proably should be reserved >> for ARCH usage. Using it in a driver for a private symbol can cause >> a build error when it conflicts with ARCH usage of the same symbol. >> >> Therefore rename pl330's "_start" to "_start_thread" so that there >> is no conflict and no build error. > > Why not rename to pl330_start or pl330_start_thread to ensure we will > might not conflict ever! > Ok, will do. Thanks. -- ~Randy