From: David Brownell <david-b@pacbell.net>
To: Greg KH <greg@kroah.com>
Cc: Patrick Mochel <mochel@osdl.org>, Dave Jones <davej@suse.de>,
linux-usb-devel@lists.sourceforge.net,
linux-kernel@vger.kernel.org
Subject: Re: [linux-usb-devel] Re: [PATCH] driverfs support for USB - take 2
Date: Wed, 30 Jan 2002 12:07:26 -0800 [thread overview]
Message-ID: <0a1501c1a9c9$bdf427e0$6800000a@brownell.org> (raw)
In-Reply-To: <Pine.LNX.4.33.0201291711560.800-100000@segfault.osdlab.org> <08cf01c1a933$f45ac460$6800000a@brownell.org> <20020130040908.GA23261@kroah.com>
"> " == "Greg KH" <greg@kroah.com>
> I completly agree.
As I see -- some mailer daemons were adding delays and
fomenting confusion!
> However, the root hub name _does_ propose a problem. I feel we have two
> solutions:
> - use the bus number (usb_bus_00x)
> Pros:
> matches the usbfs naming and directory structure
> Cons:
> depends on the initialization order of the busses.
At this point, I'd propose that "driverfs" should adopt a policy
that naming dependencies on initialization order are a virus
that should be obliterated to the degree it's possible ... which
in this case is completely! :)
> - use a generic name like I did (usb_bus)
> Pros:
> does not depend on the init order, and relies on the
> location in the entire pci topology tree to show its
> uniqueness.
> Cons:
> boring :)
Or a third option is to get rid of the extra level of indirection
in the current driverfs naming policy, as Patrick suggested
in a separate email. I'll follow up separately.
> And also remember, the status file in a device's directory also provides
> a _lot_ of information. We haven't even started to fill up the fields
> there...
And there can be a lot more such files. Though that 4KB limit
may become an issue at some point.
What sort of USB information were you thinking should show
up? Current configuration and altsetting? Power consumption
for hubs (not that we budget that yet :)? There really aren't any
examples of this in the kernel yet.
Also, one could argue that each USB function ("interface")
should be presented as an individual device, just like each PCI
function is handled ... after all, USB drivers bind to interfaces,
not devices, and this is the "driver" FS! :)
- Dave
next prev parent reply other threads:[~2002-01-30 20:09 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2002-01-30 0:24 Greg KH
2002-01-30 1:03 ` Dave Jones
2002-01-30 1:09 ` Greg KH
2002-01-30 1:19 ` Patrick Mochel
2002-01-30 2:15 ` [linux-usb-devel] " David Brownell
2002-01-30 4:09 ` Greg KH
2002-01-30 20:07 ` David Brownell [this message]
2002-02-02 0:18 ` [linux-usb-devel] " Greg KH
2002-02-02 19:13 ` David Brownell
2002-02-05 6:49 ` Greg KH
2002-01-30 1:49 ` [linux-usb-devel] " Stephen J. Gowdy
2002-01-30 4:10 ` Greg KH
2002-01-30 18:26 ` Patrick Mochel
2002-01-30 20:24 ` [linux-usb-devel] " David Brownell
2002-02-02 0:23 ` Greg KH
2002-02-02 19:27 ` David Brownell
2002-01-31 12:49 ` Pavel Machek
2002-02-01 9:27 ` Horst von Brand
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to='0a1501c1a9c9$bdf427e0$6800000a@brownell.org' \
--to=david-b@pacbell.net \
--cc=davej@suse.de \
--cc=greg@kroah.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb-devel@lists.sourceforge.net \
--cc=mochel@osdl.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®