From: Qu Wenruo <wqu@suse.com>
To: Rosen Penev <rosenp@gmail.com>, linux-btrfs@vger.kernel.org
Cc: Chris Mason <clm@fb.com>, David Sterba <dsterba@suse.com>,
open list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] btrfs: compression: allocate buckets with workspace
Date: Mon, 29 Jun 2026 19:44:13 +0930 [thread overview]
Message-ID: <0a3b352d-a267-46a8-84b4-ba97def25f5c@suse.com> (raw)
In-Reply-To: <20260629002505.1552238-1-rosenp@gmail.com>
在 2026/6/29 09:55, Rosen Penev 写道:
> Convert 3 allocations into one. Simplifies code slightly.
>
> Signed-off-by: Rosen Penev <rosenp@gmail.com>
> ---
> fs/btrfs/compression.c | 18 +++++-------------
> 1 file changed, 5 insertions(+), 13 deletions(-)
>
> diff --git a/fs/btrfs/compression.c b/fs/btrfs/compression.c
> index ffb6b52863a7..da6749ff5924 100644
> --- a/fs/btrfs/compression.c
> +++ b/fs/btrfs/compression.c
> @@ -650,11 +650,11 @@ struct heuristic_ws {
> /* Partial copy of input data */
> u8 *sample;
> u32 sample_size;
> - /* Buckets store counters for each byte value */
> - struct bucket_item *bucket;
> /* Sorting buffer */
> struct bucket_item *bucket_b;
> struct list_head list;
> + /* Buckets store counters for each byte value */
> + struct bucket_item bucket[];
> };
>
> static void free_heuristic_ws(struct list_head *ws)
> @@ -664,8 +664,6 @@ static void free_heuristic_ws(struct list_head *ws)
> workspace = list_entry(ws, struct heuristic_ws, list);
>
> kvfree(workspace->sample);
> - kfree(workspace->bucket);
> - kfree(workspace->bucket_b);
> kfree(workspace);
> }
>
> @@ -673,22 +671,16 @@ static struct list_head *alloc_heuristic_ws(struct btrfs_fs_info *fs_info)
> {
> struct heuristic_ws *ws;
>
> - ws = kzalloc_obj(*ws);
> + ws = kzalloc(struct_size(ws, bucket, BUCKET_SIZE * 2), GFP_KERNEL);
> if (!ws)
> return ERR_PTR(-ENOMEM);
>
> + ws->bucket_b = ws->bucket + BUCKET_SIZE;
> +
This barely improves any readability.
We have two different bucket pointers, one is a variable sized member,
one (bucket_b) is a pointer.
Not a fan of this at all.
> ws->sample = kvmalloc(MAX_SAMPLE_SIZE, GFP_KERNEL);
> if (!ws->sample)
> goto fail;
>
> - ws->bucket = kzalloc_objs(*ws->bucket, BUCKET_SIZE);
> - if (!ws->bucket)
> - goto fail;
> -
> - ws->bucket_b = kzalloc_objs(*ws->bucket_b, BUCKET_SIZE);
> - if (!ws->bucket_b)
> - goto fail;
> -
> INIT_LIST_HEAD(&ws->list);
> return &ws->list;
> fail:
prev parent reply other threads:[~2026-06-29 10:14 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-29 0:25 Rosen Penev
2026-06-29 1:54 ` Sun YangKai
2026-06-29 23:09 ` David Sterba
2026-06-30 1:51 ` Sun YangKai
2026-06-29 10:14 ` Qu Wenruo [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=0a3b352d-a267-46a8-84b4-ba97def25f5c@suse.com \
--to=wqu@suse.com \
--cc=clm@fb.com \
--cc=dsterba@suse.com \
--cc=linux-btrfs@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rosenp@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®