mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Niklas Schnelle <schnelle@linux.ibm.com>
To: Heiko Carstens <hca@linux.ibm.com>,
	Alexander Gordeev	 <agordeev@linux.ibm.com>,
	Sven Schnelle <svens@linux.ibm.com>,
	Vasily Gorbik	 <gor@linux.ibm.com>,
	Christian Borntraeger <borntraeger@linux.ibm.com>,
	Gerd Bayer <gbayer@linux.ibm.com>
Cc: linux-s390@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 2/3] s390/pci: Rework__zpci_event_availability() to remove conditional locking
Date: Wed, 05 Aug 2026 13:32:10 +0200	[thread overview]
Message-ID: <0b65164f7442fec896c76e0a39a8d9a43f98b721.camel@linux.ibm.com> (raw)
In-Reply-To: <20260803142907.1771509-3-hca@linux.ibm.com>

On Mon, 2026-08-03 at 16:29 +0200, Heiko Carstens wrote:
> Clang's compiler based static context analysis does not work with locks
> that are conditionally taken like in __zpci_event_availability():
> 
> arch/s390/pci/pci_event.c:402:10: warning: mutex 'get_zdev_by_fid(ccdf->fid).state_lock'
>   is not held on every path through here [-Wthread-safety-analysis]
> 
> Given that code which takes locks conditionally can be considered
> suboptimal rework __zpci_event_availability() to get rid of this.
> 
> Signed-off-by: Heiko Carstens <hca@linux.ibm.com>
> ---
>  arch/s390/pci/pci_event.c | 108 +++++++++++++++++++-------------------
>  1 file changed, 53 insertions(+), 55 deletions(-)
> 
> diff --git a/arch/s390/pci/pci_event.c b/arch/s390/pci/pci_event.c
> index 48fa26dcbee1..f96ee87405f9 100644
> --- a/arch/s390/pci/pci_event.c
> +++ b/arch/s390/pci/pci_event.c
> @@ -389,19 +389,25 @@ static void zpci_event_reappear(struct zpci_dev *zdev)
>  
>  static void __zpci_event_availability(struct zpci_ccdf_avail *ccdf)
>  {
> -	struct zpci_dev *zdev = get_zdev_by_fid(ccdf->fid);
> -	bool existing_zdev = !!zdev;
> +	struct zpci_dev *zdev;
>  	enum zpci_state state;
>  
>  	zpci_dbg(3, "avl fid:%x, fh:%x, pec:%x\n",
>  		 ccdf->fid, ccdf->fh, ccdf->pec);
>  
> -	if (existing_zdev)
> -		mutex_lock(&zdev->state_lock);
> +	/* 0x0306 - No handle or fid stored */
> +	if (ccdf->pec == 0x0306) {
> +		/* 0x308 or 0x302 for multiple devices */
> +		zpci_remove_reserved_devices();
> +		zpci_scan_devices();
> +		return;
> +	}
>  
> -	switch (ccdf->pec) {
> -	case 0x0301: /* Reserved|Standby -> Configured */
> -		if (!zdev) {
> +	zdev = get_zdev_by_fid(ccdf->fid);
> +

Nit: Stray empty line

> +	if (!zdev) {
> +		switch (ccdf->pec) {
> +		case 0x0301: /* Reserved|Standby -> Configured */
>  			zdev = zpci_create_device(ccdf->fid, ccdf->fh, ZPCI_FN_STATE_CONFIGURED);
>  			if (IS_ERR(zdev))
>  				break;
--- snip ---
> +			break;
>  		}
> +		return;
> +	}
--- snip ---
> +
> +	mutex_lock(&zdev->state_lock);
> +	switch (ccdf->pec) {
> +	case 0x0301: /* Reserved|Standby -> Configured */
> +		if (zdev->state == ZPCI_FN_STATE_RESERVED)
> +			zpci_event_reappear(zdev);
> +		/* the configuration request may be stale */
> +		else if (zdev->state != ZPCI_FN_STATE_STANDBY)
> +			break;
> +		zdev->state = ZPCI_FN_STATE_CONFIGURED;
> +		zpci_scan_configured_device(zdev, ccdf->fh);
> +		break;
> +	case 0x0302: /* Reserved -> Standby */
> +		if (zdev->state == ZPCI_FN_STATE_RESERVED)
> +			zpci_event_reappear(zdev);
> +		zpci_update_fh(zdev, ccdf->fh);
--- snip ---
>  	}
> +	mutex_unlock(&zdev->state_lock);
> +	zpci_zdev_put(zdev);
>  }
>  
>  void zpci_event_availability(void *data)

Personally I think I'd put the 0x0306 and each of the two switches in
helper functions to improve readability as this is getting awfully
long. Maybe something like zpci_event_avail_any_device() (0x0306),
zpci_event_avail_new_device() and zpci_event_avail_existing_device().

If you prefer and since I'm doing a follow up for the missing locking
in zpci_reserved_devices() I can also do that in a separate patch. Also
just to clarify Sashiko is right in that the missing locking is a pre-
existing issue as the state_lock was already not taken in that case,
it's just more obvious now.

Either way, functionality looks good to me so feel free to add:

Reviewed-by: Niklas Schnelle <schnelle@linux.ibm.com>

Thanks,
Niklas

  reply	other threads:[~2026-08-05 11:33 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-03 14:29 [PATCH v2 0/3] s390/pci: Enable CONTEXT_ANALYSIS Heiko Carstens
2026-08-03 14:29 ` [PATCH v2 1/3] s390/pci: Rework __zpci_event_error() to remove conditional locking Heiko Carstens
2026-08-03 16:40   ` Niklas Schnelle
2026-08-03 14:29 ` [PATCH v2 2/3] s390/pci: Rework__zpci_event_availability() " Heiko Carstens
2026-08-05 11:32   ` Niklas Schnelle [this message]
2026-08-05 12:43     ` Heiko Carstens
2026-08-03 14:29 ` [PATCH v2 3/3] s390/pci: Enable CONTEXT_ANALYSIS Heiko Carstens
2026-08-05 13:22   ` Niklas Schnelle
2026-08-03 14:55 ` [PATCH v2 0/3] " Niklas Schnelle

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0b65164f7442fec896c76e0a39a8d9a43f98b721.camel@linux.ibm.com \
    --to=schnelle@linux.ibm.com \
    --cc=agordeev@linux.ibm.com \
    --cc=borntraeger@linux.ibm.com \
    --cc=gbayer@linux.ibm.com \
    --cc=gor@linux.ibm.com \
    --cc=hca@linux.ibm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-s390@vger.kernel.org \
    --cc=svens@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®