From: Alex Shi <alex.shi@linux.alibaba.com>
To: Peter Zijlstra <peterz@infradead.org>
Cc: Ingo Molnar <mingo@redhat.com>,
Frederic Weisbecker <fweisbec@gmail.com>,
Wanpeng Li <wanpeng.li@hotmail.com>,
Thomas Gleixner <tglx@linutronix.de>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/2] cputime: remove duplicate code in account_process_tick
Date: Thu, 11 Jul 2019 14:41:24 +0800 [thread overview]
Message-ID: <0c3ce3c1-5a7e-314a-97f8-8270cc6ed990@linux.alibaba.com> (raw)
In-Reply-To: <20190710141500.GQ3402@hirez.programming.kicks-ass.net>
在 2019/7/10 下午10:15, Peter Zijlstra 写道:
> On Tue, Jul 09, 2019 at 02:01:00PM +0800, Alex Shi wrote:
>> In funcation account_process_tick, func actually do same things with
>> irqtime_account_process_tick, whenever if IRQ_TIME_ACCOUNTING set or
>> if sched_clock_irqtime enabled.
>>
>> So it's better to reuse one function for both.
>
> But it's not the exact same.. and you didn't say, not did you say why
> that is fine.
>
Thanks for reply!
The irqtime_account_process_tick path was introduced for precise ns irq time account(abb74cefa9c682fb sched: Export ns irqtimes through /proc/stat) while account_process_tick still use jiffes. but now both pathes are using ns cputime. And there is not strong reason to keep 2 very very similar path coexists. That's the reason I believe unite the collection is better.
Thanks
Alex
prev parent reply other threads:[~2019-07-11 6:41 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-07-09 6:00 [PATCH 1/2] cputime: remove rq parameter for function clean up Alex Shi
2019-07-09 6:01 ` [PATCH 2/2] cputime: remove duplicate code in account_process_tick Alex Shi
2019-07-10 14:15 ` Peter Zijlstra
2019-07-11 6:41 ` Alex Shi [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=0c3ce3c1-5a7e-314a-97f8-8270cc6ed990@linux.alibaba.com \
--to=alex.shi@linux.alibaba.com \
--cc=fweisbec@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=peterz@infradead.org \
--cc=tglx@linutronix.de \
--cc=wanpeng.li@hotmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®