From: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
To: Hsin-Yi Wang <hsinyi@chromium.org>,
Matthias Brugger <matthias.bgg@gmail.com>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>
Cc: "Rob Herring" <robh+dt@kernel.org>,
"Conor Dooley" <conor+dt@kernel.org>,
"Nícolas F . R . A . Prado" <nfraprado@collabora.com>,
"Bernhard Rosenkränzer" <bero@baylibre.com>,
"Frank Wunderlich" <frank-w@public-files.de>,
"Macpaul Lin" <macpaul.lin@mediatek.com>,
"Sean Wang" <sean.wang@mediatek.com>,
devicetree@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-mediatek@lists.infradead.org
Subject: Re: [PATCH v2 3/7] arm64: dts: mt8183: Add kukui katsu board
Date: Wed, 25 Oct 2023 10:25:33 +0200 [thread overview]
Message-ID: <0dcc5a99-ef14-4250-b8c1-bf9d7471f5cb@collabora.com> (raw)
In-Reply-To: <20231024212618.1079676-4-hsinyi@chromium.org>
Il 24/10/23 23:22, Hsin-Yi Wang ha scritto:
> katsu is also known as ASUS Chromebook Detachable CZ1.
>
> Signed-off-by: Hsin-Yi Wang <hsinyi@chromium.org>
> ---
> v1->v2: non sku38 is sku32
> ---
> arch/arm64/boot/dts/mediatek/Makefile | 2 +
> .../dts/mediatek/mt8183-kukui-katsu-sku32.dts | 40 +++++++++++++++++
> .../dts/mediatek/mt8183-kukui-katsu-sku38.dts | 44 +++++++++++++++++++
> 3 files changed, 86 insertions(+)
> create mode 100644 arch/arm64/boot/dts/mediatek/mt8183-kukui-katsu-sku32.dts
> create mode 100644 arch/arm64/boot/dts/mediatek/mt8183-kukui-katsu-sku38.dts
>
> diff --git a/arch/arm64/boot/dts/mediatek/Makefile b/arch/arm64/boot/dts/mediatek/Makefile
> index e6e7592a3645..a13419e67e8e 100644
> --- a/arch/arm64/boot/dts/mediatek/Makefile
> +++ b/arch/arm64/boot/dts/mediatek/Makefile
> @@ -36,6 +36,8 @@ dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-jacuzzi-willow-sku0.dtb
> dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-jacuzzi-willow-sku1.dtb
> dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-kakadu.dtb
> dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-kakadu-sku22.dtb
> +dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-katsu-sku32.dtb
> +dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-katsu-sku38.dtb
> dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-kodama-sku16.dtb
> dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-kodama-sku272.dtb
> dtb-$(CONFIG_ARCH_MEDIATEK) += mt8183-kukui-kodama-sku288.dtb
> diff --git a/arch/arm64/boot/dts/mediatek/mt8183-kukui-katsu-sku32.dts b/arch/arm64/boot/dts/mediatek/mt8183-kukui-katsu-sku32.dts
> new file mode 100644
> index 000000000000..9fa205c06c74
> --- /dev/null
> +++ b/arch/arm64/boot/dts/mediatek/mt8183-kukui-katsu-sku32.dts
> @@ -0,0 +1,40 @@
> +// SPDX-License-Identifier: (GPL-2.0 OR MIT)
> +/*
> + * Copyright 2023 Google LLC
> + */
> +
> +/dts-v1/;
> +#include "mt8183-kukui-kakadu.dtsi"
> +#include "mt8183-kukui-audio-da7219-rt1015p.dtsi"
> +
> +/ {
> + model = "Google katsu board";
> + chassis-type = "tablet";
> + compatible = "google,katsu-sku32", "google,katsu", "mediatek,mt8183";
> +};
> +
> +&i2c0 {
> + status = "okay";
> +
The i2c0 node already inherits status = "okay" from mt8183-kukui-kakadu.dtsi,
this is redundant.
> + /delete-node/touchscreen@10;
You can definitely avoid those ugly /delete-node/ statements: if you check more
closely, mt8183-kukui-kakadu.dtsi is used by only two *.dts files.
I would propose to move the touchscreen@10 node from kakadu.dtsi to kakadu.dts
and kakadu-sku22.dts: in my opinion, that will make things more readable, as
every board defines its own touchscreen.
It would be a different story if we had to duplicate that @10 node for something
like five times or more, but that's not the case.
> + touchscreen1: touchscreen@5d {
> + compatible = "goodix,gt7375p";
> + reg = <0x5d>;
> + pinctrl-names = "default";
> + pinctrl-0 = <&open_touch>;
> +
This....
> + interrupt-parent = <&pio>;
> + interrupts = <155 IRQ_TYPE_LEVEL_LOW>;
...should be done in one line, like so:
interrupts-extended = <&pio 155 IRQ_TYPE_LEVEL_LOW>;
> +
> + reset-gpios = <&pio 156 GPIO_ACTIVE_LOW>;
> + vdd-supply = <&lcd_pp3300>;
> + };
> +};
> +
> +&panel {
> + compatible = "starry,2081101qfh032011-53g";
Actually, same comment goes for the panel node: kakadu.dtsi defines a panel
compatible "boe,tv105wum-nw0" but then you're overriding it here with the
starry panel.
You could leave the status = "okay" in kakadu.dtsi and move the panel compatible
to each *.dts board file, therefore increasing readability.
> +};
> +
> +&qca_wifi {
> + qcom,ath10k-calibration-variant = "GO_KATSU";
> +};
Same comment applies to sku38, of course.
Regards,
Angelo
next prev parent reply other threads:[~2023-10-25 8:25 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-10-24 21:22 [PATCH v2 0/7] Add a few mt8183 follower boards Hsin-Yi Wang
2023-10-24 21:22 ` [PATCH v2 1/7] arm64: dts: mt8183: kukui: Fix underscores in node names Hsin-Yi Wang
2023-10-25 8:25 ` AngeloGioacchino Del Regno
2023-10-24 21:22 ` [PATCH v2 2/7] dt-bindings: arm64: dts: mediatek: Add mt8183-kukui-katsu Hsin-Yi Wang
2023-10-24 21:22 ` [PATCH v2 3/7] arm64: dts: mt8183: Add kukui katsu board Hsin-Yi Wang
2023-10-25 8:25 ` AngeloGioacchino Del Regno [this message]
2023-10-24 21:22 ` [PATCH v2 4/7] dt-bindings: arm64: dts: mediatek: Add mt8183-kukui-jacuzzi-makomo Hsin-Yi Wang
2023-10-24 21:22 ` [PATCH v2 5/7] arm64: dts: mt8183: Add jacuzzi makomo board Hsin-Yi Wang
2023-10-24 21:22 ` [PATCH v2 6/7] dt-bindings: arm64: dts: mediatek: Add mt8183-kukui-jacuzzi-pico Hsin-Yi Wang
2023-10-24 21:22 ` [PATCH v2 7/7] arm64: dts: mt8183: Add jacuzzi pico/pico6 board Hsin-Yi Wang
2023-10-25 4:48 ` [PATCH v2 0/7] Add a few mt8183 follower boards Frank Wunderlich
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=0dcc5a99-ef14-4250-b8c1-bf9d7471f5cb@collabora.com \
--to=angelogioacchino.delregno@collabora.com \
--cc=bero@baylibre.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=frank-w@public-files.de \
--cc=hsinyi@chromium.org \
--cc=krzysztof.kozlowski+dt@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=macpaul.lin@mediatek.com \
--cc=matthias.bgg@gmail.com \
--cc=nfraprado@collabora.com \
--cc=robh+dt@kernel.org \
--cc=sean.wang@mediatek.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®