From: Hans de Goede <hdegoede@redhat.com>
To: Ricardo Ribalda <ribalda@chromium.org>
Cc: Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Sakari Ailus <sakari.ailus@linux.intel.com>,
linux-kernel@vger.kernel.org, linux-media@vger.kernel.org,
Yunke Cao <yunkec@chromium.org>,
Hans Verkuil <hverkuil@xs4all.nl>
Subject: Re: [PATCH v3 2/8] media: uvcvideo: Factor out gpio functions to its own file
Date: Mon, 25 Nov 2024 16:46:05 +0100 [thread overview]
Message-ID: <0dfb780b-f2dc-43ed-a67d-afd5f50bb88f@redhat.com> (raw)
In-Reply-To: <CANiDSCsQ3Rp55+9WbporH37W_-XHaXCR0iww6n6kHXngKh67TQ@mail.gmail.com>
Hi,
On 25-Nov-24 4:10 PM, Ricardo Ribalda wrote:
> On Mon, 25 Nov 2024 at 15:45, Hans de Goede <hdegoede@redhat.com> wrote:
>>
>> Hi Ricardo,
>>
>> On 12-Nov-24 6:30 PM, Ricardo Ribalda wrote:
>>> This is just a refactor patch, no new functionality is added.
>>>
>>> Signed-off-by: Ricardo Ribalda <ribalda@chromium.org>
>>
>> I guess this patch may need to change depending on if we want
>> to keep the GPIO handling as a UVC entity or not.
>
> I have a v4 that removes the virtual uvc entity. Still with that
> approach IMHO this patch makes sense.
Right I was not suggesting dropping it, but atm it is moving
the uvc entity creation around. I was wondering if that
moving around before removing it still makes sense ?
Note I have no preference either way if first moving it
and then dropping it is cleaner, or just easier because
of the history of this patch-set then IMHO either way
is fine.
> I was planning to send it today, I am testing it right now.
>
>>
>> Laurent what is your take on this, should this stay as
>> a struct uvc_entity; or should the gpio_desc and input_device
>> be stored directly inside struct uvc_device as is done for
>> the snapshot-button input_device?
>>
>>
>> Also de we want a separate input_device for this or do
>> we re-use the snapshot button one ?
>>
>> Since my plan is to open-up the permission on the device with
>> the SW_CAMERA_LENS_COVER to be equal to the /dev/video#
>> permissions sharing has the downside of allowing keylogging
>> of the snapshot button.
>
> A downside of having 2 devices is that userspace will have to either
> figure out what evdev they want to use or listen to both....
Right, so both would be picked up by the compositor and the
snapshot button is just another multimedia-key then, while
the compositor can use SW_CAMERA_LENS_COVER for its OSD.
The other would be of interest to libcamera.
I'm think we may need a naming convention for the evdev
with SW_CAMERA_LENS_COVER something like "* camera privacy"
or whatever then we can have a udev rule matching on that for
uaccess + libcamera can do a strstr on the name for
"camera privacy" and ignore other evdevs.
Regards,
Hans
next prev parent reply other threads:[~2024-11-25 15:46 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-11-12 17:30 [PATCH v3 0/8] media: uvcvideo: Implement the Privacy GPIO as a evdev Ricardo Ribalda
2024-11-12 17:30 ` [PATCH v3 1/8] media: uvcvideo: Fix crash during unbind if gpio unit is in use Ricardo Ribalda
2024-11-12 17:30 ` [PATCH v3 2/8] media: uvcvideo: Factor out gpio functions to its own file Ricardo Ribalda
2024-11-25 14:45 ` Hans de Goede
2024-11-25 15:10 ` Ricardo Ribalda
2024-11-25 15:46 ` Hans de Goede [this message]
2024-11-25 21:45 ` Laurent Pinchart
2024-11-12 17:30 ` [PATCH v3 3/8] media: uvcvideo: Re-implement privacy GPIO as an input device Ricardo Ribalda
2024-11-12 17:30 ` [PATCH v3 4/8] Revert "media: uvcvideo: Allow entity-defined get_info and get_cur" Ricardo Ribalda
2024-11-12 17:30 ` [PATCH v3 5/8] media: uvcvideo: Create ancillary link for GPIO subdevice Ricardo Ribalda
2024-11-12 17:30 ` [PATCH v3 6/8] media: v4l2-core: Add new MEDIA_ENT_F_GPIO Ricardo Ribalda
2024-11-12 17:30 ` [PATCH v3 7/8] media: uvcvideo: Use MEDIA_ENT_F_GPIO for the GPIO entity Ricardo Ribalda
2024-11-12 17:30 ` [PATCH v3 8/8] media: uvcvideo: Introduce UVC_QUIRK_PRIVACY_DURING_STREAM Ricardo Ribalda
2024-11-13 17:57 ` [PATCH v3 0/8] media: uvcvideo: Implement the Privacy GPIO as a evdev Hans de Goede
2024-11-14 19:21 ` Ricardo Ribalda
2024-11-14 23:06 ` Laurent Pinchart
2024-11-15 8:20 ` Ricardo Ribalda
2024-11-18 15:43 ` Hans de Goede
2024-11-18 16:47 ` Ricardo Ribalda
2024-11-25 12:01 ` Hans de Goede
2024-11-25 13:14 ` Laurent Pinchart
2024-11-25 14:41 ` Hans de Goede
2024-11-25 21:35 ` Laurent Pinchart
2024-11-26 16:27 ` Ricardo Ribalda
2024-11-26 16:50 ` Laurent Pinchart
2024-11-26 17:12 ` Ricardo Ribalda
2024-11-26 17:25 ` Laurent Pinchart
2024-12-02 12:08 ` Hans de Goede
2024-11-25 15:05 ` Ricardo Ribalda
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=0dfb780b-f2dc-43ed-a67d-afd5f50bb88f@redhat.com \
--to=hdegoede@redhat.com \
--cc=hverkuil@xs4all.nl \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=mchehab@kernel.org \
--cc=ribalda@chromium.org \
--cc=sakari.ailus@linux.intel.com \
--cc=yunkec@chromium.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®