From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from szxga08-in.huawei.com (szxga08-in.huawei.com [45.249.212.255]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 30E17156C9; Thu, 21 Dec 2023 07:59:41 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=quarantine dis=none) header.from=huawei.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=huawei.com Received: from mail.maildlp.com (unknown [172.19.163.174]) by szxga08-in.huawei.com (SkyGuard) with ESMTP id 4SwjW71nyQz1Q78M; Thu, 21 Dec 2023 15:59:15 +0800 (CST) Received: from dggpemm500005.china.huawei.com (unknown [7.185.36.74]) by mail.maildlp.com (Postfix) with ESMTPS id 46AD6140499; Thu, 21 Dec 2023 15:59:33 +0800 (CST) Received: from [10.69.30.204] (10.69.30.204) by dggpemm500005.china.huawei.com (7.185.36.74) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256) id 15.1.2507.35; Thu, 21 Dec 2023 15:59:33 +0800 Subject: Re: [PATCH net-next] page_pool: Rename frag_users to frag_cnt To: Ilias Apalodimas CC: , Jesper Dangaard Brouer , "David S. Miller" , Eric Dumazet , Jakub Kicinski , Paolo Abeni , References: <20231215073119.543560-1-ilias.apalodimas@linaro.org> <6fddeb22-0906-e04c-3a84-7836bef9ffa2@huawei.com> From: Yunsheng Lin Message-ID: <0dfffe91-2bd4-2151-cf71-ef29bf562767@huawei.com> Date: Thu, 21 Dec 2023 15:59:32 +0800 User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Thunderbird/52.2.0 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset="utf-8" Content-Language: en-US Content-Transfer-Encoding: 7bit X-ClientProxiedBy: dggems706-chm.china.huawei.com (10.3.19.183) To dggpemm500005.china.huawei.com (7.185.36.74) On 2023/12/21 14:37, Ilias Apalodimas wrote: > Hi Yunsheng, > > On Thu, 21 Dec 2023 at 04:07, Yunsheng Lin wrote: >> >> On 2023/12/20 15:56, Ilias Apalodimas wrote: >>> Hi Yunsheng, >>>>>>> #ifdef CONFIG_PAGE_POOL_STATS >>>>>>> /* these stats are incremented while in softirq context */ >>>>>>> diff --git a/net/core/page_pool.c b/net/core/page_pool.c >>>>>>> index 9b203d8660e4..19a56a52ac8f 100644 >>>>>>> --- a/net/core/page_pool.c >>>>>>> +++ b/net/core/page_pool.c >>>>>>> @@ -659,7 +659,7 @@ EXPORT_SYMBOL(page_pool_put_page_bulk); >>>>>>> static struct page *page_pool_drain_frag(struct page_pool *pool, >>>>>>> struct page *page) >>>>>>> { >>>>>>> - long drain_count = BIAS_MAX - pool->frag_users; >>>>>>> + long drain_count = BIAS_MAX - pool->frag_cnt; >>>>>> >>>>>> drain_count = pool->refcnt_bais; >>>>> >>>>> I think this is a typo right? This still remains >>>> >>>> It would be better to invert logic too, as it is mirroring: >>>> >>>> https://elixir.bootlin.com/linux/v6.7-rc5/source/mm/page_alloc.c#L4745 >>> >>> This is still a bit confusing for me since the actual bias is the >>> number of fragments that you initially split the page. But I am fine >> Acctually there are two bais numbers for a page used by >> page_pool_alloc_frag(). >> the one for page->pp_ref_count, which already use the BIAS_MAX, which >> indicates the initial bais number: >> https://elixir.bootlin.com/linux/latest/source/net/core/page_pool.c#L779 >> >> Another one for pool->frag_users indicating the runtime bais number, which >> need changing when a page is split into more fragments: >> https://elixir.bootlin.com/linux/latest/source/net/core/page_pool.c#L776 >> https://elixir.bootlin.com/linux/latest/source/net/core/page_pool.c#L783 > > I know, and that's exactly what my commit message explains. Also, > that's the reason that the rename was 'frag_cnt' on v1. > Yes, I think we do not need to invert logic when the naming is frag_users or frag_cnt. But if we use 'bias' as part of the name, isn't that more reasonable to set both of the bias number to BIAS_MAX initially, and decrement the runtime bais number every time the page is split to more fragmemts? >