From: "Thomas Weißschuh" <linux@weissschuh.net>
To: Matteo Croce <technoboy85@gmail.com>
Cc: Joe Perches <joe@perches.com>,
Brendan Higgins <brendan.higgins@linux.dev>,
David Gow <davidgow@google.com>,
linux-kselftest@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2] get_maintainer: add KUnit maintainers for KUnit test files
Date: Sun, 1 Mar 2026 12:34:09 +0100 [thread overview]
Message-ID: <0fd8bfde-e7d4-4730-841d-85cb4c5eb8ac@t-8ch.de> (raw)
In-Reply-To: <CAFnufp0rQ=p2qGcpDdJB-SjW=qNOaxFRTrO1TprhKLtds96bJg@mail.gmail.com>
On 2026-03-01 12:17:17+0100, Matteo Croce wrote:
> Il giorno dom 1 mar 2026 alle ore 03:36 Joe Perches <joe@perches.com>
> ha scritto:
> >
> > On Sun, 2026-03-01 at 02:11 +0100, Matteo Croce wrote:
> > > ```
> > > KUnit test files are scattered across the tree and don't always match
> > > the F: patterns in the KERNEL UNIT TESTING FRAMEWORK MAINTAINERS entry.
> > > Add the KUnit maintainers automatically when the file path matches
> > > common KUnit naming conventions: _kunit.c, -kunit.c, _kunit_test.c,
> > > and -kunit-tests.c.
> >
> > nack. There's no need to modify get_maintainer.
> >
> > Use F: patterns instead.
> >
> > diff --git a/MAINTAINERS b/MAINTAINERS
> > index 96e97d25e1c2..9796e184b9d5 100644
> > --- a/MAINTAINERS
> > +++ b/MAINTAINERS
> > @@ -13956,6 +13956,11 @@ F: rust/kernel/kunit.rs
> > F: rust/macros/kunit.rs
> > F: scripts/rustdoc_test_*
> > F: tools/testing/kunit/
> > +F: */*[_-]kunit*.c
> > +F: */*/*[_-]kunit*.c
> > +F: */*/*/*[_-]kunit*.c
> > +F: */*/*/*/*[_-]kunit*.c
> > +F: */*/*/*/*/*[_-]kunit*.c
> >
> > KERNEL USERMODE HELPER
> > M: Luis Chamberlain <mcgrof@kernel.org>
>
> So many rules covering all possible depths?
> Sounds good.
>
> BTW at this point it would be useful to implement the ** glob operator,
> but maybe it's not worth it.
K: or N: patterns would be cleaner than both proposals here.
Thomas
next prev parent reply other threads:[~2026-03-01 11:34 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-03-01 1:11 Matteo Croce
2026-03-01 2:36 ` Joe Perches
2026-03-01 11:17 ` Matteo Croce
2026-03-01 11:34 ` Thomas Weißschuh [this message]
2026-03-01 16:42 ` Joe Perches
2026-03-02 0:50 ` Matteo Croce
2026-03-02 2:05 ` Joe Perches
2026-03-02 2:34 ` Matteo Croce
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=0fd8bfde-e7d4-4730-841d-85cb4c5eb8ac@t-8ch.de \
--to=linux@weissschuh.net \
--cc=brendan.higgins@linux.dev \
--cc=davidgow@google.com \
--cc=joe@perches.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=technoboy85@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®