From: Lukasz Luba <lukasz.luba@arm.com>
To: "Rafael J. Wysocki" <rjw@rjwysocki.net>
Cc: LKML <linux-kernel@vger.kernel.org>,
"Rafael J. Wysocki" <rafael@kernel.org>,
Linux PM <linux-pm@vger.kernel.org>,
Daniel Lezcano <daniel.lezcano@linaro.org>
Subject: Re: [PATCH v1] thermal: core: Introduce thermal_governor_trip_crossed()
Date: Wed, 24 Apr 2024 08:26:48 +0100 [thread overview]
Message-ID: <1016c73b-9bcb-49b8-85a6-854476681558@arm.com> (raw)
In-Reply-To: <12426299.O9o76ZdvQC@kreacher>
On 4/23/24 20:01, Rafael J. Wysocki wrote:
> From: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
>
> Add a wrapper around the .trip_crossed() governor callback invocation
> to reduce code duplications slightly and improve the code layout in
> __thermal_zone_device_update().
>
> No intentional functional impact.
>
> Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
> ---
>
> As requested in https://lore.kernel.org/linux-pm/3c169af3-e9c3-47c0-b343-48f699680009@linaro.org/
>
> ---
> drivers/thermal/thermal_core.c | 15 +++++++++++----
> 1 file changed, 11 insertions(+), 4 deletions(-)
>
> Index: linux-pm/drivers/thermal/thermal_core.c
> ===================================================================
> --- linux-pm.orig/drivers/thermal/thermal_core.c
> +++ linux-pm/drivers/thermal/thermal_core.c
> @@ -450,6 +450,15 @@ static void thermal_zone_device_init(str
> pos->initialized = false;
> }
>
> +static void thermal_governor_trip_crossed(struct thermal_governor *governor,
> + struct thermal_zone_device *tz,
> + const struct thermal_trip *trip,
> + bool crossed_up)
> +{
> + if (governor->trip_crossed)
> + governor->trip_crossed(tz, trip, crossed_up);
> +}
> +
> static int thermal_trip_notify_cmp(void *ascending, const struct list_head *a,
> const struct list_head *b)
> {
> @@ -489,16 +498,14 @@ void __thermal_zone_device_update(struct
> list_for_each_entry(td, &way_up_list, notify_list_node) {
> thermal_notify_tz_trip_up(tz, &td->trip);
> thermal_debug_tz_trip_up(tz, &td->trip);
> - if (governor->trip_crossed)
> - governor->trip_crossed(tz, &td->trip, true);
> + thermal_governor_trip_crossed(governor, tz, &td->trip, true);
> }
>
> list_sort(NULL, &way_down_list, thermal_trip_notify_cmp);
> list_for_each_entry(td, &way_down_list, notify_list_node) {
> thermal_notify_tz_trip_down(tz, &td->trip);
> thermal_debug_tz_trip_down(tz, &td->trip);
> - if (governor->trip_crossed)
> - governor->trip_crossed(tz, &td->trip, false);
> + thermal_governor_trip_crossed(governor, tz, &td->trip, false);
> }
>
> if (governor->manage)
>
>
>
Good suggestion from Daniel. That code would probably be inlined anyway
by most of compilers today, so no harm & LGTM.
Reviewed-by: Lukasz Luba <lukasz.luba@arm.com>
prev parent reply other threads:[~2024-04-24 7:26 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-04-23 19:01 Rafael J. Wysocki
2024-04-24 7:26 ` Lukasz Luba [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1016c73b-9bcb-49b8-85a6-854476681558@arm.com \
--to=lukasz.luba@arm.com \
--cc=daniel.lezcano@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=rafael@kernel.org \
--cc=rjw@rjwysocki.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®