mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: Mika Westerberg <mika.westerberg@linux.intel.com>
Cc: Linus Walleij <linus.walleij@linaro.org>,
	Alexandre Courbot <gnurou@gmail.com>,
	Lan Tianyu <tianyu.lan@intel.com>, Lv Zheng <lv.zheng@intel.com>,
	Alan Cox <alan.cox@intel.com>,
	Mathias Nyman <mathias.nyman@linux.intel.com>,
	linux-acpi@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 3/6] gpio / ACPI: Rename acpi_gpio_evt_pin to acpi_gpio_event
Date: Tue, 25 Feb 2014 15:23:51 +0100	[thread overview]
Message-ID: <10661491.9ZT613bo8E@vostro.rjw.lan> (raw)
In-Reply-To: <1393257611-18031-4-git-send-email-mika.westerberg@linux.intel.com>

On Monday, February 24, 2014 06:00:08 PM Mika Westerberg wrote:
> In order to consolidate _Exx, _Lxx and _EVT to use the same structure we
> make the structure name reflect that we are dealing with any event, not
> just _EVT.

It's just a rename, right?  Then please say in the changelog that no functional
changes should result from this.

> Signed-off-by: Mika Westerberg <mika.westerberg@linux.intel.com>
> ---
>  drivers/gpio/gpiolib-acpi.c | 56 ++++++++++++++++++++++-----------------------
>  1 file changed, 28 insertions(+), 28 deletions(-)
> 
> diff --git a/drivers/gpio/gpiolib-acpi.c b/drivers/gpio/gpiolib-acpi.c
> index 5f5f107c2099..cb99dc2c552e 100644
> --- a/drivers/gpio/gpiolib-acpi.c
> +++ b/drivers/gpio/gpiolib-acpi.c
> @@ -19,7 +19,7 @@
>  
>  #include "gpiolib.h"
>  
> -struct acpi_gpio_evt_pin {
> +struct acpi_gpio_event {
>  	struct list_head node;
>  	acpi_handle *evt_handle;
>  	unsigned int pin;
> @@ -28,7 +28,7 @@ struct acpi_gpio_evt_pin {
>  
>  struct acpi_gpio_chip {
>  	struct gpio_chip *chip;
> -	struct list_head *evt_pins;
> +	struct list_head *events;
>  };
>  
>  static int acpi_gpiochip_find(struct gpio_chip *gc, void *data)
> @@ -79,9 +79,9 @@ static irqreturn_t acpi_gpio_irq_handler(int irq, void *data)
>  
>  static irqreturn_t acpi_gpio_irq_handler_evt(int irq, void *data)
>  {
> -	struct acpi_gpio_evt_pin *evt_pin = data;
> +	struct acpi_gpio_event *event = data;
>  
> -	acpi_execute_simple_method(evt_pin->evt_handle, NULL, evt_pin->pin);
> +	acpi_execute_simple_method(event->evt_handle, NULL, event->pin);
>  
>  	return IRQ_HANDLED;
>  }
> @@ -107,7 +107,7 @@ static void acpi_gpiochip_request_interrupts(struct acpi_gpio_chip *achip)
>  	struct gpio_chip *chip = achip->chip;
>  	struct acpi_resource *res;
>  	acpi_handle handle, evt_handle;
> -	struct list_head *evt_pins = NULL;
> +	struct list_head *events = NULL;
>  	acpi_status status;
>  	unsigned int pin;
>  	int irq, ret;
> @@ -126,10 +126,10 @@ static void acpi_gpiochip_request_interrupts(struct acpi_gpio_chip *achip)
>  
>  	status = acpi_get_handle(handle, "_EVT", &evt_handle);
>  	if (ACPI_SUCCESS(status)) {
> -		evt_pins = kzalloc(sizeof(*evt_pins), GFP_KERNEL);
> -		if (evt_pins) {
> -			INIT_LIST_HEAD(evt_pins);
> -			achip->evt_pins = evt_pins;
> +		events = kzalloc(sizeof(*events), GFP_KERNEL);
> +		if (events) {
> +			INIT_LIST_HEAD(events);
> +			achip->events = events;
>  		}
>  	}
>  
> @@ -168,19 +168,19 @@ static void acpi_gpiochip_request_interrupts(struct acpi_gpio_chip *achip)
>  				data = ev_handle;
>  			}
>  		}
> -		if (!handler && evt_pins) {
> -			struct acpi_gpio_evt_pin *evt_pin;
> +		if (!handler && events) {
> +			struct acpi_gpio_event *event;
>  
> -			evt_pin = kzalloc(sizeof(*evt_pin), GFP_KERNEL);
> -			if (!evt_pin)
> +			event = kzalloc(sizeof(*event), GFP_KERNEL);
> +			if (!event)
>  				continue;
>  
> -			list_add_tail(&evt_pin->node, evt_pins);
> -			evt_pin->evt_handle = evt_handle;
> -			evt_pin->pin = pin;
> -			evt_pin->irq = irq;
> +			list_add_tail(&event->node, events);
> +			event->evt_handle = evt_handle;
> +			event->pin = pin;
> +			event->irq = irq;
>  			handler = acpi_gpio_irq_handler_evt;
> -			data = evt_pin;
> +			data = event;
>  		}
>  		if (!handler)
>  			continue;
> @@ -207,23 +207,23 @@ static void acpi_gpiochip_request_interrupts(struct acpi_gpio_chip *achip)
>   */
>  static void acpi_gpiochip_free_interrupts(struct acpi_gpio_chip *achip)
>  {
> -	struct list_head *evt_pins;
> -	struct acpi_gpio_evt_pin *evt_pin, *ep;
> +	struct list_head *events;
> +	struct acpi_gpio_event *event, *ep;
>  	struct gpio_chip *chip = achip->chip;
>  
> -	if (!chip->dev || !chip->to_irq || !achip->evt_pins)
> +	if (!chip->dev || !chip->to_irq || !achip->events)
>  		return;
>  
> -	evt_pins = achip->evt_pins;
> -	achip->evt_pins = NULL;
> +	events = achip->events;
> +	achip->events = NULL;
>  
> -	list_for_each_entry_safe_reverse(evt_pin, ep, evt_pins, node) {
> -		devm_free_irq(chip->dev, evt_pin->irq, evt_pin);
> -		list_del(&evt_pin->node);
> -		kfree(evt_pin);
> +	list_for_each_entry_safe_reverse(event, ep, events, node) {
> +		devm_free_irq(chip->dev, event->irq, event);
> +		list_del(&event->node);
> +		kfree(event);
>  	}
>  
> -	kfree(evt_pins);
> +	kfree(events);
>  }
>  
>  struct acpi_gpio_lookup {
> 

-- 
I speak only for myself.
Rafael J. Wysocki, Intel Open Source Technology Center.

  reply	other threads:[~2014-02-25 14:08 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-02-24 16:00 [PATCH 0/6] gpio / ACPI: Rework ACPI GPIO events and add support for operation regions Mika Westerberg
2014-02-24 16:00 ` [PATCH 1/6] gpiolib: Allow GPIO chips to request their own GPIOs Mika Westerberg
2014-02-25 14:10   ` Rafael J. Wysocki
2014-02-26  9:05     ` Mika Westerberg
2014-02-26 13:47       ` Rafael J. Wysocki
2014-02-27  9:48         ` Mika Westerberg
2014-03-05  2:49   ` Linus Walleij
2014-03-05 12:05     ` Mika Westerberg
2014-03-05 13:07       ` Rafael J. Wysocki
2014-03-06  2:16     ` Alexandre Courbot
2014-02-24 16:00 ` [PATCH 2/6] gpio / ACPI: Allocate ACPI specific data directly in acpi_gpiochip_add() Mika Westerberg
2014-02-25 14:21   ` Rafael J. Wysocki
2014-02-26  9:08     ` Mika Westerberg
2014-02-24 16:00 ` [PATCH 3/6] gpio / ACPI: Rename acpi_gpio_evt_pin to acpi_gpio_event Mika Westerberg
2014-02-25 14:23   ` Rafael J. Wysocki [this message]
2014-02-26  9:09     ` Mika Westerberg
2014-02-24 16:00 ` [PATCH 4/6] gpio / ACPI: Embed events list directly into struct acpi_gpio_chip Mika Westerberg
2014-02-25 14:26   ` Rafael J. Wysocki
2014-02-26  9:10     ` Mika Westerberg
2014-02-24 16:00 ` [PATCH 5/6] gpio / ACPI: Rework ACPI GPIO event handling Mika Westerberg
2014-02-25 14:44   ` Rafael J. Wysocki
2014-02-26  9:10     ` Mika Westerberg
2014-02-24 16:00 ` [PATCH 6/6] gpio / ACPI: Add support for ACPI GPIO operation regions Mika Westerberg
2014-02-25 14:55   ` Rafael J. Wysocki
2014-02-26  9:11     ` Mika Westerberg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=10661491.9ZT613bo8E@vostro.rjw.lan \
    --to=rjw@rjwysocki.net \
    --cc=alan.cox@intel.com \
    --cc=gnurou@gmail.com \
    --cc=linus.walleij@linaro.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lv.zheng@intel.com \
    --cc=mathias.nyman@linux.intel.com \
    --cc=mika.westerberg@linux.intel.com \
    --cc=tianyu.lan@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®