On Mon, 2003-11-17 at 02:28, Jan-Benedict Glaw wrote: > On Sun, 2003-11-16 17:37:05 -0500, Will Dyson > wrote in message <1069022225.19499.59.camel@thalience>: > > On Sun, 2003-11-16 at 03:16, Will Dyson wrote: > > > -int match_token(char *s, match_table_t table, substring_t args[]); > > - > > +int match_token(char *, match_table_t table, substring_t args[]); > > Dropping the blank line is okay, but I don't like dropping "s" > altogether:) Well, I think it should be consistent. My original patch added "s" to all of the prototypes, on the basis that that is the name given in the function definition (and a partial misunderstanding of kernel-doc). But it was pointed out that "s" is highly uninformative as an argument name, and serves no documentation purpose. So I got rid of it, with the intention of providing another patch which changes the argument names to something better. For what it's worth, however, I didn't realize that the original match_token had the "s" when I re-diffed the patch earlier. And having the blank line does make some sense, because match_token is different from the others. Got any ideas about how to name that argument in a way that is more helpful to a developer looking to use the functions? I was thinking "char *token" for match_token (because you must tokenize the argument string before feeding each token to match_token) and "substring_t arg" for the others. Here is a(nother) rediff of the kernel-doc patch, changing no prototypes at all. And also a follow-on that renames the arguments in the manner I describe in the previous paragraph. Feel free to provide an alternate renaming patch if you've got a better idea than "token" and "arg". -- Will Dyson "Back off man, I'm a scientist!" -Dr. Peter Venkman