From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: "Xue, Ken" <Ken.Xue@amd.com>
Cc: "andy.shevchenko@gmail.com" <andy.shevchenko@gmail.com>,
"mika.westerberg@linux.intel.com"
<mika.westerberg@linux.intel.com>,
"linux-acpi@vger.kernel.org" <linux-acpi@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 1/3 V3] acpi:soc: merge common codes for creating platform device
Date: Fri, 30 Jan 2015 16:08:08 +0100 [thread overview]
Message-ID: <10727316.ODV2mHv2Vx@vostro.rjw.lan> (raw)
In-Reply-To: <4AC89B18A26BAB43B540DB1C94E2802C05AA96E0@scybexdag03.amd.com>
On Friday, January 30, 2015 07:07:14 AM Xue, Ken wrote:
> Hi Rafael,
> I looked into your patch in https://patchwork.kernel.org/patch/5677461/.
> I found that "XXX_platform_notify" should be implemented separately in LPSS and APD driver instead of "acpi_soc_platform_notify" in acpi_soc.
> Because there is WA can't be share with two drivers. And it can make LPSS or APD driver more flexible.
>
> Then only "acpi_soc_create_device" can be shared by LPSS and APD. Maybe, the meaning of acpi_soc becomes less than what we expected.
> So, can we go back to two separated drivers without any binding?
I don't want code duplication between them, though. So if there's a function
that may be shared between them, it should be shared. And so on. No duplicate
data structure definitions etc.
> And try thoughts about acpi_soc, if there were more common features.
As I said. If you can do that without code duplication, please feel free to try.
--
I speak only for myself.
Rafael J. Wysocki, Intel Open Source Technology Center.
prev parent reply other threads:[~2015-01-30 14:45 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-12-18 8:44 Ken Xue
2015-01-20 15:12 ` Rafael J. Wysocki
2015-01-21 10:09 ` Mika Westerberg
2015-01-21 10:26 ` Andy Shevchenko
2015-01-21 14:40 ` Rafael J. Wysocki
2015-01-22 22:57 ` Rafael J. Wysocki
2015-01-30 7:07 ` Xue, Ken
2015-01-30 15:08 ` Rafael J. Wysocki [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=10727316.ODV2mHv2Vx@vostro.rjw.lan \
--to=rjw@rjwysocki.net \
--cc=Ken.Xue@amd.com \
--cc=andy.shevchenko@gmail.com \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mika.westerberg@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®