From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751696AbdALNPT (ORCPT ); Thu, 12 Jan 2017 08:15:19 -0500 Received: from mout.kundenserver.de ([212.227.17.13]:51494 "EHLO mout.kundenserver.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751504AbdALNPN (ORCPT ); Thu, 12 Jan 2017 08:15:13 -0500 From: Arnd Bergmann To: David Howells Cc: linux-kernel@vger.kernel.org, ruchandani.tina@gmail.com, linux-afs@lists.infradead.org Subject: Re: [PATCH 1/2] afs: Move UUID struct to linux/uuid.h Date: Thu, 12 Jan 2017 14:14:35 +0100 Message-ID: <107420020.65PPp1ZfLz@wuerfel> User-Agent: KMail/5.1.3 (Linux/4.4.0-34-generic; KDE/5.18.0; x86_64; ; ) In-Reply-To: <148422219487.9419.2588525606361566422.stgit@warthog.procyon.org.uk> References: <148422219487.9419.2588525606361566422.stgit@warthog.procyon.org.uk> MIME-Version: 1.0 Content-Transfer-Encoding: 7Bit Content-Type: text/plain; charset="us-ascii" X-Provags-ID: V03:K0:P/tHtxj2ApAw36p4cCHYfKw/9YzhmJyIKVOhvu6YOY04LPAl+30 SUfrc+OiuA171J+XiYL4yKegTydDI/cukF6sDMptxH3tzM7bhPsB2ht7zaurP14YL9o/h9g M2yC2jaGfSsFPdIo9jCxSu152myD+LGDIA5Kro4YKOYgHxWTpMdnt0Pw4lCNdrQT2Sj6MGl YudFSol6ArgV98JGy1dOw== X-UI-Out-Filterresults: notjunk:1;V01:K0:vy2S8WbnBpw=:7v9w95HohGr7Jl9axHQ36l ZxPVqU02wqKJHzrunB0VXGNWOnqc0lBNCXR547EwWB93KIuIsRfW2oUW3/yH8F3pHPbvyp2R/ cCRGU7BL3isfgZ5FBEJ0OwVemZ6DfBXMNyIQSdqikBaTvM/lYeHyb3Wc7j1PMfxQ1Z01lytY8 nihwGdUN+WOxyXk6pBssiKZqaUKzmFDEhx+4zbwh7BiDd0uA8KHU0IZSNjIzwIwSdGcAZ1Pxk df1a20+b9/z1xJh3za1XHCTcAS0bNxC6Iybz3qVw7FstECSzeO+SuL9dMqCYrKjcaQU+GWNaq ALfZ2lSMl+gDlqa9y9VNQ3gfr5EVy/19ZsOBYoEiJ8ckEShe+DvKOThSaQPaivcPXpZBHYhz4 gHv5zlG4sWWSkY2dROcz6bvnntIkz+A+SS/xoXuLAXQyJT3MAo2JDP43bZygEP/lzGnvHLf38 uNIHO+VhvA2aERcmfXOlKx8vcyubgXgPnkUxwITxNXtMxqnd5eSqH/YGxtsUQZa5lG4p/kfZl bqEOCKyt4TnHsgmNC8DvmATDEVj41j3134UyhQPtvA+yR3RBtrcgfEjFn5OJOOZWlyogcfdnB 90OFvncRzX/G1OhevKCpkJvUQzPS1wmISSxyNeoKismkxBM6QjkO7D7jNjWr03sSukqdskK7D vJefKxZVms7BWI3FJn2uiR2ilWVP2PhgOSDrV4q9CUGIkZoRLPNonKbq3trUrUGfZhumy0T68 GyMWGghqZOE3mSLh Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thursday, January 12, 2017 11:56:34 AM CET David Howells wrote: > Move the afs_uuid struct to linux/uuid.h and rename it to uuid_v1. > > Signed-off-by: David Howells > Looks good to me, but I wonder if this part: r = call->request; - r->time_low = ntohl(b[0]); - r->time_mid = ntohl(b[1]); - r->time_hi_and_version = ntohl(b[2]); + r->time_low = b[0]; + r->time_mid = htons(ntohl(b[1])); + r->time_hi_and_version = htons(ntohl(b[2])); r->clock_seq_hi_and_reserved = ntohl(b[3]); r->clock_seq_low = ntohl(b[4]); should be considered a bugfix and split out into a separate patch. From what I understand about the mess in UUID formats, the time fields can either be big-endian (as defined) or little-endian (for all things Microsoft), and you are changing the representation from CPU-specific to big-endian, which makes it different for x86 and most ARM at least. Arnd