From: "J.A. Magallon" <jamagallon@able.es>
To: Matt Mackall <mpm@selenic.com>
Cc: Chris Wedgwood <cw@f00f.org>, Jens Axboe <axboe@suse.de>,
Jeff Garzik <jgarzik@pobox.com>,
LKML <linux-kernel@vger.kernel.org>,
Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>
Subject: Re: [PATCH] Rename SECTOR_SIZE to BIO_SECTOR_SIZE
Date: Wed, 27 Oct 2004 20:45:24 +0000 [thread overview]
Message-ID: <1098909924l.12725l.0l@werewolf.able.es> (raw)
In-Reply-To: <20041027202733.GG28904@waste.org> (from mpm@selenic.com on Wed Oct 27 22:27:33 2004)
On 2004.10.27, Matt Mackall wrote:
> On Wed, Oct 27, 2004 at 12:05:23PM -0700, Chris Wedgwood wrote:
> > Rename (one of the uses of) SECTOR_SIZE to BIO_SECTOR_SIZE which is
> > more appropriate.
>
> > Index: cw-current/include/linux/ide.h
> > ===================================================================
> > --- cw-current.orig/include/linux/ide.h 2004-10-27 11:33:06.237319044 -0700
> > +++ cw-current/include/linux/ide.h 2004-10-27 11:35:13.246711414 -0700
> > @@ -202,8 +202,8 @@
> > #define PARTN_BITS 6 /* number of minor dev bits for partitions */
> > #define PARTN_MASK ((1<<PARTN_BITS)-1) /* a useful bit mask */
> > #define MAX_DRIVES 2 /* per interface; 2 assumed by lots of code */
> > -#define SECTOR_SIZE 512
> > -#define SECTOR_WORDS (SECTOR_SIZE / 4) /* number of 32bit words per sector */
> > +#define BIO_SECTOR_SIZE 512
> > +#define SECTOR_WORDS (BIO_SECTOR_SIZE / 4) /* number of 32bit words per sector */
> > #define IDE_LARGE_SEEK(b1,b2,t) (((b1) > (b2) + (t)) || ((b2) > (b1) + (t)))
>
> So shouldn't this be in bio.h now?
>
And for uniformity, SECTOR_WORDS -> BIO_SECTOR_WORDS ?
--
J.A. Magallon <jamagallon()able!es> \ Software is like sex:
werewolf!able!es \ It's better when it's free
Mandrakelinux release 10.1 (Community) for i586
Linux 2.6.9-jam1 (gcc 3.4.1 (Mandrakelinux 10.1 3.4.1-4mdk)) #6
prev parent reply other threads:[~2004-10-27 23:32 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2004-10-27 6:08 [RFC] Rename SECTOR_SIZE to IDE_SECTOR_SIZE Chris Wedgwood
2004-10-27 6:47 ` Jeff Garzik
2004-10-27 6:55 ` Chris Wedgwood
2004-10-27 7:22 ` Jens Axboe
2004-10-27 19:05 ` [PATCH] Rename SECTOR_SIZE to BIO_SECTOR_SIZE Chris Wedgwood
2004-10-27 20:27 ` Matt Mackall
2004-10-27 20:29 ` Chris Wedgwood
2004-10-27 20:36 ` Bartlomiej Zolnierkiewicz
2004-10-27 20:45 ` J.A. Magallon [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1098909924l.12725l.0l@werewolf.able.es \
--to=jamagallon@able.es \
--cc=axboe@suse.de \
--cc=bzolnier@gmail.com \
--cc=cw@f00f.org \
--cc=jgarzik@pobox.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mpm@selenic.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®