From: "Huang, Kai" <kai.huang@intel.com>
To: "pbonzini@redhat.com" <pbonzini@redhat.com>,
"Hunter, Adrian" <adrian.hunter@intel.com>,
"Annapurve, Vishal" <vannapurve@google.com>,
"Edgecombe, Rick P" <rick.p.edgecombe@intel.com>,
"dave.hansen@linux.intel.com" <dave.hansen@linux.intel.com>,
"seanjc@google.com" <seanjc@google.com>
Cc: "kvm@vger.kernel.org" <kvm@vger.kernel.org>,
"Li, Xiaoyao" <xiaoyao.li@intel.com>,
"Luck, Tony" <tony.luck@intel.com>,
"Zhao, Yan Y" <yan.y.zhao@intel.com>,
"kas@kernel.org" <kas@kernel.org>,
"Chatre, Reinette" <reinette.chatre@intel.com>,
"binbin.wu@linux.intel.com" <binbin.wu@linux.intel.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"mingo@redhat.com" <mingo@redhat.com>,
"Yamahata, Isaku" <isaku.yamahata@intel.com>,
"tony.lindgren@linux.intel.com" <tony.lindgren@linux.intel.com>,
"tglx@linutronix.de" <tglx@linutronix.de>,
"hpa@zytor.com" <hpa@zytor.com>, "Gao, Chao" <chao.gao@intel.com>,
"bp@alien8.de" <bp@alien8.de>, "x86@kernel.org" <x86@kernel.org>
Subject: Re: [PATCH V4 1/2] x86/tdx: Eliminate duplicate code in tdx_clear_page()
Date: Wed, 23 Jul 2025 23:01:09 +0000 [thread overview]
Message-ID: <10af9524189d42d633b260547857516b49f9dc8e.camel@intel.com> (raw)
In-Reply-To: <7e54649c-7eb2-444f-849b-7ced20a5bb05@intel.com>
On Wed, 2025-07-23 at 18:30 +0300, Hunter, Adrian wrote:
> On 23/07/2025 17:44, Edgecombe, Rick P wrote:
> > On Wed, 2025-07-23 at 17:37 +0300, Adrian Hunter wrote:
> > > > The latter seems better to me for the sake of less churn.
> > >
> > > Why make tdx_quirk_reset_page() and tdx_quirk_reset_paddr() follow
> > > different rules.
> > >
> > > How about this:
> > >
> > > From: Adrian Hunter <adrian.hunter@intel.com>
> > > Subject: [PATCH] x86/tdx: Tidy reset_pamt functions
> > >
> > > Rename reset_pamt functions to contain "quirk" to reflect the new
> > > functionality, and remove the now misleading comment.
> >
> > This looks like the "former" option. Churn is not too bad, and it has the
> > benefit of clear code vs long comment. I'm ok either way. But it needs to go
> > cleanup first in the patch order.
> >
> > The log should explain why it's ok to change now, with respect to the reasoning
> > in the comment that is being removed.
>
> It makes more sense afterwards because then it can refer to the
> functional change:
>
> From: Adrian Hunter <adrian.hunter@intel.com>
> Subject: [PATCH] x86/tdx: Tidy reset_pamt functions
>
> tdx_quirk_reset_paddr() has been made to reflect that, in fact, the
> clearing is necessary only for hardware with a certain quirk. Refer
> patch "x86/tdx: Skip clearing reclaimed pages unless X86_BUG_TDX_PW_MCE
> is present" for details.
>
> Rename reset_pamt functions to contain "quirk" to reflect the new
> functionality, and remove the now misleading comment.
>
> Signed-off-by: Adrian Hunter <adrian.hunter@intel.com>
> ---
> arch/x86/virt/vmx/tdx/tdx.c | 16 ++++------------
> 1 file changed, 4 insertions(+), 12 deletions(-)
>
> diff --git a/arch/x86/virt/vmx/tdx/tdx.c b/arch/x86/virt/vmx/tdx/tdx.c
> index ef22fc2b9af0..823850399bb7 100644
> --- a/arch/x86/virt/vmx/tdx/tdx.c
> +++ b/arch/x86/virt/vmx/tdx/tdx.c
> @@ -664,17 +664,17 @@ void tdx_quirk_reset_page(struct page *page)
> }
> EXPORT_SYMBOL_GPL(tdx_quirk_reset_page);
>
> -static void tdmr_reset_pamt(struct tdmr_info *tdmr)
> +static void tdmr_quirk_reset_pamt(struct tdmr_info *tdmr)
> {
> tdmr_do_pamt_func(tdmr, tdx_quirk_reset_paddr);
> }
>
> -static void tdmrs_reset_pamt_all(struct tdmr_info_list *tdmr_list)
> +static void tdmrs_quirk_reset_pamt_all(struct tdmr_info_list *tdmr_list)
> {
> int i;
>
> for (i = 0; i < tdmr_list->nr_consumed_tdmrs; i++)
> - tdmr_reset_pamt(tdmr_entry(tdmr_list, i));
> + tdmr_quirk_reset_pamt(tdmr_entry(tdmr_list, i));
> }
>
> static unsigned long tdmrs_count_pamt_kb(struct tdmr_info_list *tdmr_list)
> @@ -1146,15 +1146,7 @@ static int init_tdx_module(void)
> * to the kernel.
> */
> wbinvd_on_all_cpus();
> - /*
> - * According to the TDX hardware spec, if the platform
> - * doesn't have the "partial write machine check"
> - * erratum, any kernel read/write will never cause #MC
> - * in kernel space, thus it's OK to not convert PAMTs
> - * back to normal. But do the conversion anyway here
> - * as suggested by the TDX spec.
> - */
> - tdmrs_reset_pamt_all(&tdx_tdmr_list);
> + tdmrs_quirk_reset_pamt_all(&tdx_tdmr_list);
> err_free_pamts:
> tdmrs_free_pamt_all(&tdx_tdmr_list);
> err_free_tdmrs:
> --
> 2.48.1
Such renaming goes a little bit far IMHO. I respect the value of having
"quirk" in the name, but it also seems quite reasonable to me to hide such
"quirk" at the last level but just having "reset TDX pages" concept in the
higher levels.
E.g.,:
static void tdx_quirk_reset_paddr(unsigned long base, unsigned long size)
{
/* doing MOVDIR64B ... */
}
static void tdx_reset_paddr(unsigned long base, unsigned long size)
{
if (!boot_cpu_has_bug(X86_BUG_TDX_PW_MCE))
return;
tdx_quirk_reset_paddr(base, size);
}
void tdx_reset_page(struct page *page)
{
tdx_reset_paddr(page_to_phys(page), PAGE_SIZE);
}
EXPORT_SYMBOL_GPL(tdx_reset_page);
next prev parent reply other threads:[~2025-07-23 23:01 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-23 12:05 [PATCH V4 0/2] x86/tdx: Skip clearing reclaimed pages unless X86_BUG_TDX_PW_MCE is present Adrian Hunter
2025-07-23 12:05 ` [PATCH V4 1/2] x86/tdx: Eliminate duplicate code in tdx_clear_page() Adrian Hunter
2025-07-23 14:06 ` Edgecombe, Rick P
2025-07-23 14:37 ` Adrian Hunter
2025-07-23 14:44 ` Edgecombe, Rick P
2025-07-23 15:30 ` Adrian Hunter
2025-07-23 15:33 ` Edgecombe, Rick P
2025-07-23 15:41 ` Adrian Hunter
2025-07-23 16:03 ` Edgecombe, Rick P
2025-07-23 23:01 ` Huang, Kai [this message]
2025-07-23 23:26 ` Edgecombe, Rick P
2025-07-23 23:56 ` Huang, Kai
2025-07-23 15:57 ` Sean Christopherson
2025-07-23 12:05 ` [PATCH V4 2/2] x86/tdx: Skip clearing reclaimed pages unless X86_BUG_TDX_PW_MCE is present Adrian Hunter
2025-07-23 12:31 ` Xiaoyao Li
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=10af9524189d42d633b260547857516b49f9dc8e.camel@intel.com \
--to=kai.huang@intel.com \
--cc=adrian.hunter@intel.com \
--cc=binbin.wu@linux.intel.com \
--cc=bp@alien8.de \
--cc=chao.gao@intel.com \
--cc=dave.hansen@linux.intel.com \
--cc=hpa@zytor.com \
--cc=isaku.yamahata@intel.com \
--cc=kas@kernel.org \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=pbonzini@redhat.com \
--cc=reinette.chatre@intel.com \
--cc=rick.p.edgecombe@intel.com \
--cc=seanjc@google.com \
--cc=tglx@linutronix.de \
--cc=tony.lindgren@linux.intel.com \
--cc=tony.luck@intel.com \
--cc=vannapurve@google.com \
--cc=x86@kernel.org \
--cc=xiaoyao.li@intel.com \
--cc=yan.y.zhao@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®