From: Steven Rostedt <rostedt@goodmis.org>
To: Ingo Molnar <mingo@elte.hu>
Cc: linux-kernel@vger.kernel.org,
Arjan van de Ven <arjanv@infradead.org>,
Andrew Morton <akpm@osdl.org>
Subject: Re: [patch] smp_processor_id() cleanup, 2.6.12-rc5
Date: Thu, 26 May 2005 09:16:14 -0400 [thread overview]
Message-ID: <1117113374.4313.6.camel@localhost.localdomain> (raw)
In-Reply-To: <20050526104449.GA14289@elte.hu>
On Thu, 2005-05-26 at 12:44 +0200, Ingo Molnar wrote:
> this patch implements a number of smp_processor_id() cleanup ideas that
> Arjan van de Ven and i came up with.
>
> the previous __smp_processor_id/_smp_processor_id/smp_processor_id API
> spaghetti was hard to follow both on the implementational and on the
> usage side.
>
> some of the complexity arose from picking wrong names, some of the
> complexity comes from the fact that not all architectures defined
> __smp_processor_id.
>
> in the new code, there are two externally visible symbols:
>
> - smp_processor_id(): debug variant.
>
> - raw_smp_processor_id(): nondebug variant. Replaces all existing
> uses of _smp_processor_id() and __smp_processor_id(). Defined
> by every SMP architecture in include/asm-*/smp.h.
>
> there is one new internal symbol, dependent on DEBUG_PREEMPT:
>
> - debug_smp_processor_id(): internal debug variant, mapped to
> smp_processor_id().
>
> also, i moved debug_smp_processor_id() from lib/kernel_lock.c into a new
> lib/smp_processor_id.c file. All related comments got updated and/or
> clarified.
Let me be the first to say "Thank you Ingo! (and Arjan)". God, the fun
I had with _?_?smp_processor_id. The first time I got the bug message I
was "WTF", and then to figure out if I should use the _ or __ version.
I hope your patch gets in so that this will be much cleared up, and put
my effort in learning the difference between them all in vain.
I guess I should download the latest kernel and try it out.
Thanks again,
-- Steve
next prev parent reply other threads:[~2005-05-26 13:17 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2005-05-26 10:44 Ingo Molnar
2005-05-26 13:16 ` Steven Rostedt [this message]
2005-05-26 23:47 ` Matthew Dobson
2005-05-27 12:35 ` [patch] smp_processor_id() cleanup fix, 2.6.12-rc5 Ingo Molnar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1117113374.4313.6.camel@localhost.localdomain \
--to=rostedt@goodmis.org \
--cc=akpm@osdl.org \
--cc=arjanv@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®