From: Matthew Gilbert <mgilbert@mvista.com>
To: Kumar Gala <kumar.gala@freescale.com>
Cc: Adam Belay <ambx1@neo.rr.com>, Greg KH <greg@kroah.com>,
rmk@arm.linux.org.uk, linux-kernel@vger.kernel.org,
Andrew Morton <akpm@osdl.org>,
Patrick Mochel <mochel@digitalimplant.org>
Subject: Re: [PATCH] Custom IORESOURCE Class
Date: Tue, 09 Aug 2005 16:24:39 -0700 [thread overview]
Message-ID: <1123629879.7951.66.camel@localhost.localdomain> (raw)
In-Reply-To: <7A8D4849-AE31-4F22-BA00-6C2B66CC833D@freescale.com>
On Mon, 2005-08-08 at 23:23 -0500, Kumar Gala wrote:
> On Aug 8, 2005, at 6:17 PM, Adam Belay wrote:
>
> > On Mon, Aug 08, 2005 at 09:00:21AM -0700, Greg KH wrote:
> >
> >> On Mon, Aug 08, 2005 at 11:11:45AM -0700, Matthew Gilbert wrote:
> >>
> >>> Below is a patch that adds an additional resource class to the
> >>>
> > platform
> >
> >>> resource types. This is to support additional resources that need to
> >>>
> > be passed
> >
> >>> to drivers without overloading the existing specific types. In my
> >>>
> > case, I need
> >
> >>> to send clock information to the driver to enable power management.
> >>>
> >>> Signed-off-by: Matthew Gilbert <mgilbert@mvista.com>
> >>>
> >>
> >> Hm, you do realize that Pat's no longer the driver core maintainer?
> >>
> > :)
> >
> >>
> >> Anyway, Russell and Adam, any objections to this patch?
> >>
> >
> > I'm not sure if I agree with this patch. "struct resource" is used
> > primarily for
> > I/O resource assignment. Although I agree we may need to add new
> > IORESOURCE types,
> > I'm not sure if clock data belongs here. I don't think "start" and
> > "end" would be
> > useful for most platform data. Could you provide more information
> > about
> > this
> > specific issue and resource type? Maybe we could create a new sysfs
> > attribute?
>
> I would also like to understand more about what the need is here. We
> have clock data and such but use platform_data for it.
I am using IORESOURCE_MEM to pass in the base addresses of the necessary
clock registers. I also need to pass a fractional divider clk id. The
resource table seemed appropriate because the base addresses and the
divider id are closely related. Its also a great framework for enabling
varying resource lists. Currently I don't use this, but in the future I
may. Its possible in a future board revision there may not be a
fractional divider available. The resource framework makes querying for
the clk id very straight forward as opposed to magic values in a struct
I pass through platform_data.
It can easily be moved to platform_data (or split between the two) if
that is more appropriate. Thanks for the feedback. _matt
prev parent reply other threads:[~2005-08-09 23:24 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2005-08-08 18:11 Matthew Gilbert
2005-08-08 16:00 ` Greg KH
2005-08-08 23:17 ` Adam Belay
2005-08-09 4:23 ` Kumar Gala
2005-08-09 23:24 ` Matthew Gilbert [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1123629879.7951.66.camel@localhost.localdomain \
--to=mgilbert@mvista.com \
--cc=akpm@osdl.org \
--cc=ambx1@neo.rr.com \
--cc=greg@kroah.com \
--cc=kumar.gala@freescale.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mochel@digitalimplant.org \
--cc=rmk@arm.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®