From: Arjan van de Ven <arjan@infradead.org>
To: Dave Airlie <airlied@linux.ie>
Cc: Alexey Dobriyan <adobriyan@gmail.com>,
Michael Veeck <michael.veeck@gmx.net>,
dri-devel@lists.sourceforge.net, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] Remove DRM_ARRAY_SIZE
Date: Sun, 25 Sep 2005 10:20:21 +0200 [thread overview]
Message-ID: <1127636422.16288.1.camel@laptopd505.fenrus.org> (raw)
In-Reply-To: <Pine.LNX.4.58.0509250054190.24532@skynet>
On Sun, 2005-09-25 at 00:56 +0100, Dave Airlie wrote:
> >
> > drivers/char/drm/drmP.h defines a macro DRM_ARRAY_SIZE(x) for
> > determining the size of an array. kernel.h already provides one.
> >
> > Signed-off-by: Alexey Dobriyan <adobriyan@gmail.com>
>
> Nak.
>
> We have DRM_ for cross platform reasons in DRM, I could in theory get rid
> of all of them in the kernel, but it would make the merging of code from
> DRM CVS even more of a nightmare,
ok so this brings the question: how does naming it DRM_ARRAY_SIZE make
it more portable than naming it ARRAY_SIZE?
If *BSD doesn't have ARRAY_SIZE, then surely naming it ARRAY_SIZE is
easy for them to provide (after all they need to provide it already just
called DRM_ARRAY_SIZE); if they have ARRAY_SIZE... then I assume it has
the exact same semantics....
next prev parent reply other threads:[~2005-09-25 8:20 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2005-09-24 21:11 Alexey Dobriyan
2005-09-24 23:56 ` Dave Airlie
2005-09-25 8:20 ` Arjan van de Ven [this message]
2005-09-25 8:30 ` Dave Airlie
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1127636422.16288.1.camel@laptopd505.fenrus.org \
--to=arjan@infradead.org \
--cc=adobriyan@gmail.com \
--cc=airlied@linux.ie \
--cc=dri-devel@lists.sourceforge.net \
--cc=linux-kernel@vger.kernel.org \
--cc=michael.veeck@gmx.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®