From: Thomas Gleixner <tglx@linutronix.de>
To: linux-kernel@vger.kernel.org
Cc: akpm@osdl.org, mingo@elte.hu, zippel@linux-m68k.org,
george@mvista.com, johnstul@us.ibm.com
Subject: [patch 38/43] rename add_ktimeout() to ktimeout_add()
Date: Thu, 01 Dec 2005 01:04:20 +0100 [thread overview]
Message-ID: <1133395460.32542.482.camel@tglx.tec.linutronix.de> (raw)
In-Reply-To: <20051130231140.164337000@tglx.tec.linutronix.de>
plain text document attachment (ktimeout-rename-ktimeout_add.patch)
- rename add_ktimeout() to ktimeout_add()
Signed-off-by: Ingo Molnar <mingo@elte.hu>
include/linux/ktimeout.h | 4 ++--
include/linux/timer.h | 2 +-
kernel/ktimeout.c | 14 +++++++-------
3 files changed, 10 insertions(+), 10 deletions(-)
Index: linux/include/linux/ktimeout.h
===================================================================
--- linux.orig/include/linux/ktimeout.h
+++ linux/include/linux/ktimeout.h
@@ -68,7 +68,7 @@ extern int ktimeout_mod(struct ktimeout
extern unsigned long ktimeout_next_interrupt(void);
/***
- * add_ktimeout - start a ktimeout
+ * ktimeout_add - start a ktimeout
* @ktimeout: the timeout to be added
*
* The kernel will do a ->function(->data) callback from the
@@ -81,7 +81,7 @@ extern unsigned long ktimeout_next_inter
* Timers with an ->expired field in the past will be executed in the next
* timeout tick.
*/
-static inline void add_ktimeout(struct ktimeout *ktimeout)
+static inline void ktimeout_add(struct ktimeout *ktimeout)
{
BUG_ON(ktimeout_pending(ktimeout));
__ktimeout_mod(ktimeout, ktimeout->expires);
Index: linux/include/linux/timer.h
===================================================================
--- linux.orig/include/linux/timer.h
+++ linux/include/linux/timer.h
@@ -24,7 +24,7 @@
#define __mod_timer __ktimeout_mod
#define mod_timer ktimeout_mod
#define next_timer_interrupt ktimeout_next_interrupt
-#define add_timer add_ktimeout
+#define add_timer ktimeout_add
#define try_to_del_timer_sync try_to_del_ktimeout_sync
#define del_timer_sync del_ktimeout_sync
#define del_singleshot_timer_sync del_singleshot_ktimeout_sync
Index: linux/kernel/ktimeout.c
===================================================================
--- linux.orig/kernel/ktimeout.c
+++ linux/kernel/ktimeout.c
@@ -82,7 +82,7 @@ static inline void set_running_ktimeout(
#endif
}
-static void internal_add_ktimeout(tvec_base_t *base, struct ktimeout *ktimeout)
+static void internal_ktimeout_add(tvec_base_t *base, struct ktimeout *ktimeout)
{
unsigned long expires = ktimeout->expires;
unsigned long idx = expires - base->ktimeout_jiffies;
@@ -228,7 +228,7 @@ int __ktimeout_mod(struct ktimeout *ktim
}
ktimeout->expires = expires;
- internal_add_ktimeout(new_base, ktimeout);
+ internal_ktimeout_add(new_base, ktimeout);
spin_unlock_irqrestore(&new_base->t_base.lock, flags);
return ret;
@@ -251,7 +251,7 @@ void ktimeout_add_on(struct ktimeout *kt
BUG_ON(ktimeout_pending(ktimeout) || !ktimeout->function);
spin_lock_irqsave(&base->t_base.lock, flags);
ktimeout->base = &base->t_base;
- internal_add_ktimeout(base, ktimeout);
+ internal_ktimeout_add(base, ktimeout);
spin_unlock_irqrestore(&base->t_base.lock, flags);
}
@@ -265,11 +265,11 @@ void ktimeout_add_on(struct ktimeout *kt
*
* ktimeout_mod(ktimeout, expires) is equivalent to:
*
- * ktimeout_del(ktimeout); ktimeout->expires = expires; add_ktimeout(ktimeout);
+ * ktimeout_del(ktimeout); ktimeout->expires = expires; ktimeout_add(ktimeout);
*
* Note that if there are multiple unserialized concurrent users of the same
* timeout, then ktimeout_mod() is the only safe way to modify the interval,
- * since add_ktimeout() cannot modify an already running ktimeout.
+ * since ktimeout_add() cannot modify an already running ktimeout.
*
* The function returns whether it has modified a pending timeout or not.
* (ie. ktimeout_mod() of an inactive timeout returns 0, ktimeout_mod() of an
@@ -398,7 +398,7 @@ static int cascade(tvec_base_t *base, tv
tmp = list_entry(curr, struct ktimeout, entry);
BUG_ON(tmp->base != &base->t_base);
curr = curr->next;
- internal_add_ktimeout(base, tmp);
+ internal_ktimeout_add(base, tmp);
}
INIT_LIST_HEAD(head);
@@ -708,7 +708,7 @@ static void migrate_ktimeout(tvec_base_t
ktimeout = list_entry(head->next, struct ktimeout, entry);
detach_ktimeout(ktimeout, 0);
ktimeout->base = &new_base->t_base;
- internal_add_ktimeout(new_base, ktimeout);
+ internal_ktimeout_add(new_base, ktimeout);
}
}
--
next prev parent reply other threads:[~2005-12-01 0:01 UTC|newest]
Thread overview: 47+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20051130231140.164337000@tglx.tec.linutronix.de>
2005-12-01 0:00 ` [patch 01/43] Move div_long_long_rem out of jiffies.h Thomas Gleixner
2005-12-01 2:06 ` Adrian Bunk
2005-12-01 11:38 ` Christoph Hellwig
2005-12-01 0:02 ` [patch 02/43] Remove duplicate div_long_long_rem implementation Thomas Gleixner
2005-12-01 0:02 ` [patch 03/43] Deinline mktime and set_normalized_timespec Thomas Gleixner
2005-12-01 0:02 ` [patch 04/43] Clean up mktime and add const modifiers Thomas Gleixner
2005-12-01 0:02 ` [patch 05/43] Export deinlined mktime Thomas Gleixner
2005-12-01 0:02 ` [patch 06/43] Remove unused clock constants Thomas Gleixner
2005-12-01 0:02 ` [patch 07/43] Cleanup clock constants coding style Thomas Gleixner
2005-12-01 0:03 ` [patch 08/43] Coding style and whitespace cleanup time.h Thomas Gleixner
2005-12-01 0:03 ` [patch 09/43] Make clock selectors in posix-timers const Thomas Gleixner
2005-12-01 0:03 ` [patch 10/43] Coding style and white space cleanup posix-timer.h Thomas Gleixner
2005-12-01 0:03 ` [patch 11/43] Create timespec_valid macro Thomas Gleixner
2005-12-01 0:03 ` [patch 12/43] Check user space timespec in do_sys_settimeofday Thomas Gleixner
2005-12-01 0:03 ` [patch 13/43] Introduce nsec_t type and conversion functions Thomas Gleixner
2005-12-01 0:03 ` [patch 14/43] Introduce ktime_t time format Thomas Gleixner
2005-12-01 0:03 ` [patch 15/43] ktimer core code Thomas Gleixner
2005-12-01 0:03 ` [patch 16/43] ktimer documentation Thomas Gleixner
2005-12-01 0:03 ` [patch 17/43] Switch itimers to ktimer Thomas Gleixner
2005-12-01 0:03 ` [patch 18/43] Remove now unnecessary includes Thomas Gleixner
2005-12-01 0:03 ` [patch 19/43] Introduce ktimer_nanosleep APIs Thomas Gleixner
2005-12-01 0:03 ` [patch 20/43] Convert sys_nanosleep to ktimer_nanosleep Thomas Gleixner
2005-12-01 0:03 ` [patch 21/43] Switch clock_nanosleep to ktimer nanosleep API Thomas Gleixner
2005-12-01 0:03 ` [patch 22/43] Convert posix interval timers to use ktimers Thomas Gleixner
2005-12-01 0:03 ` [patch 23/43] Simplify ktimers rearm code Thomas Gleixner
2005-12-01 0:03 ` [patch 24/43] Split timeout code into kernel/ktimeout.c Thomas Gleixner
2005-12-01 0:03 ` [patch 25/43] Create ktimeout.h and move timer.h code into it Thomas Gleixner
2005-12-01 2:36 ` Adrian Bunk
2005-12-01 2:51 ` Ingo Molnar
2005-12-01 0:03 ` [patch 26/43] Rename struct timer_list to struct ktimeout Thomas Gleixner
2005-12-01 0:03 ` [patch 27/43] Convert timer_list users to ktimeout Thomas Gleixner
2005-12-01 0:03 ` [patch 28/43] Convert ktimeout.h and create wrappers Thomas Gleixner
2005-12-01 0:03 ` [patch 29/43] Convert ktimeout.c to ktimeout struct and APIs Thomas Gleixner
2005-12-01 0:04 ` [patch 30/43] ktimeout documentation Thomas Gleixner
2005-12-01 0:04 ` [patch 31/43] rename init_ktimeout() to ktimeout_init() Thomas Gleixner
2005-12-01 0:04 ` [patch 32/43] rename setup_ktimeout() to ktimeout_setup() Thomas Gleixner
2005-12-01 0:04 ` [patch 33/43] rename add_ktimeout_on() to ktimeout_add_on() Thomas Gleixner
2005-12-01 0:04 ` [patch 34/43] rename del_ktimeout() to ktimeout_del() Thomas Gleixner
2005-12-01 0:04 ` [patch 35/43] rename __mod_ktimeout() to __mod_ktimeout() Thomas Gleixner
2005-12-01 0:04 ` [patch 36/43] rename mod_ktimeout() to ktimeout_mod() Thomas Gleixner
2005-12-01 0:04 ` [patch 37/43] rename next_ktimeout_interrupt() to ktimeout_next_interrupt() Thomas Gleixner
2005-12-01 0:04 ` Thomas Gleixner [this message]
2005-12-01 0:04 ` [patch 39/43] rename try_to_del_ktimeout_sync() to ktimeout_try_to_del_sync() Thomas Gleixner
2005-12-01 0:04 ` [patch 40/43] rename del_ktimeout_sync() to del_ktimeout_sync() Thomas Gleixner
2005-12-01 0:04 ` [patch 41/43] rename del_singleshot_ktimeout_sync() to ktimeout_del_singleshot_sync() Thomas Gleixner
2005-12-01 0:04 ` [patch 42/43] rename TIMER_SOFTIRQ to TIMEOUT_SOFTIRQ Thomas Gleixner
2005-12-01 0:04 ` [patch 43/43] ktimeout code style cleanups Thomas Gleixner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1133395460.32542.482.camel@tglx.tec.linutronix.de \
--to=tglx@linutronix.de \
--cc=akpm@osdl.org \
--cc=george@mvista.com \
--cc=johnstul@us.ibm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=zippel@linux-m68k.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®