From: "Gustavo A. R. Silva" <gustavo@embeddedor.com>
To: Erick Archer <erick.archer@gmx.com>,
Vinod Koul <vkoul@kernel.org>,
"Gustavo A. R. Silva" <gustavoars@kernel.org>
Cc: dmaengine@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-hardening@vger.kernel.org
Subject: Re: [PATCH] dmaengine: pl08x: Use kcalloc() instead of kzalloc()
Date: Tue, 30 Jan 2024 12:33:30 -0600 [thread overview]
Message-ID: <114074ef-7021-4ca0-a5f7-b0ea37948f5d@embeddedor.com> (raw)
In-Reply-To: <20240128115236.4791-1-erick.archer@gmx.com>
On 1/28/24 05:52, Erick Archer wrote:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1].
>
> Here the multiplication is obviously safe because the "channels"
> member can only be 8 or 2. This value is set when the "vendor_data"
> structs are initialized.
>
> static struct vendor_data vendor_pl080 = {
> [...]
> .channels = 8,
> [...]
> };
>
> static struct vendor_data vendor_nomadik = {
> [...]
> .channels = 8,
> [...]
> };
>
> static struct vendor_data vendor_pl080s = {
> [...]
> .channels = 8,
> [...]
> };
>
> static struct vendor_data vendor_pl081 = {
> [...]
> .channels = 2,
> [...]
> };
>
> However, using kcalloc() is more appropriate [1] and improves
> readability. This patch has no effect on runtime behavior.
>
> Link: https://github.com/KSPP/linux/issues/162 [1]
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Signed-off-by: Erick Archer <erick.archer@gmx.com>
Reviewed-by: Gustavo A. R. Silva <gustavoars@kernel.org>
Thanks!
--
Gustavo
> ---
> drivers/dma/amba-pl08x.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/dma/amba-pl08x.c b/drivers/dma/amba-pl08x.c
> index eea8bd33b4b7..e40766108787 100644
> --- a/drivers/dma/amba-pl08x.c
> +++ b/drivers/dma/amba-pl08x.c
> @@ -2855,8 +2855,8 @@ static int pl08x_probe(struct amba_device *adev, const struct amba_id *id)
> }
>
> /* Initialize physical channels */
> - pl08x->phy_chans = kzalloc((vd->channels * sizeof(*pl08x->phy_chans)),
> - GFP_KERNEL);
> + pl08x->phy_chans = kcalloc(vd->channels, sizeof(*pl08x->phy_chans),
> + GFP_KERNEL);
> if (!pl08x->phy_chans) {
> ret = -ENOMEM;
> goto out_no_phychans;
> --
> 2.25.1
>
prev parent reply other threads:[~2024-01-30 18:33 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-01-28 11:52 Erick Archer
2024-01-30 18:33 ` Gustavo A. R. Silva [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=114074ef-7021-4ca0-a5f7-b0ea37948f5d@embeddedor.com \
--to=gustavo@embeddedor.com \
--cc=dmaengine@vger.kernel.org \
--cc=erick.archer@gmx.com \
--cc=gustavoars@kernel.org \
--cc=linux-hardening@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=vkoul@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®